PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > General PT Cruiser Discussions

PT Cruiser Forum

Advertisements
tie rod/alignment question

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 31 May 2015, 01:41 pm
Regular Cruiser
 
Join Date: Mar 2007
Location: .
Posts: 138
Default tie rod/alignment question

About two months ago I got two front tires for my 2010 Cruiser with 66,000 on the clock. They had worn unevenly. About a week later I had an alignment. The last several days there has been a noticeable shimmy when I get close to 50. Now, about two weeks ago when the car was getting state inspected I had to have a motor mount replaced as well as a tie rod end. So, my question is, do I need to have another alignment due to the tie rod replacement? My back tires are cupped and I have to get other ones this week if I can find the time. Possibly, the shimmy is coming from that.
Reply With Quote
  #2 (permalink)  
Old 31 May 2015, 01:58 pm
Handy_Cruiser's Avatar
Obsessed Cruiser
 
Join Date: Oct 2013
Location: Arkansas
Posts: 10,325
Default Re: tie rod/alignment question

Yes. If you have had a tie rod replaced, then you definitely need an alignment or at least have the alignment checked.

Also, I recommend you go some place new for the alignment. A good shop will do a pretty thorough inspection of the steering and under carriage while doing the alignment. If you picked up a shimmy right after the last alignment, either something came loose, the shop did not find an existing problem and/or they did a poor or incomplete alignment. It may not be their fault, but why take the chance?

I prefer doing most automotive work myself. But it really takes a good tech with the right equipment to do a proper alignment. And the inspection they do while the car is up on the lift is very valuable to a DIY guy since some issues are much easier to detect once the car is in the air. This is money well spent.
__________________

Last edited by Handy_Cruiser; 31 May 2015 at 02:01 pm.
Reply With Quote
  #3 (permalink)  
Old 31 May 2015, 05:52 pm
Regular Cruiser
 
Join Date: Mar 2007
Location: .
Posts: 138
Default Re: tie rod/alignment question

Actually, I think it might have been a tie rod end. If my recollection is correct, does that make any difference?
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Alignment question Shiniquiet Wheels, Tires, Suspension 6 24 Jul 2014 07:30 am
rear hatch alignment question sharpeel General PT Cruiser Discussions 1 28 Aug 2011 02:18 pm
re: Timing Belt Alignment Question SteveG22 Tech & Performance Forum 1 13 Jan 2011 02:43 pm
Alignment necessary??? Shiniquiet Wheels, Tires, Suspension 5 28 Jul 2009 05:11 am
04 PT GT Alignment Kit biggus127 Wheels, Tires, Suspension 5 24 Oct 2008 07:37 pm


All times are GMT -5. The time now is 05:49 pm.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors