PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > General PT Cruiser Discussions

PT Cruiser Forum

Advertisements
New handbrake cables fitted, still not working.

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 24 Jul 2015, 07:26 pm
whiteclaw's Avatar
Cool Cruiser
 
Join Date: Mar 2012
Location: United Kingdom
Posts: 422
Default New handbrake cables fitted, still not working.

So what could it be?

Just had 2 new handbrake cables fitted on advice from mechanic as to why it wasn't working. It worked for about a day after they replaced them, but again now, same issue as before.

Is it the rear brake drums?

I know this will come up in my MOT test soon so it has to be fixed beforehand.
__________________
Chrysler PT Cruiser 2001, Automatic, No Mods, Right hand drive. 2.0

Reply With Quote
  #2 (permalink)  
Old 24 Jul 2015, 07:50 pm
Obsessed Cruiser
 
Join Date: Aug 2014
Location: Thousand Oaks, CA
Posts: 7,161
Default Re: New handbrake cables fitted, still not working.

When the handbrake cables were replaced did you reset the handbrake mechanism?

If not I would suggest opening the 4 screws around the long console of the handbrake lever to reveal the handbrake mechanism, there are two bolts holding the lever down, easy to remove and detach the two rear cables and pull the cable fixed to lever as much as possible and then insert a lock pin or thin nail to hold the spring, and then attach the two cables back in and remove the pin, this will re-tension the spring in the lever, make sure the handbrake is bolted down when you do this, check handbrake light before reinstalling the console.
Reply With Quote
  #3 (permalink)  
Old 24 Jul 2015, 08:18 pm
whiteclaw's Avatar
Cool Cruiser
 
Join Date: Mar 2012
Location: United Kingdom
Posts: 422
Default Re: New handbrake cables fitted, still not working.

I honestly have no idea if they did. I recall a loud kind of twang sound and then handbrake didnt work too well just like before. Trouble is, mechanics now here dont do so well with cars which are not say ford or BMW lol.

Its the same issue though as before i replaced the cables making me think I never perhaps had an issue with the cables to begin with.

I guess its back to a mechanic, maybe someone else this time who may actually sort the issue.
__________________
Chrysler PT Cruiser 2001, Automatic, No Mods, Right hand drive. 2.0

Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Hydraulic Handbrake mod cruisin03pt Interior Accessories Forum 1 06 Dec 2012 10:53 am
new headunit fitted problem dave1972 Sound and Security Forum 2 04 Mar 2012 09:24 pm
Handbrake adjustment Bawsack Wheels, Tires, Suspension 8 27 May 2010 02:01 am
more led lights fitted fastdel Exterior Accessories Forum 4 31 Jan 2010 08:46 am
Who fitted 225's on stock wheels? MEXICANPT Turbo Wheels/Suspension/Handling 5 24 Dec 2003 08:24 pm


All times are GMT -5. The time now is 03:13 am.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors