PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > General PT Cruiser Discussions

PT Cruiser Forum

Advertisements
Coolant not sucked back from reservoir

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 29 Jul 2015, 11:47 am
Young Cruiser
 
Join Date: Oct 2012
Posts: 98
Default Coolant not sucked back from reservoir

So the level in the overflow tank rises slowly, and I need to manually pump it out and refill the radiator.

The radiator cap is new, and thermostat is new.

The overflow tank and the hose are checked, no leak.

What else can cause this problem?

Any suggestion is appreciated.

Thanks
Reply With Quote
  #2 (permalink)  
Old 29 Jul 2015, 09:23 pm
Busted_PT's Avatar
Obsessed Cruiser
 
Join Date: Jan 2012
Location: Beckley, W.V.
Posts: 13,886
Default Re: Coolant not sucked back from reservoir

Quote:
Originally Posted by postbeauty View Post
So the level in the overflow tank rises slowly, and I need to manually pump it out and refill the radiator.

The radiator cap is new, and thermostat is new.

The overflow tank and the hose are checked, no leak.

What else can cause this problem?

Any suggestion is appreciated.

Thanks
This hose typically does not leak in the traditional sense. You will push coolant into the tank but if the end is lose it will suck air back into radiator when cooling off. A pin hole has been known to cause this as well with this hose.
__________________

03 Dream stock___________________________ 04 Touring turbo lite stock_________ 02 Touring stock_____________________ The "Three Amigos"
__________________________________________________ __________________________________________________ ___________Performance, Body and Service, OEM

This Is my project page.
http://www.ptcruiserlinks.com/forum/...oject-1-a.html

This is a great read from one of our own! Badglas
badglas.blogspot.com
Reply With Quote
  #3 (permalink)  
Old 29 Jul 2015, 09:48 pm
Obsessed Cruiser
 
Join Date: Aug 2014
Location: Thousand Oaks, CA
Posts: 7,309
Default Re: Coolant not sucked back from reservoir

Quote:
Originally Posted by postbeauty View Post
The radiator cap is new, and thermostat is new.
'
Did you drain all the coolant when you put the new thermostat in? If you did then you need to burp the radiator so you will get most of the air out of the coolant system. Was it burped?
Reply With Quote
  #4 (permalink)  
Old 30 Jul 2015, 08:23 am
Young Cruiser
 
Join Date: Oct 2012
Posts: 98
Default Re: Coolant not sucked back from reservoir

Quote:
Originally Posted by Busted_PT View Post
This hose typically does not leak in the traditional sense. You will push coolant into the tank but if the end is lose it will suck air back into radiator when cooling off. A pin hole has been known to cause this as well with this hose.
thanks

I will try to replace the hose.

Do you know where can I purchase the hose?

usually the hose and the tank are sold together.
Reply With Quote
  #5 (permalink)  
Old 30 Jul 2015, 08:24 am
Young Cruiser
 
Join Date: Oct 2012
Posts: 98
Default Re: Coolant not sucked back from reservoir

Quote:
Originally Posted by ptcruisersteve View Post
'
Did you drain all the coolant when you put the new thermostat in? If you did then you need to burp the radiator so you will get most of the air out of the coolant system. Was it burped?

I burp the system many times.
but the air still find its way into the system
Reply With Quote
  #6 (permalink)  
Old 30 Jul 2015, 08:57 am
Busted_PT's Avatar
Obsessed Cruiser
 
Join Date: Jan 2012
Location: Beckley, W.V.
Posts: 13,886
Default Re: Coolant not sucked back from reservoir

Quote:
Originally Posted by postbeauty View Post
thanks

I will try to replace the hose.

Do you know where can I purchase the hose?

usually the hose and the tank are sold together.
Just get the right size hose at the parts store. may need to take hose with you.
__________________

03 Dream stock___________________________ 04 Touring turbo lite stock_________ 02 Touring stock_____________________ The "Three Amigos"
__________________________________________________ __________________________________________________ ___________Performance, Body and Service, OEM

This Is my project page.
http://www.ptcruiserlinks.com/forum/...oject-1-a.html

This is a great read from one of our own! Badglas
badglas.blogspot.com
Reply With Quote
  #7 (permalink)  
Old 31 Jul 2015, 01:59 am
Fresh Cruiser
 
Join Date: May 2012
Posts: 47
Default Re: Coolant not sucked back from reservoir

Quote:
Originally Posted by Busted_PT View Post
Just get the right size hose at the parts store. may need to take hose with you.
Funny as I have the same question. Problem is, the overflow hose is so tight at the filler neck that I'd have to slit it off, and I've already cut off enough slack in the past as it is... Got the length and outer diameter; it's the inner diameter I need, alas!
Reply With Quote
  #8 (permalink)  
Old 31 Jul 2015, 08:27 am
Young Cruiser
 
Join Date: Oct 2012
Posts: 98
Default Re: Coolant not sucked back from reservoir

Did you solve this problem?
Reply With Quote
  #9 (permalink)  
Old 31 Jul 2015, 01:13 pm
Busted_PT's Avatar
Obsessed Cruiser
 
Join Date: Jan 2012
Location: Beckley, W.V.
Posts: 13,886
Default Re: Coolant not sucked back from reservoir

Quote:
Originally Posted by postbeauty View Post
Did you solve this problem?
He need the inside diameter of the over flow hose.
__________________

03 Dream stock___________________________ 04 Touring turbo lite stock_________ 02 Touring stock_____________________ The "Three Amigos"
__________________________________________________ __________________________________________________ ___________Performance, Body and Service, OEM

This Is my project page.
http://www.ptcruiserlinks.com/forum/...oject-1-a.html

This is a great read from one of our own! Badglas
badglas.blogspot.com
Reply With Quote
  #10 (permalink)  
Old 02 Aug 2015, 01:47 am
Fresh Cruiser
 
Join Date: May 2012
Posts: 47
Default Re: Coolant not sucked back from reservoir

Yeah, to clarify to the OP, my coolant is coming back, but I'm putting in a new radiator and want to replace the related hoses while I'm at it... could possibly be a pinhole in there as Busted PT suggested, and gotta eliminate all the possible factors I can...

Last edited by randomzombie; 02 Aug 2015 at 01:54 am.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
GT Turbo coolant recovery reservoir littleblueGT General Turbo Discussions 1 07 Oct 2014 06:23 pm
Coolant Reservoir Cap LionPT Classifieds: Want To Buy 3 11 Jun 2014 04:43 pm
Coolant hose from reservoir Bansheelos Tech & Performance Forum 2 03 Nov 2013 03:48 am
coolant reservoir question kruzin4now Tech & Performance Forum 2 13 Oct 2010 11:05 pm
coolant reservoir question pineapple Tech & Performance Forum 13 19 Aug 2009 07:02 am


All times are GMT -5. The time now is 11:22 am.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors