PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > General PT Cruiser Discussions

PT Cruiser Forum

Advertisements
Crusie control does not turn on sometimes

 
Like Tree22Likes

Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 20 Aug 2015, 10:07 pm
wingman55's Avatar
Senior Cruiser
 
Join Date: Aug 2015
Location: Pennellville, NY
Posts: 1,615
Question Cruise control does not turn on sometimes

I just bought a 2006 Limited Edition, and I noticed that about 50% of the time, the cruise control will not turn on. It seems quite random. Otherwise it works just fine.

I have read about disconnecting the battery. Is that the best idea?

Last edited by wingman55; 21 Aug 2015 at 11:00 am.
Reply With Quote
  #2 (permalink)  
Old 20 Aug 2015, 10:30 pm
dalandon's Avatar
Cool Cruiser
 
Join Date: Sep 2014
Location: Hesperia, California
Posts: 224
Default Re: Crusie control does not turn on sometimes

does it display "cruise" above the odometer when you push the button?
__________________
2007 Pastel Yellow PT Cruiser Touring Edition Auto 4 speed, 1 of 2473
Airaid SynthaFlow Cold Air Intake 300-198
UltraGauge EM v1.2
Bridgestone Turanza Serenity Plus 195/65r15
AKA "Banana Car"

Reply With Quote
  #3 (permalink)  
Old 21 Aug 2015, 07:03 am
wingman55's Avatar
Senior Cruiser
 
Join Date: Aug 2015
Location: Pennellville, NY
Posts: 1,615
Default Re: Crusie control does not turn on sometimes

No, only when it's working, then it does. Otherwise nothing happens at all. When the word "cruise" lights up it works just fine.
Reply With Quote
  #4 (permalink)  
Old 21 Aug 2015, 07:09 am
Veteran Cruiser
 
Join Date: Aug 2015
Location: Lake Wales, FL
Posts: 4,765
Default Re: Crusie control does not turn on sometimes

Maybe you have a clockspring that needs replacing. IDK
wingman55 likes this.
__________________


Aspire to inspire before you expire.
Reply With Quote
  #5 (permalink)  
Old 21 Aug 2015, 08:36 am
ptprice's Avatar
Dedicated Cruiser
 
Join Date: Nov 2012
Location: Ormond Beach, Fl. 32174
Posts: 2,163
Default Re: Crusie control does not turn on sometimes

Check the electric plug going into the cruise control unit for proper seating and that the plug lock is set correctly. That's all that was the matter with mine.
Additionally, if you can visually compare the plug on your CC unit with another PT's this'll be a good guide to getting it right! Good luck. Happy PTin' ptprice
wingman55 likes this.
Reply With Quote
  #6 (permalink)  
Old 21 Aug 2015, 11:03 am
wingman55's Avatar
Senior Cruiser
 
Join Date: Aug 2015
Location: Pennellville, NY
Posts: 1,615
Default Re: Cruise control does not turn on sometimes

OK, well I have a set of Field Service Manuals on the way. Should be here soon.

When you say the connector on the Cruise Control, do you mean the under hood vacuum servo? Or is there a 'black box' somewhere that has some connectors on it?

I took a look at the vacuum servo, but did not actually remove and re-set the connector. I will give that a try.
Reply With Quote
  #7 (permalink)  
Old 21 Aug 2015, 11:05 am
LionPT's Avatar
Veteran Cruiser
 
Join Date: May 2014
Location: Central Florida
Posts: 4,344
Default Re: Crusie control does not turn on sometimes

Quote:
Originally Posted by wingman55 View Post
OK, well I have a set of Field Service Manuals on the way. Should be here soon.

When you say the connector on the Cruise Control, do you mean the under hood vacuum servo? Or is there a 'black box' somewhere that has some connectors on it?

I took a look at the vacuum servo, but did not actually remove and re-set the connector. I will give that a try.

There is a black box under the passenger side wheel well that has some connections.
__________________

2006 Touring Edition in Cool Vanilla...aka/Ghost
Reply With Quote
  #8 (permalink)  
Old 21 Aug 2015, 11:51 am
wingman55's Avatar
Senior Cruiser
 
Join Date: Aug 2015
Location: Pennellville, NY
Posts: 1,615
Default Re: Cruise control does not turn on sometimes

OK, thanks, I'll check it out.
Reply With Quote
  #9 (permalink)  
Old 23 Aug 2015, 09:59 pm
wingman55's Avatar
Senior Cruiser
 
Join Date: Aug 2015
Location: Pennellville, NY
Posts: 1,615
Question Re: Cruise control does not turn on sometimes

OK, I am not sure what black box you are speaking of under the passenger side wheel well? From what the manual shows the Speed Control is connected to the PCM (on the firewall) and there is a Speed Sensor. (I have not figured out where the Speed Sensor is yet.) There is a connection on the Vacuum Servo (which looks OK - but I have not removed it and re-seated it yet). The only other connection is inside the steering wheel.

Can you be more specific about what you mean? (Sorry, the vehicle is new to me and I am learning.)

Thanks for your help.
Reply With Quote
  #10 (permalink)  
Old 23 Aug 2015, 10:28 pm
dalandon's Avatar
Cool Cruiser
 
Join Date: Sep 2014
Location: Hesperia, California
Posts: 224
Default Re: Cruise control does not turn on sometimes

Quote:
Originally Posted by wingman55 View Post
OK, I am not sure what black box you are speaking of under the passenger side wheel well? From what the manual shows the Speed Control is connected to the PCM (on the firewall) and there is a Speed Sensor. (I have not figured out where the Speed Sensor is yet.) There is a connection on the Vacuum Servo (which looks OK - but I have not removed it and re-seated it yet). The only other connection is inside the steering wheel.

Can you be more specific about what you mean? (Sorry, the vehicle is new to me and I am learning.)

Thanks for your help.
The black box is the vacuum accumulator, if its leaking it could cause issues
__________________
2007 Pastel Yellow PT Cruiser Touring Edition Auto 4 speed, 1 of 2473
Airaid SynthaFlow Cold Air Intake 300-198
UltraGauge EM v1.2
Bridgestone Turanza Serenity Plus 195/65r15
AKA "Banana Car"

Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Front Turn Signal Lights Turn On and Off When Applying Brake? Danny7627 Tech & Performance Forum 12 20 Jan 2014 09:42 pm
Windshield Wipers Turn On With Turn Signal or Bump... NewPTCruiserInPA General PT Cruiser Discussions 8 17 Dec 2013 09:10 am
2001 modified PT Cruiser Best of Show at Crusie the Falls (2x) ocs craigslist 0 10 Apr 2012 07:56 am
Is your traction control off when you turn car on? love bandit2 General PT Cruiser Discussions 8 01 Mar 2007 12:13 pm
blue turn signal bulbs that turn orange when in us Capt Kidd General PT Cruiser Discussions 1 04 Jun 2004 10:10 pm


All times are GMT -5. The time now is 04:11 pm.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors