PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > General PT Cruiser Discussions

PT Cruiser Forum

Advertisements
turn signal question

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 06 Sep 2015, 08:26 am
Fresh Cruiser
 
Join Date: Sep 2015
Posts: 1
Default turn signal question

I am new but I have been going through the threads trying to see if i can find an answer before posting.
2007 pt cruiser, the inside dash says turn signals and hazards are working; however, they are not working outside. The turn signals are blinking fast. I have checked the bulds and have bought new , but still did not solve problem. Fuses are not blown but replaced anyway. What do i check next?
Reply With Quote
  #2 (permalink)  
Old 06 Sep 2015, 08:41 am
LionPT's Avatar
Veteran Cruiser
 
Join Date: May 2014
Location: Central Florida
Posts: 4,343
Default Re: turn signal question

Fast blinking is usually an indicator of a blown bulb, but if that was the case you should have the others working.
Check the sockets, especially the rear.
There are no fuses to check in the G2's 2006-2010...blinkers are controlled by the TIPM.
__________________

2006 Touring Edition in Cool Vanilla...aka/Ghost

Last edited by LionPT; 06 Sep 2015 at 08:48 am.
Reply With Quote
  #3 (permalink)  
Old 06 Sep 2015, 11:16 am
Veteran Cruiser
 
Join Date: Aug 2015
Location: Lake Wales, FL
Posts: 4,750
Default Re: turn signal question

I agree with LionPT. Fast blinking is usually a blown bulb. Pull the bulbs and check them first. If they all look good, check the contact points on the bottom of the bulbs and the contact points inside the socket. I've had to remove sockets over the years because the dang spring under them gets rusty and then stuck, not allowing for full contact between the plate and bulb. Sometimes, the spring has been broken, so a new socket's been necessary. Check your grounds on all four sockets too. Maybe you just have a broken or loose, dirty ground wire.
__________________


Aspire to inspire before you expire.
Reply With Quote
  #4 (permalink)  
Old 06 Sep 2015, 01:33 pm
Obsessed Cruiser
 
Join Date: Aug 2014
Location: Thousand Oaks, CA
Posts: 7,308
Default Re: turn signal question

If all the grounds and contacts are good I would check the turn signal input and output at the TIPM. This would give you a good idea if the problem is before the TIPM or the TIPM itself.

Last edited by ptcruisersteve; 06 Sep 2015 at 01:35 pm.
Reply With Quote
  #5 (permalink)  
Old 07 Sep 2015, 09:13 am
Cool Cruiser
 
Join Date: Feb 2014
Posts: 298
Default Re: turn signal question

The rear sockets burn out and don't make contact you can find them on ebay or dealer for whole lot more. Get a meter or test light and see if you have voltage out of the sockets.

Make sure you have the correct bulb!!!! Some look the same but don't make contact. Been there done that!!

Good luck!
Mike
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Front Turn Signal Lights Turn On and Off When Applying Brake? Danny7627 Tech & Performance Forum 12 20 Jan 2014 09:42 pm
Windshield Wipers Turn On With Turn Signal or Bump... NewPTCruiserInPA General PT Cruiser Discussions 8 17 Dec 2013 09:10 am
Turn signal activates signal...and wipers? TF3 General PT Cruiser Discussions 2 19 Feb 2013 12:48 pm
blue turn signal bulbs that turn orange when in us Capt Kidd General PT Cruiser Discussions 1 04 Jun 2004 10:10 pm


All times are GMT -5. The time now is 01:28 am.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors