PT Cruiser Forum  

Go Back   PT Cruiser Forum > General Forums > General PT Cruiser Discussions

PT Cruiser Forum

Weird turning signal problem

Like Tree1Likes
  • 1 Post By ptcruisersteve

LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 12 Sep 2015, 07:08 pm
Young Cruiser
Join Date: Oct 2012
Posts: 98
Default Weird turning signal problem

It happened a few times.
When I turn the right signal, both signal are on and blink for about 1 sec, then work normally. Of course I observe this from the dashboard, not from outside.

Is it a switch problem?

Reply With Quote
  #2 (permalink)  
Old 12 Sep 2015, 09:02 pm
Obsessed Cruiser
Join Date: Aug 2014
Location: Thousand Oaks, CA
Posts: 6,678
Default Re: Weird turning signal problem

I suggest more information is needed before we can do a proper diagnosis.

Check and observe if they do the same on the outside.

Is there anything else that is not working properly?
Reply With Quote

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads
Thread Thread Starter Forum Replies Last Post
Turn Signal Problem Larry2828 General PT Cruiser Discussions 8 12 Nov 2014 12:04 am
Turn Signal Problem 2007 Pt Twinb2 General PT Cruiser Discussions 4 26 Sep 2012 02:46 pm
Turn signal problem Karenscruiser Tech & Performance Forum 2 12 Jun 2012 02:12 am
Rear turn signal problem leroy420 General PT Cruiser Discussions 5 18 Feb 2009 08:43 pm
Turn Signal Fuse Problem Indynick General PT Cruiser Discussions 1 04 Jul 2004 07:33 pm

All times are GMT -5. The time now is 11:41 am.

Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.