PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > General PT Cruiser Discussions

PT Cruiser Forum

Advertisements
02 cruiser, 16v coolant leak

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 13 Oct 2015, 10:09 am
Fresh Cruiser
 
Join Date: Oct 2015
Posts: 5
Default 02 cruiser, 16v coolant leak

Hello everyone, this is my second post on this forum. The first one was no help at all. I am fluent with vw, and have grown to love this cruiser so any advice is appreciated. I had a leak coming from the water pump-to-radiator pipe. So I went in and did the timing belt, water pump, thermostat, and the seal for the pipe. The car is still pissing coolant out of the WP-to-rad pipe, I pulled the pipe + lower rad hose, the new seal I just installed is chewed up... That's where I'm at if anyone wants to drop in.
Reply With Quote
  #2 (permalink)  
Old 13 Oct 2015, 11:26 am
LionPT's Avatar
Veteran Cruiser
 
Join Date: May 2014
Location: Central Florida
Posts: 4,373
Default Re: 02 cruiser, 16v coolant leak

Can you post some pics, it could help.
__________________

2006 Touring Edition in Cool Vanilla...aka/Ghost
Reply With Quote
  #3 (permalink)  
Old 13 Oct 2015, 11:55 am
Fresh Cruiser
 
Join Date: Oct 2015
Posts: 5
Default Re: 02 cruiser, 16v coolant leak

I can't upload pictures from my phone or I would. I rebuilt the car with the new WP, timing belt, thermostat, and o-ring seal for the WP-to-rad pipe. I took it out for a drive after bleeding the coolant system... All was fine until I stopped for 5 minutes to fill my tires up with air at my local grocery store. It started pouring coolant out of the drivers side of the water pump(where the rad pipe O-ring seal is). I proceeded to take that pipe/hose off and found the o-ring seal was torn up. I have checked that the radiator is clear of clogs, the water pump is spinning properly, the heatercore is blowing very hot air. The only abnormality I found was that the lower rad hose was cold while the top hose was hot. Bad thermostat from advanced auto maybe?
Reply With Quote
  #4 (permalink)  
Old 13 Oct 2015, 12:40 pm
Senior Cruiser
 
Join Date: Jan 2014
Location: SW PA
Posts: 1,348
Default Re: 02 cruiser, 16v coolant leak

Improper installation of the "O" ring, T stat would have no bearing on the "O" ring seal. I've never bothered to change that O ring unless it was leaking already.
I take it is inserted from the starter side of the water pump.
__________________
Addicted to Mopar You can tell how old I am..
65 Dodge Coronet 6 cyl 2dr Post
66 Ply Satellite with 273 engine swap to 69 340 4spd
70 340 4spd Dart Swinger "Those were the days my friend"
73 Charger SE
Had a few Vetts on the way 69, 85
Several Neons some flips
01 Sebring flip
Cruiser's 01, 220K Gone to a new home
Cruiser 03 133K Gone to a new home
Cruiser 06 110K Project Gone to new Home
Cruiser 05 Ltd 120,809 bought with broken belt Oct2015
May 16 Resurrected to once again roam the streets.

20 Miles South Of Pittsburgh
Reply With Quote
  #5 (permalink)  
Old 13 Oct 2015, 01:41 pm
Fresh Cruiser
 
Join Date: Oct 2015
Posts: 5
Default Re: 02 cruiser, 16v coolant leak

The original leak was from the starter side of the water pump, I changed everything else because the car is at 120k miles and appeared to be the factory original parts. When I pulled the O ring out, it had been marred on one section. I went through and wire brushed both of the surfaces that the O ring mates to. I am at the point that I do believe it was a possible bad install, due to the fact that the t stat did open and close during the coolant bleeding procedure.
Reply With Quote
  #6 (permalink)  
Old 13 Oct 2015, 02:18 pm
Senior Cruiser
 
Join Date: Jan 2014
Location: SW PA
Posts: 1,348
Default Re: 02 cruiser, 16v coolant leak

Make sure the pipe that goes into it is clean and lube it before you slip it in.

Inspect it , may be cracked. My supply and return lines are rusting pretty bad.
__________________
Addicted to Mopar You can tell how old I am..
65 Dodge Coronet 6 cyl 2dr Post
66 Ply Satellite with 273 engine swap to 69 340 4spd
70 340 4spd Dart Swinger "Those were the days my friend"
73 Charger SE
Had a few Vetts on the way 69, 85
Several Neons some flips
01 Sebring flip
Cruiser's 01, 220K Gone to a new home
Cruiser 03 133K Gone to a new home
Cruiser 06 110K Project Gone to new Home
Cruiser 05 Ltd 120,809 bought with broken belt Oct2015
May 16 Resurrected to once again roam the streets.

20 Miles South Of Pittsburgh
Reply With Quote
  #7 (permalink)  
Old 13 Oct 2015, 02:36 pm
Fresh Cruiser
 
Join Date: Oct 2015
Posts: 5
Default Re: 02 cruiser, 16v coolant leak

Thanks, I'm going to install a new seal after an inspection as stated above, and I'll try it again. If it doesn't work I'll keep updates coming to help out anyone else in this situation.
Reply With Quote
Reply

Tags
coolant, leak, water pump


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Coolant Leak jjackson23 Tech & Performance Forum 5 22 Mar 2014 01:19 pm
2001 PT Cruiser overheated, coolant leak help! Jmavens Tech & Performance Forum 3 14 Jan 2014 09:58 am
Troubleshoot coolant leak: Photo of Coolant on top of engine radiator cap MarcusO Tech & Performance Forum 7 27 Apr 2013 09:16 am
Coolant Leak TimWeaver Tech & Performance Forum 6 13 Jul 2012 08:55 pm
PLz help= Coolant leak PtC06 Tech & Performance Forum 2 04 Dec 2010 02:01 am


All times are GMT -5. The time now is 02:16 pm.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors