PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > General PT Cruiser Discussions

PT Cruiser Forum

Advertisements
SCARY! Engine and electrical quit while driving!

 
Like Tree5Likes

Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 29 Oct 2015, 09:29 pm
wingman55's Avatar
Senior Cruiser
 
Join Date: Aug 2015
Location: Pennellville, NY
Posts: 1,616
Unhappy SCARY! Engine and electrical quit while driving!

YIKES!

Tonight on the way home I was making a left turn, shifting into second when suddenly without warning the engine and all lights, dash, radio - EVERYTHING quit for a split second and then came back on.

ALL of the dash lights lit up for a second or so, and then everything was back to normal like nothing happened.

It was almost as if the car did a complete system reboot. The whole episode took less than five seconds.

I did the 'key dance' and there are no codes. I haven't had a chance to check it with my scanner yet

I have snooped around a bit on the forums and so far I don't seem to find any answers yet.

Any ideas?
__________________
2006 Limited Edition, Inferno Red, 5-speed, Bassani dual exhaust, Chrome backup light bezels, taillight trim, fuel door, antenna mount, Ventiports, door spear covers & hood prop. Silver painted lower front grille. American Racing 383 Casino wheels, w/Chrysler emblems, '02 engine cover, PT Cruiser mudguards, cargo mat. EGR Window Visors, dark gray lock pulls, dual horns, Fuzzy Dice, flames and MOPAR emblems added to front door logos, gold Chrysler emblem on rear hatch. Upgraded to RAK radio with 6 CD changer, Cassette Tape and RDS info. Name: "FIREBALL" I bought it Aug 10, 2015, with just over 35,600 miles on it.

2004 Limited Edition Platinum Series, Graphite Metallic, Standard Turbo, automatic, RBQ radio with Sirius Radio & 6 CD changer, VentShades, chrome exhaust tip, door spears, grille inserts, door lock pulls, bright pedals and steering wheel spokes. Red spoiler from a donor PT. Known as: "The RATMOBILE" I bought it Apr 28th, 2016 with 62,400 miles on it.

Last edited by wingman55; 29 Oct 2015 at 09:34 pm.
Reply With Quote
  #2 (permalink)  
Old 29 Oct 2015, 10:09 pm
Obsessed Cruiser
 
Join Date: Aug 2014
Location: Thousand Oaks, CA
Posts: 7,339
Default Re: SCARY! Engine and electrical quit while driving!

First thing I would suggest is to have a battery load test done. Make sure you don't have any loose battery cable connections. Some members have found the battery cable connector loose or completely corroded through and came off. Check your battery fluid level.

Do you have many keys on your key ring when you use the key to turn the ignition on?

What is the manufactured date on the drivers door of your PT Cruiser? The reason I am asking is to find out if your PT Cruiser has a TIPM.
chuzz and wingman55 like this.
__________________
If at First You Don't Succeed - Try, Try Again

Last edited by ptcruisersteve; 29 Oct 2015 at 10:14 pm.
Reply With Quote
  #3 (permalink)  
Old 30 Oct 2015, 05:59 am
wingman55's Avatar
Senior Cruiser
 
Join Date: Aug 2015
Location: Pennellville, NY
Posts: 1,616
Default Re: SCARY! Engine and electrical quit while driving!

Hi ptcruisersteve-

I had a similar thought about the battery cable. I recently had the cruise control repaired by the dealer and I wonder if the negative cable is not on tight.

Nope no extra keys on the key ring at all.

My cruiser was built in Sept of '05. It's an '06 and I believe it does have a TIPM.
__________________
2006 Limited Edition, Inferno Red, 5-speed, Bassani dual exhaust, Chrome backup light bezels, taillight trim, fuel door, antenna mount, Ventiports, door spear covers & hood prop. Silver painted lower front grille. American Racing 383 Casino wheels, w/Chrysler emblems, '02 engine cover, PT Cruiser mudguards, cargo mat. EGR Window Visors, dark gray lock pulls, dual horns, Fuzzy Dice, flames and MOPAR emblems added to front door logos, gold Chrysler emblem on rear hatch. Upgraded to RAK radio with 6 CD changer, Cassette Tape and RDS info. Name: "FIREBALL" I bought it Aug 10, 2015, with just over 35,600 miles on it.

2004 Limited Edition Platinum Series, Graphite Metallic, Standard Turbo, automatic, RBQ radio with Sirius Radio & 6 CD changer, VentShades, chrome exhaust tip, door spears, grille inserts, door lock pulls, bright pedals and steering wheel spokes. Red spoiler from a donor PT. Known as: "The RATMOBILE" I bought it Apr 28th, 2016 with 62,400 miles on it.
Reply With Quote
  #4 (permalink)  
Old 11 Nov 2016, 04:19 am
Cool Cruiser
 
Join Date: Aug 2016
Location: Stockholm
Posts: 297
Default Re: SCARY! Engine and electrical quit while driving!

What's a TIPM?
Reply With Quote
  #5 (permalink)  
Old 11 Nov 2016, 07:28 am
LionPT's Avatar
Veteran Cruiser
 
Join Date: May 2014
Location: Central Florida
Posts: 4,374
Default Re: SCARY! Engine and electrical quit while driving!

Quote:
Originally Posted by ed9msi View Post
What's a TIPM?
Totally Integrated Power Module

__________________

2006 Touring Edition in Cool Vanilla...aka/Ghost
Reply With Quote
  #6 (permalink)  
Old 11 Nov 2016, 07:34 am
Veteran Cruiser
 
Join Date: Aug 2015
Location: Lake Wales, FL
Posts: 4,868
Default Re: SCARY! Engine and electrical quit while driving!

I agree with Steve, Wingman. Check those battery cables and connections. I think it's a little too "coincidental" that this has happened after having the cruise worked on. I DO NOT believe in coincidences.
wingman55 likes this.
__________________


Aspire to inspire before you expire.
Reply With Quote
  #7 (permalink)  
Old 11 Nov 2016, 07:52 am
Cool Cruiser
 
Join Date: Aug 2016
Location: Stockholm
Posts: 297
Default Re: SCARY! Engine and electrical quit while driving!

Quote:
Originally Posted by LionPT View Post
Totally Integrated Power Module

I see, mine looks different and is from 2003 so I guess I don't have TIMP. What good does the TIMP do compared to the old solution?
Reply With Quote
  #8 (permalink)  
Old 11 Nov 2016, 08:10 am
044400's Avatar
Senior Cruiser
 
Join Date: Dec 2015
Location: Lake Elsinore, Cal
Posts: 1,286
Default Re: SCARY! Engine and electrical quit while driving!

For the first time ever all exterior and interior lights shut off while driving in the dark a couple months ago. They came back on so fast that I was wondering if I imagined the whole thing. A bit unnerving!!
wingman55 likes this.
__________________
2004 Turbo Lite Purchased 4 $400
Reply With Quote
  #9 (permalink)  
Old 11 Nov 2016, 02:24 pm
Veteran Cruiser
 
Join Date: Aug 2015
Location: Lake Wales, FL
Posts: 4,868
Default Re: SCARY! Engine and electrical quit while driving!

ed9msi, there is absolutely NO advantage to having a PT (or anything else) with the TIPM. At least with the 03 model you have, you can trouble shoot various problems that may arise and not have to worry about having to replace a very expensive item. The TIPM controls all of the electrical in those cars equipped with it. Personally, I don't like them. I have a 2013 Chrysler with one and I hope that nothing electrical ever goes wrong with it.
rob302 likes this.
__________________


Aspire to inspire before you expire.
Reply With Quote
  #10 (permalink)  
Old 11 Nov 2016, 06:19 pm
rob302's Avatar
Veteran Cruiser
 
Join Date: Jul 2016
Location: Darien, IL | Forest Park, IL
Posts: 3,526
Default Re: SCARY! Engine and electrical quit while driving!

Quote:
Originally Posted by chuzz View Post
absolutely NO advantage
unless you're a mad scientist
Reprogrammed some vehicle options today - FUN!

Last edited by rob302; 11 Nov 2016 at 06:23 pm.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Won't crank sometimes - dies when driving - electrical issue? jmansour Tech & Performance Forum 14 23 Jun 2014 03:53 pm
Scary driving in heavy rain and/or standing water. Cliff5550 General PT Cruiser Discussions 13 30 May 2013 12:24 am
Engine cuts out/dies...while driving ScottS Tech & Performance Forum 2 13 Mar 2013 07:37 am
Engine quits while driving Ornald Tech & Performance Forum 2 20 Jan 2013 12:55 pm
engine cuts off while driving leesa47 Tech & Performance Forum 2 19 Apr 2012 11:14 am


All times are GMT -5. The time now is 11:39 pm.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors