PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > General PT Cruiser Discussions

PT Cruiser Forum

Advertisements
New PT owner...

 
Like Tree4Likes
  • 1 Post By pasadenahotrod03Dreamer
  • 2 Post By LionPT
  • 1 Post By chuzz

Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 03 Nov 2015, 10:01 pm
Fresh Cruiser
 
Join Date: Nov 2015
Location: Iowa
Posts: 3
Default New PT owner...

Just purchased my first PT this past weekend. 2001 Touring. Doing some routine stuff like plugs, wires, etc and have come a across a small coolant leak. Seems to be coming from the radiator cap. The one on there was a junk plastic one so I replaced it with a 16psi metal one. the previous owner told me that in the last 6 months the radiator, thermostat, and filler neck had been replaced. the small leak still is happening, after further investigation it only happens when there is a load on the motor. Nothing at idle. hasn't over heated on me or even showed any signs, the only reason I noticed it is because I could smell the burning coolant when I get out of the car. Can any of you PT gurus point me in the right direction as to why this happening? TIA
Reply With Quote
  #2 (permalink)  
Old 03 Nov 2015, 10:26 pm
Fanatic Cruiser
 
Join Date: May 2014
Location: Pasadena TX
Posts: 713
Default Re: New PT owner...

Welcome aboard from Pasadena Texas!
Search for cooling problems under the search function. Lots of stuff to read.
Generally speaking your operating temp is ideal if the needle on the gauge hovers just under or at the halfway point.
I'd take the hose from the bottle to the filler neck off and inspect it carefully for age cracks, tiny splits at the ends.
The o-ring seal on thermostat mat be pinched too causing it to seep.
I always replace the radiator hoses, heater hoses and other coolant hoses as well as external belts if not obviously not originals when I buy a used car. I learned to replace the thermostat seal and the bottle hose too on Cruisers.
These are great little cars once you fix the little quirks but no more or less than many other cars.
ptprice likes this.
Reply With Quote
  #3 (permalink)  
Old 04 Nov 2015, 06:46 am
LionPT's Avatar
Veteran Cruiser
 
Join Date: May 2014
Location: Central Florida
Posts: 4,375
Default Re: New PT owner...

Get yourself one of these Mityvac MV4560 Radiator/Cooling System and Pressure Test Kit...it will pay for itself the 1st time you use it.

ptprice and Gkon like this.
__________________

2006 Touring Edition in Cool Vanilla...aka/Ghost
Reply With Quote
  #4 (permalink)  
Old 04 Nov 2015, 09:11 am
Fresh Cruiser
 
Join Date: Nov 2015
Location: Iowa
Posts: 3
Default Re: New PT owner...

Thank you for the quick responses. I'll check the filler hose tonight.all other visually look fine. And I'll dig into the forum more tonight as well. This is the first car I've worked on that the radiator cap isn't actually on the radiator.really looks like under load though is seeping from the cap like the pressure is getting to high and the cap is doing what it's supposed to do. At idle nothing, everything looks normal. the temp gauge is right where it needs to be right in the middle and i just replaced the temp sensor last night just to make sure.I'll look into that tester too, would be handy to have around
Reply With Quote
  #5 (permalink)  
Old 04 Nov 2015, 05:41 pm
Veteran Cruiser
 
Join Date: Aug 2015
Location: Lake Wales, FL
Posts: 4,872
Default Re: New PT owner...

Did you get the correct cap? I'm pretty sure it takes a 16 pound pressure cap and not 14. If you got the 14, that might explain it. If you got the right one, then check that hose as mentioned or look for a crack on the filler neck.
ptprice likes this.
__________________


Aspire to inspire before you expire.
Reply With Quote
  #6 (permalink)  
Old 04 Nov 2015, 09:29 pm
ptprice's Avatar
Dedicated Cruiser
 
Join Date: Nov 2012
Location: Ormond Beach, Fl. 32174
Posts: 2,315
Default Re: New PT owner...

Also check the hose to the reservoir and the reservoir itself. Happy PTin', ptprice
__________________
SOOO BIG 2005 PT CRUISER, LIMITED EDITION, SIGNATURE SERIES
Cool Vanilla White, 3 Coats. 2.4 DOHC 16V SMPI Eng. Vanity Cover, 4 Spd. Auto Trans. 2.6 Overall Top Gear, Lock-up Torque Converter. PT Chrome Clad 16" X 6" Wheels, P205/55 R16 Cooper Starfire/Solarus tires, Touring Suspension. Chrome Package; Side Spears, Grills, Fuel Filler Door, Door Locks, Handles, PRND3-1 Bezel, Silver/Chrome Shift Ball/Knob, Bright Spoke Leather Tilt Steering Wheel. Chrome Tail Lights, 3/8" Belt Trim. Cruise Control, Power Mirrors, A/C, Deep Tinted Sun Screen Glass, Power Moon Roof, Fog and Back-Up Lights, Rear Spoiler, Variable Front Wipers W/Washers, Rear Wiper/Washer, Key less Entry, Replacement 2001 Dark Taupe Grey Suede/Leather Trim Seats, Dual Under Seat Storage Drawers, Drivers Side Power Seat Height Adjust. Full Length Console, Locking Glove Box, Overhead Temperature/Compass Console, Rear Shelf Panel, AM/FM CD GPS Navigation Radio, 6 Premium Speakers, Back up Camera/ 7" Monitor.
Reply With Quote
  #7 (permalink)  
Old 04 Nov 2015, 10:39 pm
bubba_1952's Avatar
Fanatic Cruiser
 
Join Date: Jul 2012
Location: Georgia
Posts: 880
Default Re: New PT owner...

Hello and welcome to the Forum from Georgia...

Bubba
__________________


2004 Limited Edition Platinum Series Dark Graphite Metallic Clearcoat Turbolight A/T
Reply With Quote
  #8 (permalink)  
Old 05 Nov 2015, 06:57 am
Fresh Cruiser
 
Join Date: Nov 2015
Location: Iowa
Posts: 3
Default Re: New PT owner...

Checked the cap and it is a 16psi. Is it possible the top of the plastic filler neck is some how not exactally the shape is supposed to be therfore not sealing with the cap the way it's supposed to?
Reply With Quote
  #9 (permalink)  
Old 05 Nov 2015, 07:04 am
Veteran Cruiser
 
Join Date: Aug 2015
Location: Lake Wales, FL
Posts: 4,872
Default Re: New PT owner...

Did you get just a flat cap or one with the pressure release lever? If you got the one with the lever, check and make sure you have the lever locked down in the hole in the cap for it. If it's raised a little, I guess it could cause it not to completely seal and hold pressure. IDK, I'm not a mechanic.
__________________


Aspire to inspire before you expire.
Reply With Quote
Reply

Tags
coolant leak, radiator cap


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Are you a PT owner or a Chrysler owner? purple04 General PT Cruiser Discussions 55 04 Sep 2014 09:57 pm
New PT owner here too youngnstudly Welcome New PT Cruiser Members 10 21 Mar 2012 09:13 pm
New Gt owner BoostJunkie General Turbo Discussions 9 08 Aug 2008 10:19 am
New PT Owner 07PTSilver General PT Cruiser Discussions 7 25 Jul 2008 01:22 pm
New Owner....almost RJ General PT Cruiser Discussions 12 25 Oct 2003 12:22 am


All times are GMT -5. The time now is 06:02 pm.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors