PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > General PT Cruiser Discussions

PT Cruiser Forum

Advertisements
P0304 misfire troubles.

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 10 Dec 2015, 02:09 pm
Fresh Cruiser
 
Join Date: Oct 2015
Posts: 24
Default P0304 misfire troubles.

The car has been throwing this code since I got it in June. I've only really been driving it for 2 months and this crappy 10-13(90% highway) mpg is killing me. The engine shakes noticeably. The coil is orange and the wires are blue and look like they were replaced be previous owner. Thr plugs look goodreplaced too. The #4 plug was black so i swapped it with #1 and the miss stayed on #4. Swapped the #4 wire with #1 wire and the miss stayed on #4. Swapped out the #4 injector and it still misses. Today i pulled the wire off the plug and its not getting spark. It isn't getting spark off the coil or end of wire. I know it will throw two cylinders at once so i checked 1 and 2 and they both have spark. What would cause no spark at the coil on only #4?
Reply With Quote
  #2 (permalink)  
Old 10 Dec 2015, 02:28 pm
Obsessed Cruiser
 
Join Date: Aug 2014
Location: Thousand Oaks, CA
Posts: 7,338
Default Re: P0304 misfire troubles.

I would suggest checking the coil wire for cylinder #4. Sometimes they have bad connections.

I would suggest making sure cylinder #4 has compression. You might have bad valves. Has it been gradually getting worse?

Check your PCV hose coming from the engine to the manifold. The hose might be bad going underneath the manifold.

How are you testing for spark?
__________________
If at First You Don't Succeed - Try, Try Again
Reply With Quote
  #3 (permalink)  
Old 10 Dec 2015, 11:05 pm
Regular Cruiser
 
Join Date: Jun 2005
Location: Ventura, CA, USA.
Posts: 150
Default Re: P0304 misfire troubles.

Quote:
Originally Posted by 1986b2000 View Post
Today i pulled the wire off the plug and its not getting spark. It isn't getting spark off the coil or end of wire. I know it will throw two cylinders at once so i checked 1 and 2 and they both have spark. What would cause no spark at the coil on only #4?
Like PT Cruiser Steve wrote, how do you know you're not getting spark to the end of the wire for #4?

You are correct that 2 cylinders are fired at once - the secondary of the coil, one end goes to one plug, the other end to the other. The fact cylinder 1 fires means the other end of the secondary is finding a path. Since you swapped wires and it's following "plug #4" (or really the output of the coil to plug #4), your coil is the likely suspect.
__________________
______________________________________________
Most misunderstandings in the world could be avoided if people would simply take the time to ask, "What else could this mean?
______________________________________________
2001 PT Cruiser LE 5 spd, original owner, no mods, MOOG arms with spherical bushing (ride is now a bit harsher vs OEM)
- 109K replaced timing belt/WP/tensioner/idler/crank&cam seals with same 1st gen design. That was a fun day and half!
- 119K Gates water pump failed after only 10K miles. Replaced with Airtex. This time around it was a 7 hour job.

2001 PT Cruiser LE AT 59K miles. Bought used, newest addition to the family
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
My P0304 misfire journey -- suggestions welcome Z51L9889 Tech & Performance Forum 12 13 Sep 2014 09:54 pm
P0304 cylinder 4 misfire gfp55 Tech & Performance Forum 4 17 Nov 2012 04:15 am
P0304 misfire sporttraveler Tech & Performance Forum 2 20 May 2012 07:19 pm
p0304 misfire code sporttraveler Tech & Performance Forum 9 17 Feb 2012 08:26 pm
Compression; Continuation of P0304 Misfire duffner Turbo Performance 3 09 Apr 2010 12:39 pm


All times are GMT -5. The time now is 06:15 am.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors