PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > General PT Cruiser Discussions

PT Cruiser Forum

Advertisements
So I got the dreaded P0340 code today

 
Like Tree5Likes
  • 3 Post By podo2000
  • 1 Post By CREWZIN
  • 1 Post By podo2000

Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 06 Jan 2016, 07:55 pm
podo2000's Avatar
Cool Cruiser
 
Join Date: Sep 2012
Location: Arizona
Posts: 266
Default So I got the dreaded P0340 code today

I was almost home when the CEL came on and the car began to buck. UG tells me pending trouble code P0340.
Lurking thru the boards, i know its the cam position sensor or timing belt. But since the car was still running, it had to be the sensor.
Did a quick search on the boards to find out more about it and where it was located.
Took it apart, cleaned the contacts ( it was full of oil) and checked all the wiring. Put it back together and car is running great again. 20 mile test drive and no CEL

Thank you guys for posting on this site to enable us to be able to make quick fixes like this.

__________________


2004 PTGT 131Kmiles
Reply With Quote
  #2 (permalink)  
Old 06 Jan 2016, 08:27 pm
Obsessed Cruiser
 
Join Date: Sep 2001
Posts: 27,744
Default Re: So I got the dreaded P0340 code today

That's the whole reason for the forum. Glad it was that easy for you.
rckstein likes this.
__________________
Rules of the forum have been updated as of *07/07/2019* Please read them over.

- All decisions by the Moderator are semi-permanent, can and may be changed at his discretion but definitely will be the final word. Any action performed by the Administrator or Moderators are not to be discussed on the forum.
Reply With Quote
  #3 (permalink)  
Old 07 Jan 2016, 08:17 am
Veteran Cruiser
 
Join Date: Aug 2015
Location: Lake Wales, FL
Posts: 4,864
Default Re: So I got the dreaded P0340 code today

Wait! Did you actually take the sensor apart or just cleaned the contacts in the electrical plug connector? I didn't know the sensor came apart. If so, I may try that with mine. Still has a slight miss that I can't seem to locate or eliminate. Maybe there's oil in mine too.
__________________


Aspire to inspire before you expire.
Reply With Quote
  #4 (permalink)  
Old 11 Jan 2016, 09:49 pm
podo2000's Avatar
Cool Cruiser
 
Join Date: Sep 2012
Location: Arizona
Posts: 266
Default Re: So I got the dreaded P0340 code today

Sensor comes apart at the block. 2 10mm ( i believe) bolts
chuzz likes this.
__________________


2004 PTGT 131Kmiles
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
the dreaded p0551 code - stumper djfox1 Turbo Performance 17 16 Apr 2016 08:14 pm
Exchange of Information.. Dreaded CAS Code!!! Read. GTCRUISER2006 Tech & Performance Forum 4 18 Jul 2015 06:52 am
Car died today - Error P0340 BlakeL General PT Cruiser Discussions 5 02 Mar 2015 10:16 pm
Code P0340 flcruiser General PT Cruiser Discussions 1 24 Aug 2012 07:08 pm
the dreaded p0344 code ev3 Tech & Performance Forum 8 02 Apr 2011 02:44 pm


All times are GMT -5. The time now is 02:52 am.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors