PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > General PT Cruiser Discussions

PT Cruiser Forum

Advertisements
Help with strange electrical problem

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 07 Feb 2016, 04:20 pm
Fresh Cruiser
 
Join Date: Jan 2011
Posts: 5
Default Help with strange electrical problem

Hi there, long time lurker, 4th time poster.
I have searched here and googled for the problem I am having and have yet to get any clues.

I have a 2007 convertible PT with round 113k miles on it. In the last couple weeks it has developed an issues where the blower just turns on, high speed, no matter where the speed switch is. And you can't turn it off. Only way to turn it off is to shut off the car.
Then we discovered a new twist. If the blower starts running, pulsing the windshield wipers will turn it off. Just one cycle and it turns off.
When things are normal, they are normal. All the blower speeds work and it can be turned off and on.
Also noticed that the recirculate switch stops working when it does this.

I'm not even sure where to start looking for the problem. Is it a CAN bus problem or an electrical/ground problem?

Any suggestions welcome.

Thanks

Mel
Reply With Quote
  #2 (permalink)  
Old 07 Feb 2016, 06:33 pm
_PTGT03's Avatar
Fanatic Cruiser
 
Join Date: Oct 2015
Location: Abbotsford, British Columbia.
Posts: 760
Default Re: Help with strange electrical problem

Blower turning on for no reason tells me the switch is grounding out its pins/contacts with vibration or thermal expansion and causing it to turn on.

Pulsing wipers and the blower turning off ? I would have to look into that with electrical diagrams and see where a connection could be between the two.

I'll come back later with a better reply.
__________________
2003 GT M/T in Onyx Green Pearl on Michelin Pilot Sport AS 3 Plus Tires 205/50ZR17. Dark Slate Gray Interior. OEM cargo net, parcel shelf, slush mats and trunk protector, mud flaps, mopar subwoofer. Platinum edition pedals, Neon SX 2.0 steering wheel with black+grey wrapped leather cover. Generic lowering springs, KYB gas shocks, Valeo solid flywheel conversion and clutch kit. Urethane insert engine mounts. Energy suspension full body urethane bushing kit. Chrysler premium front speakers, Jenson 6x9 rears. Boston Audio 4x55W amp. Panasonic head unit with xtenzi bluetooth. 300W AC power inverter. Escort 360max and Escort Shifter ZR4, dual front+rear dash camera. stage 1 blow off valve and syked tune computer . Boost and oil pressure gauges with Turbo-Timer. Needswings 3" exhaust elbow, Electric valve actuated Y-pipe with catalytic converter. To do: coilovers, 2step controller, quaife diff, Air-Fuel Meter
Reply With Quote
  #3 (permalink)  
Old 07 Feb 2016, 08:25 pm
Obsessed Cruiser
 
Join Date: Aug 2014
Location: Thousand Oaks, CA
Posts: 7,337
Default Re: Help with strange electrical problem

Has there been any repairs done to the PT Cruiser before this happened? Sometimes when repairing something else it moves or disconnect wires to get to the component that needs the repairl
__________________
If at First You Don't Succeed - Try, Try Again
Reply With Quote
  #4 (permalink)  
Old 07 Feb 2016, 10:41 pm
Fresh Cruiser
 
Join Date: Jan 2011
Posts: 5
Default Re: Help with strange electrical problem

No repairs. Last thing was an oil change and inspection.

I don't think it is a vibration issue. I've tried a little "percussive maintenance" on the switch with no change.

One other thing I have noticed is that when you turn the switch to off, it sounds like something is blocking the air flow.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Very Strange Electrical Issue Please Help! Hans2112 General PT Cruiser Discussions 4 21 Nov 2015 10:35 pm
Strange Electrical problem windsblow Tech & Performance Forum 5 22 Mar 2011 09:11 am
Strange Electrical Problem carlton Tech & Performance Forum 9 08 Feb 2011 10:21 pm
electrical problem. burning electrical plug cruiserjim269 General PT Cruiser Discussions 17 03 Dec 2010 03:38 pm
need advice on strange electrical problem in Jeep comPuTer General PT Cruiser Discussions 1 07 Jul 2004 07:31 pm


All times are GMT -5. The time now is 04:25 pm.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors