PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > General PT Cruiser Discussions

PT Cruiser Forum

Advertisements
Woops. Attached battery backwards. What do I check?

 
Like Tree1Likes

Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 12 Feb 2016, 03:54 pm
Fresh Cruiser
 
Join Date: Feb 2016
Posts: 8
Default Woops. Attached battery backwards. What do I check?

So my car wasn't working, I messed with it and put the battery on backwards. (so dumb)

BUT The car worked after I reattached it right! For a whole day! I started it up at least 8 times.


Then now it doesn't work.

What could've blown in the electrical system? What should I check?
Reply With Quote
  #2 (permalink)  
Old 12 Feb 2016, 04:58 pm
NitroPT's Avatar
Obsessed Cruiser
 
Join Date: Jun 2012
Location: USA kalyfornia
Posts: 15,812
Default Re: Woops. Attached battery backwards. What do I check?

Check the systems voltage.
Check the battery by load testing it.
Check all your relays and fuses.
Check the battery leads both at the battery and also the frame/body and starter.

You may have just killed the battery.
__________________
To view larger pictures simply "click " on the picture!

Dalai Lama
"Share you knowledge. It's the best way to achieve immortality."
ASE MASTER TECHNICIAN
Reply With Quote
  #3 (permalink)  
Old 12 Feb 2016, 06:25 pm
quicksilverdon's Avatar
Obsessed Cruiser
 
Join Date: Nov 2003
Location: Felton, Delaware
Posts: 20,501
Default Re: Woops. Attached battery backwards. What do I check?

Quote:
Originally Posted by FrostDrive View Post
So my car wasn't working, I messed with it and put the battery on backwards. (so dumb)

BUT The car worked after I reattached it right! For a whole day! I started it up at least 8 times.


Then now it doesn't work.

What could've blown in the electrical system? What should I check?
If you didn't do anything else, it may be the original problem you had before when your car wouldn't work.
Does the starter turn and engine not "catch"?
Turn key and hear "clicks"?
__________________
"Anti-intellectualism has been a constant thread winding its way through our political and cultural life,
nurtured by the false notion that democracy means that 'my ignorance is just as good as your knowledge."
Isaac Asimov"

'05 Limited Turbo Lite, (Silver, of course)4-wheel ABS, Sunroof, Spoiler. Mods: E&G Classic grill, K&N FIPK, BTG duals, rear lowered 1.5", LED washer lights, $20 catch can, Aoogah horn, Weatherflectors, Sunroof Deflector, Fuzzy Dice, rear logo flames, rear pinstripe graphic, Gen3 Taillights, rear sway bar, hood struts, Strut bar.
Traded in '02 Silver Touring Edition w/87,000 miles
Reply With Quote
  #4 (permalink)  
Old 12 Feb 2016, 10:08 pm
_PTGT03's Avatar
Fanatic Cruiser
 
Join Date: Oct 2015
Location: Abbotsford, British Columbia.
Posts: 762
Default Re: Woops. Attached battery backwards. What do I check?

it probably your main fuse. ive done it befor but on a suzuki (it happens man, don't sweat it ) . should be located in the power distribution centre just under the clutch slave resevoir
__________________
2003 GT M/T in Onyx Green Pearl on Michelin Pilot Sport AS 3 Plus Tires 205/50ZR17. Dark Slate Gray Interior. OEM cargo net, parcel shelf, slush mats and trunk protector, mud flaps, mopar subwoofer. Platinum edition pedals, Neon SX 2.0 steering wheel with black+grey wrapped leather cover. Generic lowering springs, KYB gas shocks, Valeo solid flywheel conversion and clutch kit. Urethane insert engine mounts. Energy suspension full body urethane bushing kit. Chrysler premium front speakers, Jenson 6x9 rears. Boston Audio 4x55W amp. Panasonic head unit with xtenzi bluetooth. 300W AC power inverter. Escort 360max and Escort Shifter ZR4, dual front+rear dash camera. stage 1 blow off valve and syked tune computer . Boost and oil pressure gauges with Turbo-Timer. Needswings 3" exhaust elbow, Electric valve actuated Y-pipe with catalytic converter. To do: coilovers, 2step controller, quaife diff, Air-Fuel Meter
Reply With Quote
  #5 (permalink)  
Old 12 Feb 2016, 10:40 pm
Obsessed Cruiser
 
Join Date: Aug 2014
Location: Thousand Oaks, CA
Posts: 7,338
Default Re: Woops. Attached battery backwards. What do I check?

Quote:
Originally Posted by FrostDrive View Post
Hello. I have a 2004 PT Cruiser.
Car didn't start.
Replaced Starter. Worked great. For a week.
Then didn't start. Made one click and a little hum. All lights lit up.
Battery was fine.
Then days later. Car started! Worked great. For a week.
Then car didn't start. Same. Made one click, little hum. Didn't work for two weeks.
Checked the starter relay. Ok.
Checked the battery. Ok.
Checked fuses. Ok.
Today, hooked up battery. Didn't pay attention an d I hooked it up backwards. The negative wire fell and hit what was the positive terminal, while the positive wire was hooked up to the negative.
Hooked battery up the right way.
Car suddenly works again. But now my interior lights, and radio don't turn on.
Did you check the fuses when the interior lights and radio didn't work?

You need to post every step you do otherwise we have no idea what you have done.

Does your engine light come on? If so what are the codes?
__________________
If at First You Don't Succeed - Try, Try Again
Reply With Quote
  #6 (permalink)  
Old 12 Feb 2016, 10:49 pm
NitroPT's Avatar
Obsessed Cruiser
 
Join Date: Jun 2012
Location: USA kalyfornia
Posts: 15,812
Default Re: Woops. Attached battery backwards. What do I check?

Quote:
Originally Posted by ptcruisersteve View Post
Did you check the fuses when the interior lights and radio didn't work?

You need to post every step you do otherwise we have no idea what you have done.

Does your engine light come on? If so what are the codes?
Steve I never read his other request...geeeeezzz I don't read every thread on this forum ...
So another member doing multiple threads inquiring about the same thing?

Good luck helping this member.
__________________
To view larger pictures simply "click " on the picture!

Dalai Lama
"Share you knowledge. It's the best way to achieve immortality."
ASE MASTER TECHNICIAN
Reply With Quote
  #7 (permalink)  
Old 12 Feb 2016, 11:55 pm
quicksilverdon's Avatar
Obsessed Cruiser
 
Join Date: Nov 2003
Location: Felton, Delaware
Posts: 20,501
Default Re: Woops. Attached battery backwards. What do I check?

Quote:
Originally Posted by NitroPT View Post
Steve I never read his other request...geeeeezzz I don't read every thread on this forum ...
So another member doing multiple threads inquiring about the same thing?

Good luck helping this member.
I agree.
I give up on this one...
__________________
"Anti-intellectualism has been a constant thread winding its way through our political and cultural life,
nurtured by the false notion that democracy means that 'my ignorance is just as good as your knowledge."
Isaac Asimov"

'05 Limited Turbo Lite, (Silver, of course)4-wheel ABS, Sunroof, Spoiler. Mods: E&G Classic grill, K&N FIPK, BTG duals, rear lowered 1.5", LED washer lights, $20 catch can, Aoogah horn, Weatherflectors, Sunroof Deflector, Fuzzy Dice, rear logo flames, rear pinstripe graphic, Gen3 Taillights, rear sway bar, hood struts, Strut bar.
Traded in '02 Silver Touring Edition w/87,000 miles
Reply With Quote
  #8 (permalink)  
Old 13 Feb 2016, 12:01 am
Obsessed Cruiser
 
Join Date: Aug 2014
Location: Thousand Oaks, CA
Posts: 7,338
Default Re: Woops. Attached battery backwards. What do I check?

Quote:
Originally Posted by NitroPT View Post
Steve I never read his other request...geeeeezzz I don't read every thread on this forum ...
So another member doing multiple threads inquiring about the same thing?

Good luck helping this member.
I don't mind a challenge as long as I get the answers I need.
NitroPT likes this.
__________________
If at First You Don't Succeed - Try, Try Again
Reply With Quote
  #9 (permalink)  
Old 18 Feb 2016, 05:50 pm
Fresh Cruiser
 
Join Date: Feb 2016
Posts: 8
Default Re: Woops. Attached battery backwards. What do I check?

Sorry for the laate reply. I'll check the main fuse thanks!


I suspected the starter was bad, but I just took it out and got it bench tested. It was fine.



When you start the car, how many volts are supposed to get through to the part on the starter that connects to the ignition. I heard you need at least 9 volts to get the car started.

I'm pretty lost and defeated at this point honestly. );
Reply With Quote
  #10 (permalink)  
Old 18 Feb 2016, 08:28 pm
Obsessed Cruiser
 
Join Date: Aug 2014
Location: Thousand Oaks, CA
Posts: 7,338
Default Re: Woops. Attached battery backwards. What do I check?

Quote:
Originally Posted by FrostDrive View Post
Sorry for the laate reply. I'll check the main fuse thanks!


I suspected the starter was bad, but I just took it out and got it bench tested. It was fine.



When you start the car, how many volts are supposed to get through to the part on the starter that connects to the ignition. I heard you need at least 9 volts to get the car started.

I'm pretty lost and defeated at this point honestly. );
I thought you replaced the starter as posted in post #5

Also bench testing the starter does not check the starter under a load. It can still be bad.
__________________
If at First You Don't Succeed - Try, Try Again

Last edited by ptcruisersteve; 18 Feb 2016 at 08:31 pm.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Cranked 2008 PT cruiser with battery hooked backwards Plantman Tech & Performance Forum 3 15 Feb 2014 07:04 pm
Awesome cruiser my my house! Pic attached Youngmaninanoldmanscar General PT Cruiser Discussions 10 11 Jan 2013 06:53 pm
Attached my Flame Grille Badge? Retroguy Exterior Accessories Forum 11 23 May 2011 05:54 pm
Why is my Autoloc keyless entry fob working backwards? bettyrubble76 Interior Accessories Forum 8 19 Sep 2009 12:45 pm
what are the two silver modules attached to the turbo mino General Turbo Discussions 2 23 Oct 2007 02:19 pm


All times are GMT -5. The time now is 05:43 am.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors