PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > General PT Cruiser Discussions

PT Cruiser Forum

Advertisements
hazards / signals issue

 
Like Tree3Likes
  • 1 Post By Ghosttowncs
  • 2 Post By sanatanadharma

Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 16 Mar 2016, 12:16 pm
Regular Cruiser
 
Join Date: Feb 2016
Posts: 115
Default hazards / signals issue

This morning I tried turning on my hazards with the engine off and got nothing. When I turned the engine on they came on and wouldn't turn off, after trying to turn them off and on a few times they finally went off but only the right side, left side of the car was still blinking. So I turned the car off and on, blinker off and on. Finally got them to shut off. Went to work, blinkers worked fine, hazards still don't want to turn off after turning them on, with the engine on. They won't work at all with the engine off. What could it be? Btw, I also have the typical non working fog lights, I removed fog light fuse because the stalk smokes other wise.

Is there a relay and fuse for the hazards and if so are they the same relay and fuse for the blinkers? I recently replaced the horn relay too. I wanted to say, I recently got this car and ever since I got it I've noticed the blinkers make a distinct clicking sound when activated different from other cars as if they're about to die or they're staining if that makes any sense.

Last edited by cloudhidd3n; 16 Mar 2016 at 12:21 pm.
Reply With Quote
  #2 (permalink)  
Old 16 Mar 2016, 12:32 pm
Ghosttowncs's Avatar
Fresh Cruiser
 
Join Date: Feb 2016
Location: Wyo!
Posts: 18
Default Re: hazards / signals issue

Having only had my PT for a little over a month now, the 1st order of business for mine was to replace the turn signal / multi-function switch. When I found the car I noticed it had the fog lights that would not shut off issue. I found mine locally at one of the big name stores for $50. Since I have replaced it, a 20 minute job, everything functions as it should. I would suspect yours needs replacement as well. I'm sure more knowledgeable people will be along shortly!
cloudhidd3n likes this.
__________________
Bag O' Corn Friend!

2002 Limited, Auto, 142k miles
Reply With Quote
  #3 (permalink)  
Old 16 Mar 2016, 01:03 pm
Regular Cruiser
 
Join Date: Feb 2016
Posts: 115
Default Re: hazards / signals issue

Yea I'll call around to find a mfs
Reply With Quote
  #4 (permalink)  
Old 16 Mar 2016, 01:56 pm
Regular Cruiser
 
Join Date: Feb 2016
Posts: 115
Default Re: hazards / signals issue

Okay so local auto store has the mfs on hold to pick up after work. I Would like to check the relay s and fuse to rule those out first, anyone know where they are located? Also isn't there a Flasher on the mfs that I might need as well?

Edit: napa has it for $80 for napa brand, comes with stalk, hazard button whole assembly. O reilly auto parts has the same thing but different brand for $58. Which do i trust?

Last edited by cloudhidd3n; 16 Mar 2016 at 02:37 pm.
Reply With Quote
  #5 (permalink)  
Old 16 Mar 2016, 02:34 pm
Fk5 Fk5 is offline
Senior Cruiser
 
Join Date: Jul 2011
Location: Colesville, MD
Posts: 1,850
Default Re: hazards / signals issue

On second read, I can see what you said about your fogs. Almost all of us have had the problem with the MFS and fog lights, but a "smoking stalk" seems a little scary. I would look for burnt wires when you are in there.
__________________
2003 GT 5 speed
162,000 miles

Last edited by Fk5; 16 Mar 2016 at 02:42 pm. Reason: Electrical guru, sanatanadharma is going to give better MFS advice than me!
Reply With Quote
  #6 (permalink)  
Old 16 Mar 2016, 02:35 pm
Veteran Cruiser
 
Join Date: Sep 2010
Location: Walking distance to the embassy
Posts: 3,103
Default Re: hazards / signals issue

Because Trump
Fk5 and cloudhidd3n like this.

Last edited by sanatanadharma; 10 Nov 2016 at 07:18 pm.
Reply With Quote
  #7 (permalink)  
Old 16 Mar 2016, 03:39 pm
Regular Cruiser
 
Join Date: Feb 2016
Posts: 115
Default Re: hazards / signals issue

So sanata, do you think the mfs will fix this?
Reply With Quote
  #8 (permalink)  
Old 16 Mar 2016, 05:32 pm
Veteran Cruiser
 
Join Date: Sep 2010
Location: Walking distance to the embassy
Posts: 3,103
Default Re: hazards / signals issue

Quote:
Originally Posted by cloudhidd3n View Post
So sanata, do you think the mfs will fix this?
More inclined to suggest trying a different flasher... (added edit) rather than the Trump selected.

Last edited by sanatanadharma; 10 Nov 2016 at 07:18 pm. Reason: Because Trump
Reply With Quote
  #9 (permalink)  
Old 16 Mar 2016, 05:47 pm
Fk5 Fk5 is offline
Senior Cruiser
 
Join Date: Jul 2011
Location: Colesville, MD
Posts: 1,850
Default Re: hazards / signals issue

Quote:
Originally Posted by sanatanadharma View Post
More inclined to suggest trying a different flasher
That was my initial thought, but he indicated that he already had the fog light issue and "smoke from the stalk." You stated that the flasher is mounted to the MFS. Wouldn't that indicate that he should swap the MFS and the flasher?
__________________
2003 GT 5 speed
162,000 miles
Reply With Quote
  #10 (permalink)  
Old 16 Mar 2016, 06:45 pm
Regular Cruiser
 
Join Date: Feb 2016
Posts: 115
Default Re: hazards / signals issue

Thank you guys, it was the mfs. Everything works now, even my fog lights! Last question, when using my blinkers why do I hear my blinkers clicking through my speakers when my radio is turned up?

Last edited by cloudhidd3n; 16 Mar 2016 at 07:18 pm.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
2006 Cruiser Turn signals and Hazards libilou Tech & Performance Forum 28 17 Sep 2014 05:21 am
No turn signals. Fuse Blows when Hazards turned off JerryJovi Northwest PT Forum 1 15 May 2014 08:16 pm
INDICATORS TURN SIGNALS HAZARDS PATGAS Tech & Performance Forum 9 29 Oct 2013 04:59 pm
Hazards and Turn signals out. KrisBo Tech & Performance Forum 4 29 Dec 2011 05:23 pm
Blinkers and Hazards not working badgingles Tech & Performance Forum 1 03 Sep 2009 08:55 pm


All times are GMT -5. The time now is 12:16 am.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors