PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > General PT Cruiser Discussions

PT Cruiser Forum

Advertisements
horn issues

 
Like Tree4Likes

Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 17 Mar 2016, 08:09 pm
Regular Cruiser
 
Join Date: Feb 2016
Posts: 115
Default horn issues

Did I buy a lemon or is this typcal pt cruiser stuff? Anyways, a week ago my horn stopped working, I diagnosed the relay, Replaced it, worked fine..now again it's not working and its not the relay, this time the alarm still works, I can set it off by opening the locked doors from the inside. But the horn won't work. Dunno if this is related but yesterday I replaced the mfs to fix my fog lights and hazards. Any ideas?

Edit; okay wtf! I just punched the steering wheel and it worked. Seems it works intermittently when it wants to if I hit the horn hard enough.
Handy_Cruiser likes this.

Last edited by cloudhidd3n; 17 Mar 2016 at 08:16 pm.
Reply With Quote
  #2 (permalink)  
Old 17 Mar 2016, 08:20 pm
Handy_Cruiser's Avatar
Obsessed Cruiser
 
Join Date: Oct 2013
Location: Arkansas
Posts: 10,427
Default Re: horn issues

Quote:
Originally Posted by cloudhidd3n View Post
Did I buy a lemon or is this typcal pt cruiser stuff? Anyways, a week ago my horn stopped working, I diagnosed the relay, Replaced it, worked fine..now again it's not working and its not the relay, this time the alarm still works, I can set it off by opening the locked doors from the inside. But the horn won't work. Dunno if this is related but yesterday I replaced the mfs to fix my fog lights and hazards. Any ideas?

Edit; okay wtf! I just punched the steering wheel and it worked. Seems it works intermittently when it wants to if I hit the horn hard enough.
You might have a clock-spring issue. But if it was me and if I had recently installed a mutlifunction switch, I'd take the covers back off the column and assure everything was plugged up good. I'd likely unplug everything, clean the plugs and then plug them back in. I'd pay close attention to the plug for the clock-spring and I'd assure I hadn't damaged any of the wires going to it.
cloudhidd3n likes this.
__________________
Reply With Quote
  #3 (permalink)  
Old 17 Mar 2016, 08:25 pm
Regular Cruiser
 
Join Date: Feb 2016
Posts: 115
Default Re: horn issues

You're right, i just did that, rechecked all the plugs, which one is the spring plug? So after a few good hits and punches, my horn works again..

Last edited by cloudhidd3n; 17 Mar 2016 at 08:50 pm.
Reply With Quote
  #4 (permalink)  
Old 17 Mar 2016, 08:33 pm
Obsessed Cruiser
 
Join Date: Sep 2001
Posts: 27,744
Default Re: horn issues



cloudhidd3n likes this.
__________________
Rules of the forum have been updated as of *07/07/2019* Please read them over.

- All decisions by the Moderator are semi-permanent, can and may be changed at his discretion but definitely will be the final word. Any action performed by the Administrator or Moderators are not to be discussed on the forum.
Reply With Quote
  #5 (permalink)  
Old 17 Mar 2016, 08:51 pm
Regular Cruiser
 
Join Date: Feb 2016
Posts: 115
Default Re: horn issues

Yea! Number 3 is what I messed with just now and works Again, for now..
Handy_Cruiser likes this.
Reply With Quote
  #6 (permalink)  
Old 18 Mar 2016, 07:09 am
Veteran Cruiser
 
Join Date: Aug 2015
Location: Lake Wales, FL
Posts: 4,862
Default Re: horn issues

Any way you can put a small zip tie around the whole thing to keep it tight?
__________________


Aspire to inspire before you expire.
Reply With Quote
  #7 (permalink)  
Old 23 Apr 2017, 06:58 pm
Regular Cruiser
 
Join Date: Feb 2016
Posts: 115
Default Re: horn issues

This problem still hasn't been solved. I opened up my steering wheel hoping I could find some sticky horn buttons but turns out they're in front of the air bag. Not able to get to it as you can see from the picture.

Basically I have to smack the horn really hard once or twice and then it'll work but eventually stops working again and then have to smack it to get it start working again.
Attached Images
File Type: jpg 20170423_164421.jpg (94.8 KB, 21 views)

Last edited by cloudhidd3n; 23 Apr 2017 at 07:21 pm.
Reply With Quote
  #8 (permalink)  
Old 24 Apr 2017, 09:58 pm
Young Cruiser
 
Join Date: May 2016
Location: Bolingbrook, IL
Posts: 51
Default Re: horn issues

Following this one... My 2007 horn sticks sometimes. The first time I honked the horn was probably 6 months after I bought the car. It stuck for a good 2 minutes. Mow, I just hit the horn again and it stops. So far, at least.
Reply With Quote
  #9 (permalink)  
Old 24 Apr 2017, 10:30 pm
rckstein's Avatar
Banned
 
Join Date: Dec 2010
Location: Texas
Posts: 15,518
Default Re: horn issues

Quote:
Originally Posted by siamese_retriever View Post
Following this one... My 2007 horn sticks sometimes. The first time I honked the horn was probably 6 months after I bought the car. It stuck for a good 2 minutes. Mow, I just hit the horn again and it stops. So far, at least.
This part has been replaced on my PT 3 times, for the horn pad sticking, the first time just 5 months after I purchased my PT:

MOPAR 68002385AA


But I can't find a good diagram of where it actually goes.

The clock spring has also been replaced, but I don't know if the clock spring is related to the horn switch. It was replaced because of the airbag light.
Reply With Quote
  #10 (permalink)  
Old 14 May 2017, 02:37 pm
Regular Cruiser
 
Join Date: Feb 2016
Posts: 115
Default Re: horn issues

At this point I just need to install an aftermarket horn and new button somewhere, or maybe just a new button rewiring, disconnecting the old horn button on the steering wheel. Any ideas guys? I hate not having a reliable horn, and now my clock spring is making noise too when rotating the wheel I hear a slight "tick/click".
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Horn Issues terryb8388 General PT Cruiser Discussions 3 03 May 2015 04:50 pm
speaker issues, wattage of stereo, door speaker replacement issues fabes89 General PT Cruiser Discussions 9 02 Jun 2009 10:59 am
My horn :( ucantcme General PT Cruiser Discussions 10 27 Jun 2008 02:12 pm
New Horn Sandy-GRR8PT General PT Cruiser Discussions 11 06 Apr 2006 08:40 am
A-uo-Ga Horn turbomangt General PT Cruiser Discussions 14 06 Feb 2003 10:01 am


All times are GMT -5. The time now is 03:03 pm.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors