PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > General PT Cruiser Discussions

PT Cruiser Forum

Advertisements
No High Beams or High Beam Indicator

 
Like Tree1Likes

Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 20 Apr 2016, 11:28 am
Fresh Cruiser
 
Join Date: Jan 2015
Location: Lindenhurst, NY
Posts: 41
Default No High Beams or High Beam Indicator

Noticed a few days ago my high beams are not working, nor is the blue high beam indicator on my dash.

All fuses in the dash panel and underhood PDC check out fine. Low beams, wipers, signals, fogs, all work. When I pull the lever to turn on high beams, low beams (and fogs, if turned on) stay on.

High beams were working fine when I last used them a bit a week ago.

Removed, cleaned and reinstalled the MFS about three months ago when my fogs and associated dash indicator stopped working, no problems since.

What is more likely at this point, the headlamp relay or high beam bulbs? If both bulbs are shot, would that in turn prevent the dash indicator from coming on?

Thanks.
__________________
2004 Chrysler PT Cruiser Limited Edition Platinum Series 2.4L 4cyl Turbo

Last edited by inertian; 20 Apr 2016 at 01:11 pm.
Reply With Quote
  #2 (permalink)  
Old 20 Apr 2016, 12:53 pm
LionPT's Avatar
Veteran Cruiser
 
Join Date: May 2014
Location: Central Florida
Posts: 4,372
Default Re: No High Beams or High Beam Indicator

It's a little hard to follow what you posted....so,
When you push the lever forward you have no high beams or indicator...
What happens when you pull the lever backward, do the high beams work..??
__________________

2006 Touring Edition in Cool Vanilla...aka/Ghost
Reply With Quote
  #3 (permalink)  
Old 20 Apr 2016, 01:09 pm
Fresh Cruiser
 
Join Date: Jan 2015
Location: Lindenhurst, NY
Posts: 41
Default Re: No High Beams or High Beam Indicator

Appreciate the quick response, please let me know what you would like me to clarify.

My high beams are normally activated by pulling the MFS lever towards me. From the manual:

Highbeam/Lowbeam Select Switch
Pull the Multi-Function Control Lever towards you to
switch the headlights to HIGH beam. Pull the control
lever a second time to switch the headlights to LOW
beam.

Currently, when I do this, neither the high beams, nor the high beam indicator on the dash come on.
__________________
2004 Chrysler PT Cruiser Limited Edition Platinum Series 2.4L 4cyl Turbo
Reply With Quote
  #4 (permalink)  
Old 20 Apr 2016, 04:52 pm
LionPT's Avatar
Veteran Cruiser
 
Join Date: May 2014
Location: Central Florida
Posts: 4,372
Default Re: No High Beams or High Beam Indicator

So in the G1's there is only on & off, not on & momentary like in the G2's..??
In my 2006 I push the MFS away to turn on the high beams & pull it towards me to turn them on momentarily.
I was trying to figure out if the MFS worked in both positions, but it sounds like you only have 1 position.
__________________

2006 Touring Edition in Cool Vanilla...aka/Ghost
Reply With Quote
  #5 (permalink)  
Old 20 Apr 2016, 05:22 pm
Obsessed Cruiser
 
Join Date: Sep 2001
Posts: 27,744
Default Re: No High Beams or High Beam Indicator

On my Gen 1, when the headlights are on, you pull the left stalk half way towards you for momentary high beam and all the way towards you till they click for the high beams to stay on.

The headlamp relay is located in the interior fuse box at the bottom left side.



Got the picture from the Internet. Sorry if that offends anyone.
LionPT likes this.
__________________
Rules of the forum have been updated as of *07/07/2019* Please read them over.

- All decisions by the Moderator are semi-permanent, can and may be changed at his discretion but definitely will be the final word. Any action performed by the Administrator or Moderators are not to be discussed on the forum.

Last edited by CREWZIN; 20 Apr 2016 at 05:26 pm.
Reply With Quote
  #6 (permalink)  
Old 20 Apr 2016, 05:41 pm
Fresh Cruiser
 
Join Date: Jan 2015
Location: Lindenhurst, NY
Posts: 41
Default Re: No High Beams or High Beam Indicator

Thanks, I located the relay when I was testing for power at the fuse block and checking fuses.

What's more likely, the relay goes bad or both high beams fail at the same time?

And if the high beam bulbs do fail, would that keep the high beam dash indicator from coming on?
__________________
2004 Chrysler PT Cruiser Limited Edition Platinum Series 2.4L 4cyl Turbo
Reply With Quote
  #7 (permalink)  
Old 21 Apr 2016, 08:04 am
Regular Cruiser
 
Join Date: Dec 2015
Location: Vancouver BC
Posts: 172
Default Re: No High Beams or High Beam Indicator

The first thing that comes to mind is the MFS because they were a problem, especially with the cars that had fog lights.
Reply With Quote
  #8 (permalink)  
Old 24 Apr 2016, 02:22 pm
Veteran Cruiser
 
Join Date: Sep 2010
Location: Walking distance to the embassy
Posts: 3,102
Default Re: No High Beams or High Beam Indicator

Because Trump

Last edited by sanatanadharma; 10 Nov 2016 at 07:22 pm.
Reply With Quote
  #9 (permalink)  
Old 24 Apr 2016, 03:09 pm
Fresh Cruiser
 
Join Date: Jan 2015
Location: Lindenhurst, NY
Posts: 41
Default Re: No High Beams or High Beam Indicator

Thanks for the explanation and next steps to take. Will check and report back.
__________________
2004 Chrysler PT Cruiser Limited Edition Platinum Series 2.4L 4cyl Turbo
Reply With Quote
  #10 (permalink)  
Old 23 Jul 2016, 10:37 am
Fresh Cruiser
 
Join Date: Jan 2015
Location: Lindenhurst, NY
Posts: 41
Default Re: No High Beams or High Beam Indicator

Quick update - haven't had a chance to address the high beam issue, but then just yesterday my foglights stopped working as well (bulbs don't light and no indicator on dash).

Is it finally time to install a new MFS, or has anyone had success in repairing it more than once?

Thanks.
__________________
2004 Chrysler PT Cruiser Limited Edition Platinum Series 2.4L 4cyl Turbo
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
High beam lights raconi General PT Cruiser Discussions 4 23 Aug 2015 01:52 am
High Beam on 2001 LE Jassy General PT Cruiser Discussions 1 06 Jul 2013 12:32 pm
Stuck on high beams Agnav General PT Cruiser Discussions 2 08 Jun 2011 08:02 am
High Beams Stopper Working reh8388 General PT Cruiser Discussions 3 25 Aug 2010 07:30 am
Low Beams and High Beams jingks Exterior & Interior Styling 3 24 Jan 2008 03:16 pm


All times are GMT -5. The time now is 07:51 am.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors