PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > General PT Cruiser Discussions

PT Cruiser Forum

Advertisements
PT missing

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 07 May 2016, 12:01 pm
Fresh Cruiser
 
Join Date: May 2016
Posts: 1
Default PT missing

2005 PT it starts and runs but is missing badly have put new crank cam sensors plugs check the compression still missing anyone have any suggestions
Reply With Quote
  #2 (permalink)  
Old 07 May 2016, 12:13 pm
Obsessed Cruiser
 
Join Date: Aug 2014
Location: Thousand Oaks, CA
Posts: 7,339
Default Re: PT missing

Welcome to the forum.

We need more information for a complete diagnosis. How many miles, last time the timing belt was replaced, everything that was done to try and fix this problem.

If its missing badly the engine light should be on. What engine trouble codes are you getting? Do you have your own OBDII Scan Tool?
__________________
If at First You Don't Succeed - Try, Try Again
Reply With Quote
  #3 (permalink)  
Old 07 May 2016, 12:41 pm
NitroPT's Avatar
Obsessed Cruiser
 
Join Date: Jun 2012
Location: USA kalyfornia
Posts: 15,822
Default Re: PT missing

Welcome to the forum


Read this

PT problems read this FIRST
__________________
To view larger pictures simply "click " on the picture!

Dalai Lama
"Share you knowledge. It's the best way to achieve immortality."
ASE MASTER TECHNICIAN
Reply With Quote
  #4 (permalink)  
Old 07 May 2016, 05:49 pm
Veteran Cruiser
 
Join Date: Aug 2015
Location: Lake Wales, FL
Posts: 4,870
Default Re: PT missing

Gee, let's see. Plugs, wires, clogged air filter, dirty injectors, filthy throttle body, etc., ect. WE NEED MORE INFORMATION!
__________________


Aspire to inspire before you expire.
Reply With Quote
  #5 (permalink)  
Old 07 May 2016, 08:34 pm
Fk5 Fk5 is offline
Senior Cruiser
 
Join Date: Jul 2011
Location: Colesville, MD
Posts: 1,850
Default Re: PT missing

Turbo or not a turbo? Which manifold? Is it just missing or are you getting a code? If you're getting a code, which code? Etc. etc.
__________________
2003 GT 5 speed
162,000 miles
Reply With Quote
  #6 (permalink)  
Old 08 May 2016, 06:34 am
SvenCruiser's Avatar
Young Cruiser
 
Join Date: Feb 2016
Location: Tall mountains
Posts: 61
Default Re: PT missing

Ha,I thought you meant it was stolen
__________________
PT CRUISER 2.2 CRD Turbodiesel

Reply With Quote
  #7 (permalink)  
Old 08 May 2016, 07:13 am
Obsessed Cruiser
 
Join Date: Sep 2001
Posts: 27,744
Default Re: PT missing

Quote:
Originally Posted by SvenCruiser View Post
Ha,I thought you meant it was stolen
So did I.
__________________
Rules of the forum have been updated as of *07/07/2019* Please read them over.

- All decisions by the Moderator are semi-permanent, can and may be changed at his discretion but definitely will be the final word. Any action performed by the Administrator or Moderators are not to be discussed on the forum.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Missing at idle VegasPTGT Tech & Performance Forum 3 25 Oct 2013 06:49 pm
What am I missing? Jacob Tech & Performance Forum 0 04 Aug 2011 09:12 am
The missing key careyk General PT Cruiser Discussions 3 09 Apr 2009 02:33 pm
MISSING AGAIN/HELP kromans Turbo Performance 8 24 Jan 2005 11:59 am
missing horn cruisergt General Turbo Discussions 10 23 May 2003 12:01 am


All times are GMT -5. The time now is 07:44 pm.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors