PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > General PT Cruiser Discussions

PT Cruiser Forum

Advertisements
I idle eyes my PT but not when it is high

 
Like Tree18Likes

Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 26 May 2016, 11:52 pm
GolfGirl's Avatar
Fresh Cruiser
 
Join Date: May 2016
Location: KIALUA, HAWAII
Posts: 30
Default I idle eyes my PT but not when it is high

Aloha everyone I have an 03 turbo and all of the sudden the idle rpm jumped to 3800 at idle. while driving, if I put it to the carpet, runs and responds normally. But at idle too high. It sounds like a vacuum leak midway in front under plenum, but I cant see any vac lines there. I sprayed starting fluid in that area and the engine began to settle the idle and tried to stall but I stopped spraying and the idle went high again. the sucking sound I am hearing is a noise level equal to pulling the air box intake hose off the throttle body. What the heck could it be?
Reply With Quote
  #2 (permalink)  
Old 27 May 2016, 12:22 am
Obsessed Cruiser
 
Join Date: Aug 2014
Location: Thousand Oaks, CA
Posts: 7,338
Default Re: I idle eyes my PT but not when it is high

I would suggest checking the vacuum hoses for leaks. Physically check the hoses for cracks. Check the hose going to the throttle body.
__________________
If at First You Don't Succeed - Try, Try Again
Reply With Quote
  #3 (permalink)  
Old 27 May 2016, 12:28 am
GolfGirl's Avatar
Fresh Cruiser
 
Join Date: May 2016
Location: KIALUA, HAWAII
Posts: 30
Default Re: I idle eyes my PT but not when it is high

Quote:
Originally Posted by ptcruisersteve View Post
I would suggest checking the vacuum hoses for leaks. Physically check the hoses for cracks. Check the hose going to the throttle body.
Thanks Steve! Do you have a link to a diagram of the vac. lines, Haven't found one yet but looking. Thanks again
Reply With Quote
  #4 (permalink)  
Old 27 May 2016, 12:33 am
Obsessed Cruiser
 
Join Date: Aug 2014
Location: Thousand Oaks, CA
Posts: 7,338
Default Re: I idle eyes my PT but not when it is high

There should be one on the sticker on the radiator support when you open the hood. Let me know if you don't see it.
__________________
If at First You Don't Succeed - Try, Try Again
Reply With Quote
  #5 (permalink)  
Old 27 May 2016, 03:56 am
GolfGirl's Avatar
Fresh Cruiser
 
Join Date: May 2016
Location: KIALUA, HAWAII
Posts: 30
Default Re: I idle eyes my PT but not when it is high

Quote:
Originally Posted by ptcruisersteve View Post
There should be one on the sticker on the radiator support when you open the hood. Let me know if you don't see it.

UPDATE: I looked for the sticker but it is missing. I did find a shop manual online for my car and have been reading. I also check out some euro pt sites and decided to try spraying starting fluid around the area that I think I am hearing the vacuum leak. So I fired it up and right away "high idle" no kickdown response just high idle. I start spraying on all the hose connecti0ns, no change. As I'm spraying on and around the fuel rail and I get to the #4 cyl. injector, the idle starts dropping. So I keep spraying the #4 fuel injector and the engine almost died. Bad injector o-ring? bad injector?
I took the upper plenum off and grabbed each injector and they all move if i twist them a little. I didn't see any vacuum lines near the front of the engine where i was spraying.

Time for new injectors ? or can I get away with a upper plenum gasket and new injector o-rings"?
Reply With Quote
  #6 (permalink)  
Old 27 May 2016, 06:06 am
Fk5 Fk5 is offline
Senior Cruiser
 
Join Date: Jul 2011
Location: Colesville, MD
Posts: 1,850
Default Re: I idle eyes my PT but not when it is high

Since you are in there I would certainly change the gasket and all the O-rings, but I am betting that your problem was the intake gasket. Hopefully your lower is fine. Otherwise you'll have to do it all over again to pull the lower and swap that gasket. How did the plenum gasket look?
__________________
2003 GT 5 speed
162,000 miles
Reply With Quote
  #7 (permalink)  
Old 27 May 2016, 07:55 am
Veteran Cruiser
 
Join Date: Aug 2015
Location: Lake Wales, FL
Posts: 4,867
Default Re: I idle eyes my PT but not when it is high

I also have an 03 GT. Here's a pic of my vacuum routing diagram. I hope it helps as it sure sounds like that's your problem.

__________________


Aspire to inspire before you expire.
Reply With Quote
  #8 (permalink)  
Old 27 May 2016, 09:59 am
Fk5 Fk5 is offline
Senior Cruiser
 
Join Date: Jul 2011
Location: Colesville, MD
Posts: 1,850
Default Re: I idle eyes my PT but not when it is high

Did this car throw any codes? CEL on?

That is a pretty high idle. I would expect at least a P0121
__________________
2003 GT 5 speed
162,000 miles
Reply With Quote
  #9 (permalink)  
Old 27 May 2016, 11:31 am
GolfGirl's Avatar
Fresh Cruiser
 
Join Date: May 2016
Location: KIALUA, HAWAII
Posts: 30
Default Re: I idle eyes my PT but not when it is high

Quote:
Originally Posted by Fk5 View Post
Since you are in there I would certainly change the gasket and all the O-rings, but I am betting that your problem was the intake gasket. Hopefully your lower is fine. Otherwise you'll have to do it all over again to pull the lower and swap that gasket. How did the plenum gasket look?
Thanks for reply Fk5, that's kinda my thinking. The Plenum gasket looked good, OEM even (hard plastic kinda) except for a bit of moisture near the #4 intake. Im not sure if it was from or what it was. Could of been from when I was spraying starting fluid on the injector, because I sprayed it until the engine almost died. OR it could have been the rum and coke that I poured on the injector to see if it made any difference, which it did also just not as drastic . I had one foot in the bag by that time. Could that injector be bad? I sounds like that cylinder isnt firing even with the idle so high, but when I rap on it the response is normal it's all getty-up blast-off.
Reply With Quote
  #10 (permalink)  
Old 27 May 2016, 11:46 am
GolfGirl's Avatar
Fresh Cruiser
 
Join Date: May 2016
Location: KIALUA, HAWAII
Posts: 30
Default Re: I idle eyes my PT but not when it is high

Quote:
Originally Posted by chuzz View Post
I also have an 03 GT. Here's a pic of my vacuum routing diagram. I hope it helps as it sure sounds like that's your problem.

Thanks for the photo Chuzz. My eyes are a bit fuzzy this morning, but I think I'll be able to follow the lines from the pic. I tried to make it larger, by rubbing it, lol just kidding, but it became pixelated. All good I figure it out. Thanks again
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
High Idle. P 0507 Arizcruiser Tech & Performance Forum 8 30 Jan 2016 04:43 pm
high idle JRH01cruiser Tech & Performance Forum 2 01 Sep 2015 11:52 pm
Replaced W/P, Now Revving High/Low in Idle andrew234 General Turbo Discussions 5 14 Aug 2013 10:59 pm
High idle 2001cruising Tech & Performance Forum 17 12 Sep 2012 09:17 am
2003 MT High Idle Sturdevant General Turbo Discussions 6 11 Sep 2007 09:55 pm


All times are GMT -5. The time now is 04:14 pm.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors