PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > General PT Cruiser Discussions

PT Cruiser Forum

Advertisements
oil light oil sensor

 
Like Tree7Likes
  • 3 Post By NitroPT
  • 2 Post By Grasshopper77
  • 2 Post By VsandFords

Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 07 Jul 2016, 10:19 am
Regular Cruiser
 
Join Date: Feb 2016
Posts: 115
Default oil light oil sensor

So beginning of April I got the typical blinking oil light while at a stop and going away after accelerating. Swapped out the sensor right away with a o riellys brand sensor. Bwd i think it's the brand. Now last week the light came back on. This time it's on all times not blinking. Sometimes goes away after restarting but comes back on eventually. I have another o Rilleys brand new sensor I'll drop in after work today. Hopefully it's just the sensor and not an actual oil issue. How can i check the oil pressure? Any other tips regarding this issue? Thanks fellas.
Reply With Quote
  #2 (permalink)  
Old 07 Jul 2016, 11:20 am
Regular Cruiser
 
Join Date: Feb 2016
Posts: 115
Default Re: oil light oil sensor

What's the correct oil pressure at idle and at higher Rpm for the 2.4 turbo motor?
Reply With Quote
  #3 (permalink)  
Old 07 Jul 2016, 11:55 am
NitroPT's Avatar
Obsessed Cruiser
 
Join Date: Jun 2012
Location: USA kalyfornia
Posts: 15,811
Default Re: oil light oil sensor

I would say it is a good possibility that you may have unknowingly damaged the new sensor during installation? It is easy to damage I have done it myself.

Do not use any sealant on the threads. Be careful not to over tighten and clean all the electrical connectors with an electrical parts cleaner.

We use many sensor brands in the shop and have used specifically O- Riley's brand parts at times without problems.

I prefer Airtex or BWD myself.
__________________
To view larger pictures simply "click " on the picture!

Dalai Lama
"Share you knowledge. It's the best way to achieve immortality."
ASE MASTER TECHNICIAN
Reply With Quote
  #4 (permalink)  
Old 08 Jul 2016, 12:53 pm
Regular Cruiser
 
Join Date: Feb 2016
Posts: 115
Default Re: oil light oil sensor

I changed the oil pressure sensor the light hasn't come back on I'm still trying to find out how to properly check my engine oil pressure any advice would be appreciated specifically the correct oil pressure specifications thank you all.
Reply With Quote
  #5 (permalink)  
Old 08 Jul 2016, 02:26 pm
Cool Cruiser
 
Join Date: May 2016
Posts: 337
Default Re: oil light oil sensor

Not sure if this helps but according to the manual the switch is normally closed and changes to open onincreasing pressure of 7psi and changes back to close on decreasing pressure of 2 to 4 psi. There is a sticky for the chrysler manual on this site. try downloading it and give it a search for the time being.
Reply With Quote
  #6 (permalink)  
Old 08 Jul 2016, 03:03 pm
VsandFords's Avatar
Senior Cruiser
 
Join Date: Apr 2014
Location: Gladewater, Texas
Posts: 1,915
Default Re: oil light oil sensor

The easiest way I know to check pressure is to pull the sending unit and install a gauge. You can do this just to test, or add a gauge along with the light.
[IMG][/IMG]
This is the gauge in my 01. This pic was taken while idling in the driveway. I added the 2 gauge pod with a volt meter and electric oil pressure. The new sending unit has 2 prongs. One for the gauge and the other to attach to the original wire going to the light.
__________________
Life is just a bowl of jello, full of fruits and nuts.

2001 LE, auto, billet grille, tall shifter, polished aluminum spare, K&N filter and Hedman hedder. Why a header? Because it makes me happy!


Reply With Quote
  #7 (permalink)  
Old 22 Aug 2016, 01:04 am
Fresh Cruiser
 
Join Date: Aug 2010
Location: Houston
Posts: 8
Default Re: oil light oil sensor

This reply may be a little .However I had replaced the oil pressure sending unit/switch and the light still was not going out .Returned the switch ,had the same results. I read in some forum response that a thorough cleaning of the connector had eliminated the erratic response of the light.
Reply With Quote
  #8 (permalink)  
Old 22 Aug 2016, 08:40 am
rob302's Avatar
Veteran Cruiser
 
Join Date: Jul 2016
Location: Darien, IL | Forest Park, IL
Posts: 3,522
Default Re: oil light oil sensor

Quote:
Originally Posted by sxcv92 View Post
This reply may be a little .However I had replaced the oil pressure sending unit/switch and the light still was not going out .Returned the switch ,had the same results. I read in some forum response that a thorough cleaning of the connector had eliminated the erratic response of the light.

if you're saying yours won't go out, the sensor is just a on/off switch. get a piece of wire and jump wire in the connector to a good ground and see if it goes out. also inspect the connector.
Reply With Quote
  #9 (permalink)  
Old 30 Aug 2016, 03:39 pm
AyeCantSeeYou's Avatar
Cool Cruiser
 
Join Date: May 2011
Location: FL Gulf Coast
Posts: 206
Default Re: oil light oil sensor

Quote:
Originally Posted by VsandFords View Post
The easiest way I know to check pressure is to pull the sending unit and install a gauge. You can do this just to test, or add a gauge along with the light.
[IMG][/IMG]
This is the gauge in my 01. This pic was taken while idling in the driveway. I added the 2 gauge pod with a volt meter and electric oil pressure. The new sending unit has 2 prongs. One for the gauge and the other to attach to the original wire going to the light.
I'm going to have mine fitted like yours at the beginning of the year. The oil pump in mine was pumping just enough to keep the light off, but it was low enough long enough to cause a new engine to have to go in.
__________________
2002 PT LE, loaded - stock
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
CrankShaft Sensor/CamShaft Sensor Questions PTMomma Tech & Performance Forum 8 12 Aug 2014 01:43 pm
crankshaft position sensor veses knock sensor BeagleDad Tech & Performance Forum 6 13 Feb 2012 06:10 pm
Engine light due to camshaft sensor... fefeemery General PT Cruiser Discussions 28 18 Jul 2010 06:38 am
Oil pressure light problem - just replaced cam sensor jeremyrocksursox Tech & Performance Forum 5 02 Jul 2010 10:22 pm
Cam Sensor code changed sensor still dead RottenKid Tech & Performance Forum 8 18 Nov 2008 08:17 am


All times are GMT -5. The time now is 05:44 am.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors