PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > General PT Cruiser Discussions

PT Cruiser Forum

Advertisements
PT Just Died... Help Please!

 
Like Tree17Likes

Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 09 Jul 2016, 12:16 pm
Young Cruiser
 
Join Date: Aug 2012
Posts: 67
Default PT Just Died... Help Please!

Hello All, So Yesterday i took off to work and less than a block away my PT just shut down. No stuttering Just dead. Turns over but wont fire. Doing the key dance shows no codes. I hear the fuel pump. I have no spark. there is no voltage to the coil pack. I checked all fuses. Anyone know where to go from here? Is there a way to test the PCM? Do all codes show up doing the key dance or do i need a code scanner? Its a 2008 base model.
Reply With Quote
  #2 (permalink)  
Old 09 Jul 2016, 12:38 pm
quicksilverdon's Avatar
Obsessed Cruiser
 
Join Date: Nov 2003
Location: Felton, Delaware
Posts: 20,501
Default Re: PT Just Died... Help Please!

How many miles?
Was timing belt changed?
When it turns over, does it sound as if it's turning over faster than usual?
__________________
"Anti-intellectualism has been a constant thread winding its way through our political and cultural life,
nurtured by the false notion that democracy means that 'my ignorance is just as good as your knowledge."
Isaac Asimov"

'05 Limited Turbo Lite, (Silver, of course)4-wheel ABS, Sunroof, Spoiler. Mods: E&G Classic grill, K&N FIPK, BTG duals, rear lowered 1.5", LED washer lights, $20 catch can, Aoogah horn, Weatherflectors, Sunroof Deflector, Fuzzy Dice, rear logo flames, rear pinstripe graphic, Gen3 Taillights, rear sway bar, hood struts, Strut bar.
Traded in '02 Silver Touring Edition w/87,000 miles
Reply With Quote
  #3 (permalink)  
Old 09 Jul 2016, 12:46 pm
Obsessed Cruiser
 
Join Date: Aug 2014
Location: Thousand Oaks, CA
Posts: 7,338
Default Re: PT Just Died... Help Please!

Quote:
Originally Posted by cinikal View Post
Hello All, So Yesterday i took off to work and less than a block away my PT just shut down. No stuttering Just dead. Turns over but wont fire. Doing the key dance shows no codes. I hear the fuel pump. I have no spark. there is no voltage to the coil pack. I checked all fuses. Anyone know where to go from here? Is there a way to test the PCM? Do all codes show up doing the key dance or do i need a code scanner? Its a 2008 base model.
I would suggest first removing the camshaft sensor and see if the camshaft is turning. If it is not turning then that will explain the lack of spark.
__________________
If at First You Don't Succeed - Try, Try Again
Reply With Quote
  #4 (permalink)  
Old 09 Jul 2016, 05:30 pm
Young Cruiser
 
Join Date: Aug 2012
Posts: 67
Default Re: PT Just Died... Help Please!

Thank you both for this bit of info.
car has 126,000 miles
Timing Belt Never Changed

And no the camshaft is not spinning!!!

Any link to how to do a Timing belt replacement?
As a seasoned vet with mechanics... Skill level to do the job?!?!
Reply With Quote
  #5 (permalink)  
Old 09 Jul 2016, 06:39 pm
Obsessed Cruiser
 
Join Date: Aug 2014
Location: Thousand Oaks, CA
Posts: 7,338
Default Re: PT Just Died... Help Please!

I would suggest you introduce yourself to the forum. Tell us about your PT Cruiser and how you came across this forum.

The PT Cruiser is not an easy engine to replace the timing belt. Many members here have had to take it apart several times to get the timing belt installed correctly.

You should spend some time going through the threads here on this forum on replacing the timing belt. Some of the threads have good information on how to make sure the timing belt is aligned correctly.
__________________
If at First You Don't Succeed - Try, Try Again

Last edited by ptcruisersteve; 09 Jul 2016 at 06:45 pm.
Reply With Quote
  #6 (permalink)  
Old 10 Jul 2016, 01:04 am
Regular Cruiser
 
Join Date: Mar 2011
Posts: 164
Default Re: PT Just Died... Help Please!

If the cam isn't spinning at crank, yeah, the timing belt has snapped. There are excellent tutorials but this is not a job for the feint of heart. In fact, it is a royal PIA. And the timing must be perfect, if you are 1/2 tooth off, the car will run poorly.
Reply With Quote
  #7 (permalink)  
Old 10 Jul 2016, 03:51 pm
AyeCantSeeYou's Avatar
Cool Cruiser
 
Join Date: May 2011
Location: FL Gulf Coast
Posts: 206
Default Re: PT Just Died... Help Please!

While you're changing the timing belt, go ahead and change the water pump too. You're right there at it and it runs off the belt. May as well check the lower motor mount while you're in that area.
__________________
2002 PT LE, loaded - stock
Reply With Quote
  #8 (permalink)  
Old 10 Jul 2016, 04:26 pm
Veteran Cruiser
 
Join Date: Aug 2015
Location: Lake Wales, FL
Posts: 4,867
Default Re: PT Just Died... Help Please!

She's absolutely right about that motor mount. It's the one in the middle with the torx head bolt that holds it in place.
rckstein and rsrocket1 like this.
__________________


Aspire to inspire before you expire.
Reply With Quote
  #9 (permalink)  
Old 10 Jul 2016, 05:57 pm
Obsessed Cruiser
 
Join Date: Aug 2014
Location: Thousand Oaks, CA
Posts: 7,338
Default Re: PT Just Died... Help Please!

Quote:
Originally Posted by chuzz View Post
She's absolutely right about that motor mount. It's the one in the middle with the torx head bolt that holds it in place.
I would suggest you replace the center mount when you replace the timing belt and waterpump. Some members have had to pay more money to replace the center motor mount only after putting 10 to 20 thousand miles on it.
rckstein and rsrocket1 like this.
__________________
If at First You Don't Succeed - Try, Try Again
Reply With Quote
  #10 (permalink)  
Old 11 Jul 2016, 09:08 am
cruserdad1976's Avatar
Obsessed Cruiser
 
Join Date: Sep 2009
Location: st james mo
Posts: 8,217
Default Re: PT Just Died... Help Please!

ideler pulleys need replaced and you are already there
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Key fob died War_Eagle General PT Cruiser Discussions 3 18 Apr 2016 05:58 pm
PT DIED thequadx General PT Cruiser Discussions 9 22 Oct 2012 07:50 pm
help pt died ;( oldskoolgaz Tech & Performance Forum 3 27 Dec 2011 01:56 pm
PT Died lowpt Tech & Performance Forum 8 21 Dec 2011 02:19 pm
Car just died loudassz Tech & Performance Forum 5 28 Apr 2011 06:24 pm


All times are GMT -5. The time now is 09:44 pm.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors