PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > General PT Cruiser Discussions

PT Cruiser Forum

Advertisements
Dumbfounded and confused

 
Like Tree16Likes

Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 08 Aug 2016, 01:59 pm
AyeCantSeeYou's Avatar
Cool Cruiser
 
Join Date: May 2011
Location: FL Gulf Coast
Posts: 206
Default Dumbfounded and confused

How can a rod bearing be bad if there is no engine knock? Don't they always make a sound when bad? My PT never had a knocking sound. I'm still reeling from the phone call this morning from the shop my PT is at that after 4 weeks being in there and $1100 later in parts and labor, I need a new engine.
__________________
2002 PT LE, loaded - stock
Reply With Quote
  #2 (permalink)  
Old 08 Aug 2016, 02:08 pm
NitroPT's Avatar
Obsessed Cruiser
 
Join Date: Jun 2012
Location: USA kalyfornia
Posts: 15,822
Default Re: Dumbfounded and confused

If they used an audio scope the noise of a bad engine bearing may have been detected.

You could have failing engine bearing(s) present, no noise unless under a load.

There are lots more examples....
I would recommend to ask how they determined it to be a bad bearing.
chuzz likes this.
__________________
To view larger pictures simply "click " on the picture!

Dalai Lama
"Share you knowledge. It's the best way to achieve immortality."
ASE MASTER TECHNICIAN
Reply With Quote
  #3 (permalink)  
Old 08 Aug 2016, 02:37 pm
Veteran Cruiser
 
Join Date: Aug 2015
Location: Lake Wales, FL
Posts: 4,872
Default Re: Dumbfounded and confused

I agree with NitroPT. They might be trying to take advantage of the fact that you're a female and they think you can be easily fooled.
__________________


Aspire to inspire before you expire.
Reply With Quote
  #4 (permalink)  
Old 08 Aug 2016, 03:31 pm
Obsessed Cruiser
 
Join Date: Aug 2014
Location: Thousand Oaks, CA
Posts: 7,339
Default Re: Dumbfounded and confused

On one of my previous cars I had a rod knock and put STP in it. After driving it for 50,000 miles with STP I got rid of the car and never touched the engine. But as other members posted get another opinion and confirm you really have a rod knock.
__________________
If at First You Don't Succeed - Try, Try Again
Reply With Quote
  #5 (permalink)  
Old 08 Aug 2016, 03:44 pm
AyeCantSeeYou's Avatar
Cool Cruiser
 
Join Date: May 2011
Location: FL Gulf Coast
Posts: 206
Default Re: Dumbfounded and confused

Mechanic said the lower bearings are shot and aren't pulling oil like they should be, that the 'old' oil pump had low pressure and wasn't able to keep up. I asked if there was any detectable engine noise, he said no. He said they didn't know it was the bearings until they pulled the oil pan off and visually saw it. They just did that this morning! I'm just completely shocked that after telling me my car wouldn't need anything else after replacing the oil pump and the belt/pulleys for the pistons that I get this phone call. I called back and told them that I don't feel like I should have to pay for the labor to install another motor after they've had my car up there for the past 4 weeks and just now realized, $1100 later, that the engine is shot.

My PT never ran low on oil either. I always kept it changed and checked.
__________________
2002 PT LE, loaded - stock
Reply With Quote
  #6 (permalink)  
Old 08 Aug 2016, 03:59 pm
Handy_Cruiser's Avatar
Obsessed Cruiser
 
Join Date: Oct 2013
Location: Arkansas
Posts: 10,435
Default Re: Dumbfounded and confused

This all sounds very fishy. Very few on this forum have reported the issues you seem to be having with your PT engine. It's sounds like you could well be the victim of dishonest mechanics.

Here's my opinion for what it's worth. Let's say your oil pressure issue really was the oil pump and not just a bad sending unit which is much more likely. A good and intelligent mechanic would have likely told you at that point that your 2002 PT is only worth so much and if that didn't fix it, it would likely be time for another car. There's no reason to run the shop bill up further.

But for them to spend $1,100 on a car likely not worth more that $2,000, they do not seem to have your best interest at heart. And that's still assuming your oil pump and now rod and main bearings are bad. Shame on those guys.

Salvage non-turbo engines are only $250 where I live. And they may be similarly priced where you live. If me, I would weigh any further repairs against the cost of a salvage engine and the value of the cars itself. And whatever future mechanic work I decide I needed, it would be at another shop.
cruserdad1976 likes this.
__________________

Last edited by Handy_Cruiser; 08 Aug 2016 at 04:02 pm.
Reply With Quote
  #7 (permalink)  
Old 08 Aug 2016, 04:29 pm
Obsessed Cruiser
 
Join Date: Aug 2014
Location: Thousand Oaks, CA
Posts: 7,339
Default Re: Dumbfounded and confused

What parts did they replace?

What brand oil pump did they put in the engine?

Has your oil light ever come on?

Have you had the PT Cruiser for a long time?
__________________
If at First You Don't Succeed - Try, Try Again

Last edited by ptcruisersteve; 08 Aug 2016 at 05:34 pm.
Reply With Quote
  #8 (permalink)  
Old 08 Aug 2016, 04:51 pm
NitroPT's Avatar
Obsessed Cruiser
 
Join Date: Jun 2012
Location: USA kalyfornia
Posts: 15,822
Default Re: Dumbfounded and confused

This is where I would like to see the actual estimate and work order!

There are a few unusual descriptive comments....

I would say to those that are actually a bit more auto mechanical experienced re-read post # 5 again before making more assumptions?
__________________
To view larger pictures simply "click " on the picture!

Dalai Lama
"Share you knowledge. It's the best way to achieve immortality."
ASE MASTER TECHNICIAN
Reply With Quote
  #9 (permalink)  
Old 08 Aug 2016, 04:56 pm
AyeCantSeeYou's Avatar
Cool Cruiser
 
Join Date: May 2011
Location: FL Gulf Coast
Posts: 206
Default Re: Dumbfounded and confused

It has 140,000 miles on it, give or take 1,000.

I've had it for 10 years.

6 weeks ago I had the front suspension replaced (tie rods, wheel bearings, etc) for around 900.

2 weeks after that, it was back to the shop because the oil light started coming on when I'd put my foot on the brake pedal. Did some research and found the usual cause was the oil pressure sending unit, which I went and got from auto zone and had the shop replace while I was there. Before this, though, last winter, when the temp would go below freezing, the oil light would come on, then go off when the outside temp went above freezing. Didn't think it was anything but the oil viscosity due to moving from FL to Baltimore and the weather changes. I kept the oil changed every 3000 miles, with a local Valvoline center doing all that and never noting anything odd with the oil when they changed it.

New oil pump, new spark plugs and wires, new thermostat, new chain/belt for the pistons or whatever is under those and new pulleys for that part as well, went ahead and gave the ok for a new timing belt and water pump even though I had that done 2 years ago.

Supposedly, they did a manual check of the oil pressure before saying it was the oil pump.

I'm truly at a loss as to what to think now. I asked several times if that was all it was going to need, and every time I was told yes, that would be it, there was nothing else they had found.

Shouldn't they have checked the oil pan before all this?
__________________
2002 PT LE, loaded - stock

Last edited by AyeCantSeeYou; 08 Aug 2016 at 05:33 pm.
Reply With Quote
  #10 (permalink)  
Old 08 Aug 2016, 05:10 pm
revo's Avatar
Cool Cruiser
 
Join Date: Oct 2015
Location: Buffalo NY
Posts: 214
Default Re: Dumbfounded and confused

Engine bearings protect and support the connecting rod or crankshaft enabling it to spin freely in engine. If a problem accrues will us ally give off two types of sounds a knock which would be a bearing or a sound that sounds like a pice of tin getting hit which would mean it would be a rod. But no noise doesn't fly with me.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
QUITE CONFUSED... SNARFUS Tech & Performance Forum 1 12 Jun 2015 01:02 pm
A bit confused IamN00bz General PT Cruiser Discussions 5 07 Apr 2012 02:43 pm
I'm Confused........... PTconquest Turbo Performance 21 19 Feb 2012 03:17 pm
New and Confused gitch Tech & Performance Forum 11 21 May 2011 12:55 am
Someone is a bit confused sakigt Wheels, Tires, Suspension 6 17 Dec 2003 03:02 pm


All times are GMT -5. The time now is 01:42 pm.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors