PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > General PT Cruiser Discussions

PT Cruiser Forum

Advertisements
Instrument Panel Cuts Out Randomly

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 09 Aug 2016, 07:10 pm
Fresh Cruiser
 
Join Date: Apr 2015
Posts: 14
Default Instrument Panel Cuts Out Randomly

I have a 2006 PT Cruiser (160k) miles (non-turbo) that has been acting funny lately.

It will:
1. Loser power in the instrument panel...rpm, mph, etc. will drop to nothing, but the car functions perfectly fine.

2. All of the start up icons (gas, seatbelt, whatever else) will flash as if I just turned on the car.

3. This will happen for 10 seconds or something and then everything will go back to where is is supposed to be. Two minutes later it will do it again...or 5 minutes later...randomly really.

4. The backlight will NOT turn off though. It is basically just the actual cluster panel that will not function correctly. Car runs perfectly fine when this is happening.

Ideas? Where to start?
Reply With Quote
  #2 (permalink)  
Old 09 Aug 2016, 07:14 pm
Cool Cruiser
 
Join Date: Jun 2010
Posts: 252
Talking Re: Instrument Panel Cuts Out Randomly

That same thing was common on the Neons. Some of the solder joints on the back of the cluster circuit board need to be re-soldered.

My 2006 Dodge Ram does the same thing a couple of times a week. Been going on for a few years. I am in no hurry to tear into it.
Reply With Quote
  #3 (permalink)  
Old 09 Aug 2016, 10:19 pm
Obsessed Cruiser
 
Join Date: Aug 2014
Location: Thousand Oaks, CA
Posts: 7,338
Default Re: Instrument Panel Cuts Out Randomly

I would suggest you do a battery load test first. The 2nd generation PT Cruisers don't like a drop in voltage under a load and some of the modules don't like it.

If the battery load test checks out good check the ground for the instrument cluster.
__________________
If at First You Don't Succeed - Try, Try Again
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
New afterMarket radio cuts off randomly TexasPTCruisin Tech & Performance Forum 3 11 Mar 2013 02:28 pm
Instrument Panel Removal paulrosenthal Interior Accessories Forum 11 22 May 2011 02:39 pm
INSTRUMENT PANEL CHEVELINO Tech & Performance Forum 1 10 May 2011 08:19 pm
Instrument Panel Problems sra4031 Tech & Performance Forum 1 18 Sep 2009 07:09 am
instrument panel azkruzn Interior Accessories Forum 2 06 Apr 2009 07:54 pm


All times are GMT -5. The time now is 01:44 pm.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors