PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > General PT Cruiser Discussions

PT Cruiser Forum

Advertisements
Instrument Cluster Illumination

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 10 Sep 2016, 11:12 am
Fresh Cruiser
 
Join Date: Sep 2016
Posts: 1
Question Instrument Cluster Illumination

My husband just changed the bulbs for the instrument cluster in my 2004 PT Cruiser GT. Half of the old ones were burnt out. He replaced all six bulbs (they are 74 bulbs) in the Chrysler Manual. After turning the power back on, the bulbs are not working. Any idea what the problem could be. Thanks for your help.
Reply With Quote
  #2 (permalink)  
Old 10 Sep 2016, 11:37 am
Obsessed Cruiser
 
Join Date: Aug 2015
Location: Lake Wales, FL
Posts: 5,011
Default Re: Instrument Cluster Illumination

Maybe he didn't get them fully seated in the sockets or he accidentally turned the dimmer switch down and forgot to turn it back up?
__________________


Aspire to inspire before you expire.
Reply With Quote
  #3 (permalink)  
Old 10 Sep 2016, 12:20 pm
Obsessed Cruiser
 
Join Date: Aug 2014
Location: Thousand Oaks, CA
Posts: 7,476
Default Re: Instrument Cluster Illumination

Welcome to the forum.

Sometimes when you buy bulbs you get a bad set. Was the new bulbs checked to be working before installing in the Instrument Cluster? Were they replaced with the same 74 bulbs?
__________________
If at First You Don't Succeed - Try, Try Again

Last edited by ptcruisersteve; 10 Sep 2016 at 12:45 pm.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Which bulb for instrument cluster? Donut Tech & Performance Forum 12 31 Mar 2016 09:59 am
Could it just be the instrument cluster? ukbeachbum General PT Cruiser Discussions 21 17 Sep 2015 08:50 pm
Instrument cluster goes dead kwells44 Tech & Performance Forum 5 02 Dec 2012 06:08 pm
Instrument Cluster failure runninlow3 Tech & Performance Forum 0 17 Nov 2011 03:14 pm
Instrument Cluster needed PTloser Classifieds: For Sale/Trade 0 23 Jul 2002 06:42 pm


All times are GMT -5. The time now is 12:09 pm.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors