PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > General PT Cruiser Discussions

PT Cruiser Forum

Advertisements
HELP Problems with hazard/signal function

 
Like Tree2Likes
  • 2 Post By muzicmax

Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 12 Sep 2016, 03:52 pm
muzicmax's Avatar
Cool Cruiser
 
Join Date: Mar 2008
Location: Great White North
Posts: 315
Exclamation HELP Problems with hazard/signal function {FIXED}

Ok here is low down,................I installed some LED turn signals and got the fast signals. A very common problem when using leds for signal lights..
Instead of using the resistors to fix the problem. I went ahead and bought a LED flasher that was supposed to have been compatible (same as the oem flasher). Yes I double checked before I replaced oem with the led flasher.
Anyways when I swapped the flashers out and turned the key on there was a noise like a zzzzz and then nothing I figured something didn't work right. I was right, nothing worked with that led flasher. I immediately replaced it with the oem flasher but now my hazard and signal lights don't work at all. I checked fuse #15 but it was good and my wipers worked. Everything else works as normal ie: brake /running lights/ headlights/ fog lights ect...
Any thoughts? I hope I didn't fry anything. Do you think mabey I have to replace the whole multifunction unit now?
Thanks for any help

UPDATE: I replaced the whole multifunction (I had a spare kicking around) and it's NOT THAT!

Another UPDATE: Turns out it was the Hazard fuse (15 amp) in the engine compartment! I had no idea it affected the signal lights, nor did I know it was even in there. Gawd I was freaking for a bit, thought maybe I had major issue happening lol!
I am not going to buy another flasher in case it happens again. Looks like I'll be using those resistors arrg there is hardly any room in there to hook them up.

Anyways maybe this thread will help someone else that has or might have the same problem. But if you feel the need to delete it then be my guest
__________________

Last edited by muzicmax; 13 Sep 2016 at 11:24 am. Reason: I SOLVED IT MYSelf!
Reply With Quote
  #2 (permalink)  
Old 12 Sep 2016, 08:13 pm
Cool Cruiser
 
Join Date: May 2016
Location: Howell, MI
Posts: 406
Default Re: HELP Problems with hazard/signal function

Could you post what LED flasher you used, so that anyone in the future won't buy the same kind.
__________________
03' Dream Cruiser Manual: 130k Stage 1, BOV, Koni Shocks, Eibach Springs/Sway Bars, TSW 18x8 Rims, Composite Manifold, 3inch Catless
Downpipe w/Cutout, Magnaflow Catback, Quaife LSD

04' GT Manual Purple PT Mileage: 95k (Died Spring 2018)
05' N/A Automatic Red PT Mileage:121k (Died summer 2017)
Reply With Quote
  #3 (permalink)  
Old 12 Sep 2016, 11:14 pm
muzicmax's Avatar
Cool Cruiser
 
Join Date: Mar 2008
Location: Great White North
Posts: 315
Default Re: HELP Problems with hazard/signal function

I bought the EP27L LED Bulb Electronic Flasher.
Funny thing is that all the research I did it said it was compatible
This is the one I bought from Napa.




This is the one I was going to buy because they said it was compatible. If you look at the part #'s it replaces my original oem flasher Part #4671 714AB and that is what the site said would work. When I called them they told me as long as it is a EP27L it doesn't matter what brand it is. It will work with your Pt

https://www.superbrightleds.com/more...Specifications
__________________

Last edited by muzicmax; 13 Sep 2016 at 11:14 am. Reason: added original part #
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
2003 PT GT turn signal problems Toolman Tech & Performance Forum 13 20 Mar 2016 01:11 pm
Turn signal activates signal...and wipers? TF3 General PT Cruiser Discussions 2 19 Feb 2013 12:48 pm
Turn signal, wiper problems dbflyer Tech & Performance Forum 1 05 Jul 2011 11:52 am
Hazard Lights Won't Turn Off crsfulk Tech & Performance Forum 7 03 May 2011 08:06 am
Road hazard warranty quicksilverdon Wheels, Tires, Suspension 1 03 Jan 2004 12:14 pm


All times are GMT -5. The time now is 05:08 am.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors