PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > General PT Cruiser Discussions

PT Cruiser Forum

Advertisements
feels like i am pulling a building

 
Like Tree1Likes
  • 1 Post By vanman

Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 18 Sep 2016, 02:50 pm
Fresh Cruiser
 
Join Date: Jun 2016
Posts: 2
Default feels like i am pulling a building

My 2007 pt crusier convertible has 96k. Suddenly, it felt like my car was pulling a building.
Even when i put it in neutral, it felt like that when it was driving down the road. So, I pulled the wheels and checked the front brakes. I decided to replace the pads w/ new ceramic pads. They seemed okay until they started smoking. Still, i felt like i was pulling a building.

I don't know if it is the timing chain, or something else. Does anyone have any ideas?
Reply With Quote
  #2 (permalink)  
Old 18 Sep 2016, 03:01 pm
Handy_Cruiser's Avatar
Obsessed Cruiser
 
Join Date: Oct 2013
Location: Arkansas
Posts: 10,556
Default Re: feels like i am pulling a building

If the engine is slow to rev even when in park, then there's a chance it's the timing belt. Failure of the belt has been reported to sometimes occur before 100,000 miles as with your PT. If this is what happened, the belt may have only slipped one tooth at the crank sprocket. If you have a check engine light, you should check to see if you have a cam and/or crank sensor code. These sometimes occur when the belt slips but not always.

To check for a slipped belt, you will need to remove #1 spark plug and get the piston all the way to the top on the compression stroke. Then remove the plug in the end of the timing belt cover and see if the marks are aligned on the cam sprockets. For me, I'd go ahead and remove the whole top portion of the timing cover so I can better tell what I am looking at.
__________________

Last edited by Handy_Cruiser; 19 Sep 2016 at 08:14 am.
Reply With Quote
  #3 (permalink)  
Old 18 Sep 2016, 03:05 pm
Obsessed Cruiser
 
Join Date: Sep 2001
Posts: 27,750
Default Re: feels like i am pulling a building

Sounds a little like the bands in the transaxle (if it's automatic) are slipping.
__________________
Rules of the forum have been updated as of *07/07/2019* Please read them over.

- All decisions by the Moderator are semi-permanent, can and may be changed at his discretion but definitely will be the final word. Any action performed by the Administrator or Moderators are not to be discussed on the forum.
Reply With Quote
  #4 (permalink)  
Old 18 Sep 2016, 03:10 pm
Fresh Cruiser
 
Join Date: Jul 2015
Location: eastern Ohio
Posts: 23
Default Re: feels like i am pulling a building

I sure the resident experts will tell more, but my wife's '07 with 93000 miles had one front brake smoking. ,and I usually go overboard, so I replaced both front calipers and hoses. The pads were OK.
Everything is good now. They say calipers could get stuck or the hoses could collapse and not release the calipers and the pads drag. I hope this might be of help....john
Handy_Cruiser likes this.
__________________



'07 PT Limited Edition ,2.4 Auto ,Pastel Yellow,Two tone grey interior. 91,000 mi

'08 HHR Panel , 2.4 Auto, Black leather interior.

'09 HHR SS Panel , 2.0 Turbocharged,5 sp, One of 216 Panel SS's made.
Reply With Quote
  #5 (permalink)  
Old 18 Sep 2016, 03:47 pm
Senior Cruiser
 
Join Date: Jan 2014
Location: SW PA
Posts: 1,357
Default Re: feels like i am pulling a building

When you installed the brakes , they should slip into the holder with out using any force to seat them. IF you forced them in they will not release. How hard was it to retract the caliper pistons? Were the pins on the caliper moving freely?
__________________
Addicted to Mopar You can tell how old I am..
65 Dodge Coronet 6 cyl 2dr Post
66 Ply Satellite with 273 engine swap to 69 340 4spd
70 340 4spd Dart Swinger "Those were the days my friend"
73 Charger SE
Had a few Vetts on the way 69, 85
Several Neons some flips
01 Sebring flip
Cruiser's 01, 220K Gone to a new home
Cruiser 03 133K Gone to a new home
Cruiser 06 110K Project Gone to new Home
Cruiser 05 Ltd 120,809 bought with broken belt Oct2015
May 16 Resurrected to once again roam the streets.

20 Miles South Of Pittsburgh
Reply With Quote
  #6 (permalink)  
Old 18 Sep 2016, 04:38 pm
Fresh Cruiser
 
Join Date: Mar 2016
Location: Florida
Posts: 7
Default Re: feels like i am pulling a building

I just went through a similar issue, turned out to be a clogged cat
Reply With Quote
  #7 (permalink)  
Old 18 Sep 2016, 05:29 pm
Obsessed Cruiser
 
Join Date: Aug 2014
Location: Thousand Oaks, CA
Posts: 7,476
Default Re: feels like i am pulling a building

Is the engine burning oil? If so how much?

Is your engine light on? If so what are the engine trouble codes?
__________________
If at First You Don't Succeed - Try, Try Again
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
parts lot cleaning up building! Thejman3 Classifieds: For Sale/Trade 23 13 Jun 2014 08:55 pm
Steering feels off davea300 Wheels, Tires, Suspension 6 07 Apr 2012 03:29 pm
This feels expensive... FanDroid General PT Cruiser Discussions 2 03 Nov 2011 07:56 pm
Building odd-shaped sub enclosure: MDF vs. Fiberglass Jtwheels2007 Sound and Security Forum 8 02 Sep 2011 10:46 am


All times are GMT -5. The time now is 11:12 am.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors