PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > General PT Cruiser Discussions

PT Cruiser Forum

Advertisements
08 Pt Cruiser- starting issues

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 30 Sep 2016, 04:22 pm
Fresh Cruiser
 
Join Date: Sep 2016
Posts: 1
Default 08 Pt Cruiser- starting issues

Turn key and get a clicking noise. The click sounds like it's the starter. I'm no mechanic, and don't know all the correct terminology. Here's what I have replaced fixed so far. I replaced the battery. I replaced the starter. I have confirmed w a voltage meter that the starter is getting sufficient amps. I thought it might have been the starter relay. I swapped it with the other relay (not sure what it's called) same issue. My only other thought, based on other PT posts is to replace the ignition switch. Anybody have any other suggestions?
Reply With Quote
  #2 (permalink)  
Old 30 Sep 2016, 04:35 pm
Obsessed Cruiser
 
Join Date: Aug 2015
Location: Lake Wales, FL
Posts: 5,009
Default Re: 08 Pt Cruiser- starting issues

Yes, I have a suggestion. Check the ground cable connector behind the battery on the driver side fender. Might be loose, dirty or broken. Look closely and clean it up and tighten it anyway.
__________________


Aspire to inspire before you expire.
Reply With Quote
  #3 (permalink)  
Old 30 Sep 2016, 04:58 pm
Obsessed Cruiser
 
Join Date: Aug 2014
Location: Thousand Oaks, CA
Posts: 7,471
Default Re: 08 Pt Cruiser- starting issues

Quote:
Originally Posted by Sgfiedlerjr View Post
Turn key and get a clicking noise. The click sounds like it's the starter. I'm no mechanic, and don't know all the correct terminology. Here's what I have replaced fixed so far. I replaced the battery. I replaced the starter. I have confirmed w a voltage meter that the starter is getting sufficient amps. I thought it might have been the starter relay. I swapped it with the other relay (not sure what it's called) same issue. My only other thought, based on other PT posts is to replace the ignition switch. Anybody have any other suggestions?

I would suggest checking voltage going to the solenoid from the ignition switch and make sure you are getting 12 volts.
__________________
If at First You Don't Succeed - Try, Try Again

Last edited by ptcruisersteve; 30 Sep 2016 at 05:39 pm.
Reply With Quote
Reply

Tags
starter issue, starter problems. pt


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
PT Cruiser Starting Issues sharkeish Tech & Performance Forum 4 13 Apr 2015 05:18 pm
PT starting Issues SaberLima General PT Cruiser Discussions 1 04 Sep 2013 11:59 pm
HELP! 2003 PT Cruiser On-going Problem with Starting Issues Nanner Tech & Performance Forum 7 05 Jul 2012 11:59 pm
2002 Pt cruiser starting issues ort102 Tech & Performance Forum 5 11 Jul 2011 07:28 pm
01 PT Cruiser starting issues rampagent69 Tech & Performance Forum 1 28 Jun 2011 09:12 am


All times are GMT -5. The time now is 09:26 pm.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors