PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > General PT Cruiser Discussions

PT Cruiser Forum

Advertisements
All gear indicators on and won't start

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 18 Oct 2016, 04:32 pm
Fresh Cruiser
 
Join Date: Oct 2016
Posts: 1
Default All gear indicators on and won't start

I got a pt turbo and all gear indicators are boxed and car won't start..the starter sounds like it's trying to activate and had starter tested and is fine..but acts like it won't start because in gear even if shifter is in park...if I disconnect battery it'll go back to normal..but then will light gears and not start again...please help.. I'm totally lost now..for next steps
Reply With Quote
  #2 (permalink)  
Old 18 Oct 2016, 06:11 pm
Obsessed Cruiser
 
Join Date: Aug 2014
Location: Thousand Oaks, CA
Posts: 7,476
Default Re: All gear indicators on and won't start

Welcome to the forum.

I am suggesting that your TCM might not be processing a valid gear position.
I would suggest checking your wires and contacts going to the TCM. Your TCM might not be communicating with the PCM. Sometimes the battery fluids drip down below the battery support plate and starts getting on the wires going to the TCM. Also check the ground wire.
__________________
If at First You Don't Succeed - Try, Try Again

Last edited by ptcruisersteve; 18 Oct 2016 at 08:16 pm.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Indicators flashing. Why? NLAlston General PT Cruiser Discussions 2 08 Aug 2016 04:05 am
INDICATORS TURN SIGNALS HAZARDS PATGAS Tech & Performance Forum 9 29 Oct 2013 04:59 pm
indicators and wipers BogleLodge Tech & Performance Forum 3 28 Dec 2012 03:36 pm
New Multifunction Switch but still no indicators/hazards. Please help! vard3n General PT Cruiser Discussions 4 28 Aug 2009 12:08 pm


All times are GMT -5. The time now is 07:10 pm.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors