PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > General PT Cruiser Discussions

PT Cruiser Forum

Advertisements
Speedo/Tach Light Issues

 
Like Tree3Likes
  • 2 Post By rob302
  • 1 Post By _PTGT03

Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 27 Nov 2016, 06:01 pm
Gkon's Avatar
Senior Cruiser
 
Join Date: Jun 2015
Location: Queens, NY
Posts: 1,840
Default Speedo/Tach Light Issues

Hi all,
When I bought my PT in June 2015, some of the light bulbs for the speedo and tach were burnt out so I replaced them with LED's.

Since then, a few months ago one of the LED's started to flicker. I chalked it up to a faulty LED and replaced it with a new one from the same batch I bought when I initially swapped them out.

Two nights ago I noticed that now yet another of the bulbs is flickering.

What gives? I have to wonder if the problem is with the these LED's or if the problem is with the PT's gauge cluster as some stock bulbs were burnt out when I first bought it.

Any suggestions on how to find out, or any info about these gauge clusters having issues?

Thanks.
__________________
2002 PT Cruiser Limited, 2.4L, Automatic Transmission, Metallic Silver Paint
Reply With Quote
  #2 (permalink)  
Old 27 Nov 2016, 08:21 pm
rob302's Avatar
Veteran Cruiser
 
Join Date: Jul 2016
Location: Darien, IL | Forest Park, IL
Posts: 3,557
Default Re: Speedo/Tach Light Issues

yep. me. i put bulbs back in mine. if they burn out in another 10 years THATS FINE!!

there's a few possibilities.

1- whomever made them chose a resistor value that would illuminate brightly at 12v. unfortunately at 14v, they are slightly overloaded and slowly fail

2- the cheap ebay LED's that i bought had so little solder to attach the resistor to the lead of the LED, they break off, from vibration, heat, etc, and they flicker and quit illuminating. this happened to me..one by one. after a month or two, i couldnt even see the dash

3- (see pic) the bases on most of these are hollow all the way to the bottom divider. this way there is room internally for the resistor. unfortunately, the way they are installed the + and - can touch. the bulb in the upper right here is how close they were in the base i'm holding. i noticed the problem with these because the first one it tried failed to light up.

Capture.JPG

Last edited by rob302; 27 Nov 2016 at 08:31 pm.
Reply With Quote
  #3 (permalink)  
Old 27 Nov 2016, 08:27 pm
rob302's Avatar
Veteran Cruiser
 
Join Date: Jul 2016
Location: Darien, IL | Forest Park, IL
Posts: 3,557
Default Re: Speedo/Tach Light Issues

better pic of how close the + and - are inside the base, and where they're soldered. corrosion shown is just a bonus. this bulb as never been outside of my shop

fuyuuuufsdfsre.JPG

these are the white base ones.
the LED's that fell apart on me were a pink base. literally the resistors just fall off. no pictures of those, i got pissed and threw them all away

idk if any of that helps. take one apart!!
Handy_Cruiser and Gkon like this.

Last edited by rob302; 27 Nov 2016 at 08:32 pm.
Reply With Quote
  #4 (permalink)  
Old 27 Nov 2016, 09:15 pm
_PTGT03's Avatar
Fanatic Cruiser
 
Join Date: Oct 2015
Location: Abbotsford, British Columbia.
Posts: 768
Default Re: Speedo/Tach Light Issues

Quote:
Originally Posted by Gkon View Post
Hi all,
When I bought my PT in June 2015, some of the light bulbs for the speedo and tach were burnt out so I replaced them with LED's.

Since then, a few months ago one of the LED's started to flicker. I chalked it up to a faulty LED and replaced it with a new one from the same batch I bought when I initially swapped them out.

Two nights ago I noticed that now yet another of the bulbs is flickering.

What gives? I have to wonder if the problem is with the these LED's or if the problem is with the PT's gauge cluster as some stock bulbs were burnt out when I first bought it.

Any suggestions on how to find out, or any info about these gauge clusters having issues?

Thanks.
be careful to notice if any other lights are flickering like the overhead console or the head lights. this indicated the voltage regulator which is built into teh PCM is going bad and either live with it or replace the PCM completely.
Gkon likes this.
__________________
2003 GT M/T in Onyx Green Pearl on Michelin Pilot Sport AS 3 Plus Tires 205/50ZR17. Dark Slate Gray Interior. OEM cargo net, parcel shelf, slush mats and trunk protector, mud flaps, mopar subwoofer. Platinum edition pedals, Neon SX 2.0 steering wheel with black+grey wrapped leather cover. Generic lowering springs, KYB gas shocks, Valeo solid flywheel conversion and clutch kit. Urethane insert engine mounts. Energy suspension full body urethane bushing kit. Chrysler premium front speakers, Jenson 6x9 rears. Boston Audio 4x55W amp. Panasonic head unit with xtenzi bluetooth. 300W AC power inverter. Escort 360max and Escort Shifter ZR4, dual front+rear dash camera. stage 1 blow off valve and syked tune computer . Boost and oil pressure gauges with Turbo-Timer. Needswings 3" exhaust elbow, Electric valve actuated Y-pipe with catalytic converter. To do: coilovers, 2step controller, quaife diff, Air-Fuel Meter
Reply With Quote
  #5 (permalink)  
Old 28 Nov 2016, 08:29 am
Gkon's Avatar
Senior Cruiser
 
Join Date: Jun 2015
Location: Queens, NY
Posts: 1,840
Default Re: Speedo/Tach Light Issues

Quote:
Originally Posted by _PTGT03 View Post
be careful to notice if any other lights are flickering like the overhead console or the head lights. this indicated the voltage regulator which is built into teh PCM is going bad and either live with it or replace the PCM completely.
Good point _PTGT03. Thankfully, no other lights flicker. All is steady.
The only issues is with the gauge lights.
__________________
2002 PT Cruiser Limited, 2.4L, Automatic Transmission, Metallic Silver Paint
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
2005 turbo light speedo markings racerev PT Cruiser Convertible Forum 4 01 Feb 2016 04:55 pm
RED LIGHT IN SPEEDO?? drumrooster Tech & Performance Forum 1 20 Jul 2011 08:17 am
Speedo & Tach jumping when engine is turned off. ShayP Tech & Performance Forum 1 20 Jun 2011 12:46 pm
Tach, Speedo & gas gauge not working?! mothersonion General PT Cruiser Discussions 2 15 Sep 2008 09:12 pm
tach'd up & the "brake light" flashes Hedgapple General Turbo Discussions 4 03 Jul 2007 09:50 pm


All times are GMT -5. The time now is 09:47 pm.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors