PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > General PT Cruiser Discussions

PT Cruiser Forum

Advertisements
Waterpump and timing belt replaced recently and....

 
Like Tree13Likes

Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 27 Jan 2017, 07:31 pm
Fresh Cruiser
 
Join Date: Jan 2017
Posts: 12
Default Waterpump and timing belt replaced recently and....

So I just took my pt and had the waterpump and timing belt done at the dealership and they told me I am goin to need a idle air control motor and a serpentine belt tensioner mind you I take good care of this car and never had any issues with it idling high it's around 1700-1800 when it used to idle at most 1000 this is after I picked it up do you guys think someone advanced timing a little to much or they messed up the idle air control?
Reply With Quote
  #2 (permalink)  
Old 27 Jan 2017, 07:36 pm
Obsessed Cruiser
 
Join Date: Aug 2014
Location: Thousand Oaks, CA
Posts: 7,309
Default Re: Waterpump and timing belt replaced recently and....

Need more information.

What year is your PT Cruiser?
Is it an automatic?
Is the idle rpm at 1700 the same with the engine cold and at normal engine temperatures?
__________________
If at First You Don't Succeed - Try, Try Again
Reply With Quote
  #3 (permalink)  
Old 27 Jan 2017, 07:57 pm
Cool Cruiser
 
Join Date: Sep 2014
Location: Northridge, California Baby
Posts: 237
Default Re: Waterpump and timing belt replaced recently and....

Isn't the IAC just a valve, not a motor? I recall taking my out and cleaning it with carb cleaner once.

Having changed the tensioner just yesterday on my wife's PT, I can say it's a pretty easy and cheap job to do too.
Reply With Quote
  #4 (permalink)  
Old 28 Jan 2017, 01:05 pm
Fresh Cruiser
 
Join Date: Jan 2017
Posts: 12
Default Re: Waterpump and timing belt replaced recently and....

It's a 2.4 non turbo auto and it wasn't doing that when I brought it to them and it does it when it is cold and warm sitting at a light and the car sounds like it's racing and I hate shutting it off with it idling that high just wonder if it's the timing being advanced I never heard of a iac motor heard of valve but that's it I am mechanically inclined so I guess I will buy a valve see if it fixes it
Reply With Quote
  #5 (permalink)  
Old 28 Jan 2017, 01:06 pm
Fresh Cruiser
 
Join Date: Jan 2017
Posts: 12
Default Re: Waterpump and timing belt replaced recently and....

I'm glad it's easy to change anything I should know before I do it?
Reply With Quote
  #6 (permalink)  
Old 28 Jan 2017, 01:37 pm
Senior Cruiser
 
Join Date: Jan 2014
Location: SW PA
Posts: 1,346
Default Re: Waterpump and timing belt replaced recently and....

There are no adjustments for timing, I would be looking for a leaking air hose.
The idler on the AC/Power steering pump belt is something I do with all my timing belt changes.
If you get the idle down to 650 and it runs rough, timing is probably off a tooth.
__________________
Addicted to Mopar You can tell how old I am..
65 Dodge Coronet 6 cyl 2dr Post
66 Ply Satellite with 273 engine swap to 69 340 4spd
70 340 4spd Dart Swinger "Those were the days my friend"
73 Charger SE
Had a few Vetts on the way 69, 85
Several Neons some flips
01 Sebring flip
Cruiser's 01, 220K Gone to a new home
Cruiser 03 133K Gone to a new home
Cruiser 06 110K Project Gone to new Home
Cruiser 05 Ltd 120,809 bought with broken belt Oct2015
May 16 Resurrected to once again roam the streets.

20 Miles South Of Pittsburgh
Reply With Quote
  #7 (permalink)  
Old 28 Jan 2017, 01:58 pm
Cool Cruiser
 
Join Date: Sep 2014
Location: Northridge, California Baby
Posts: 237
Default Re: Waterpump and timing belt replaced recently and....

Quote:
Originally Posted by 01ptcruze View Post
I'm glad it's easy to change anything I should know before I do it?
Just that you need to put a new belt on with the tensioner as the old one will have warped to the old tensioner and won't sit right on the new one. I was able to pick up both parts for about $40 at the auto parts store. You need a 10mm socket for the splash guard cover and a 15 mm wrench for the tensioner.

Here's a video walk through:



As a thought, check to see that the throttle cable isn't getting hooked up on something. I ran a high idle a couple of times after some repair work and found out that my throttle cable had caught on a mis-installed guard cover or spark plug wire. Also check the throttle plate itself to be sure it's operating correctly. I saw a video recently where a PT had sucked one of those air filter sponges into the throttle body. As for the IAC valve I do suggest you try cleaning it before buying a new one.

Last edited by Renegade; 28 Jan 2017 at 02:05 pm.
Reply With Quote
  #8 (permalink)  
Old 28 Jan 2017, 08:29 pm
Fresh Cruiser
 
Join Date: Jan 2017
Posts: 12
Default Re: Waterpump and timing belt replaced recently and....

K will do I will check it out tomm and let you guys know wat I found thanks for everyone's help
Reply With Quote
  #9 (permalink)  
Old 30 Jan 2017, 12:58 pm
Fresh Cruiser
 
Join Date: Jan 2017
Posts: 12
Exclamation Re: Waterpump and timing belt replaced recently and....

Well took the idle air control valve out and cleaned it with carb and choke cleaner which it was filled with a whole lot of carbon out it back in and started it up and now it idles at 2100rpm in park and neutral and then it gets to a point where it drops to 1500rpms then starts fluttering and making the engine feel like it is going to die so needless to say I ordered a brand new one
Reply With Quote
  #10 (permalink)  
Old 30 Jan 2017, 01:57 pm
Obsessed Cruiser
 
Join Date: Aug 2014
Location: Thousand Oaks, CA
Posts: 7,309
Default Re: Waterpump and timing belt replaced recently and....

I would suggest you check to see if the PCV is working properly.
__________________
If at First You Don't Succeed - Try, Try Again
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
A/C not working after timing belt replaced 1gr8pt Tech & Performance Forum 11 31 Jul 2015 09:30 am
A/C problems after Timing Belt Replaced MichellesCruizer Tech & Performance Forum 3 01 Jun 2015 05:42 pm
replaced timing belt but no rpm cbpres Tech & Performance Forum 1 18 Jul 2012 12:08 pm
Replaced timing belt turbomangt General Turbo Discussions 0 06 Oct 2008 07:27 am
Waterpump replaced, now problems. ptguy Tech & Performance Forum 4 07 Sep 2007 05:12 pm


All times are GMT -5. The time now is 12:02 pm.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors