PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > General PT Cruiser Discussions

PT Cruiser Forum

Advertisements
2006 Cruiser turn signals and brake lights not working

 
Like Tree1Likes

Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 26 Feb 2017, 12:01 am
Fresh Cruiser
 
Join Date: Feb 2017
Posts: 7
Default 2006 Cruiser turn signals and brake lights not working

Hello all,

Recently our brake lights and turn signals stopped working. The turn signals dont work at all, front or rear, though the light blinks on the dash.

Two of the three brake lights (center and right) will work if the headlights are off, but with the headlights on they don't work at all.

Some googling suggests this maybe an issue with a fuse, or could there be a more serious electrical problem?

Any suggestions or advice is appreciated!
Reply With Quote
  #2 (permalink)  
Old 26 Feb 2017, 12:20 am
rckstein's Avatar
Obsessed Cruiser
 
Join Date: Dec 2010
Location: Euless, TX
Posts: 12,012
Default Re: 2006 Cruiser turn signals and brake lights not working

Welcome to the forum
__________________

'06 Touring Edition NA Automatic
150k Miles / Electric Blue Pearl
USMC '82 - '93
Reply With Quote
  #3 (permalink)  
Old 26 Feb 2017, 12:51 am
Obsessed Cruiser
 
Join Date: Aug 2014
Location: Thousand Oaks, CA
Posts: 6,236
Default Re: 2006 Cruiser turn signals and brake lights not working

Welcome to the forum.

Does your hazard lights work?

Does your wipers work?

Did both turn signals and brake lights stop working at the same time?
__________________
If at First You Don't Succeed - Try, Try Again

Last edited by ptcruisersteve; 26 Feb 2017 at 01:12 am.
Reply With Quote
  #4 (permalink)  
Old 26 Feb 2017, 01:28 am
Fresh Cruiser
 
Join Date: Feb 2017
Posts: 7
Default Re: 2006 Cruiser turn signals and brake lights not working

Thank you for the welcome

the hazard lights do not work

the wipers work, front and back, with the headlights on or off.

I'm unsure if they stopped working at the same time. I noticed that they weren't working at the same time, but thinking back at how some people have been reacting when I merge.. maybe they've been out for a while..
Reply With Quote
  #5 (permalink)  
Old 26 Feb 2017, 02:33 am
Young Cruiser
 
Join Date: Jan 2017
Location: Puyallup, WA
Posts: 77
Default Re: 2006 Cruiser turn signals and brake lights not working

EDIT: I went back and re-read your 1st post more closely. At 1st I thought fuse, but then read you have brake lights if the headlights are off. This now makes me think bad ground back there. Locate and clean the grounds and the problem will probably go away.

EDIT TO EDIT: Apparently there is a TIPM involved. I start getting nervous when there's a module involved. Well if it were mine, I'd still start by cleaning all the grounds I could find back there and checking all the bulbs. Beyond that I'm not going to be of much help.

Last edited by 03PTCrewser; 26 Feb 2017 at 03:22 am.
Reply With Quote
  #6 (permalink)  
Old 26 Feb 2017, 10:09 pm
Obsessed Cruiser
 
Join Date: Aug 2014
Location: Thousand Oaks, CA
Posts: 6,236
Default Re: 2006 Cruiser turn signals and brake lights not working

Does your power door locks and key remote work?
__________________
If at First You Don't Succeed - Try, Try Again
Reply With Quote
  #7 (permalink)  
Old 28 Feb 2017, 11:57 am
Fresh Cruiser
 
Join Date: Feb 2017
Posts: 7
Default Re: 2006 Cruiser turn signals and brake lights not working

Quote:
Originally Posted by ptcruisersteve View Post
Does your power door locks and key remote work?
Yes they do. I'm going to poke around in the fuse box and see if any of them look burnt out.

thanks all for your suggestions so far!
Reply With Quote
  #8 (permalink)  
Old 28 Feb 2017, 01:49 pm
LionPT's Avatar
Veteran Cruiser
 
Join Date: May 2014
Location: Central Florida
Posts: 3,900
Default Re: 2006 Cruiser turn signals and brake lights not working

Quote:
Originally Posted by jonasd View Post
Yes they do. I'm going to poke around in the fuse box and see if any of them look burnt out.

thanks all for your suggestions so far!

Fuse #3 controls the 3rd brake light.
There are no other fuses or relays for the blinkers or the brakes in the G2's. 2006-2010.
__________________

2006 Touring Edition in Cool Vanilla...aka/Ghost
Nexus 5X, Nexus 4, Nexus 7 (2013)
Reply With Quote
  #9 (permalink)  
Old 28 Feb 2017, 04:31 pm
Obsessed Cruiser
 
Join Date: Aug 2014
Location: Thousand Oaks, CA
Posts: 6,236
Default Re: 2006 Cruiser turn signals and brake lights not working

Quote:
Originally Posted by 03PTCrewser View Post
EDIT: I went back and re-read your 1st post more closely. At 1st I thought fuse, but then read you have brake lights if the headlights are off. This now makes me think bad ground back there. Locate and clean the grounds and the problem will probably go away.

EDIT TO EDIT: Apparently there is a TIPM involved. I start getting nervous when there's a module involved. Well if it were mine, I'd still start by cleaning all the grounds I could find back there and checking all the bulbs. Beyond that I'm not going to be of much help.
I would suggest checking the G302 & G303 ground connections that the tail lights,turn signals, and hazards depend on. Make sure you are making good contacts. If that is good I would check the battery voltage after you turn on your headlights. If the battery voltage goes down I would suggest checking to see if your headlights are drawing excessive current.
__________________
If at First You Don't Succeed - Try, Try Again

Last edited by ptcruisersteve; 28 Feb 2017 at 04:40 pm.
Reply With Quote
  #10 (permalink)  
Old 04 Mar 2017, 04:17 pm
Fresh Cruiser
 
Join Date: Feb 2017
Posts: 7
Default Re: 2006 Cruiser turn signals and brake lights not working

Quote:
Originally Posted by ptcruisersteve View Post
I would suggest checking the G302 & G303 ground connections
can you offer any advice on how to find these? im not sure what im looking for and havent been able to find any pictures by googling or looking in the manual.

also i checked every fuse in the box and none was burnt out. I took the rear lights out and the bulbs were fine and the wiring looked fine to me but im not really sure what to look for. no obvious frayed or old looking wires though. not sure how to go about taking out the front lights.

also another thing i noticed is that all brake lights come on when the e-brake is on (even when the headlights are on). (as opposed to only the middle and right when the headlights are off, and none when the headlights are on)

thanks again for any tips or advice
Reply With Quote
Reply

Tags
2006, brake lights, brakes, fuse, turn signals


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Turn Signals Lighting Up with Brake Lights PentastarThunder General PT Cruiser Discussions 8 03 Feb 2016 09:58 am
Turn signals,wipers,brights not working 2006 Pinball General PT Cruiser Discussions 11 31 Oct 2015 08:20 pm
2006 Cruiser Turn signals and Hazards libilou Tech & Performance Forum 28 17 Sep 2014 06:21 am
05 Touring turn signals working & not working angel66rose Tech & Performance Forum 5 11 Dec 2013 09:34 am
Turn Signals Not Working Indynick General PT Cruiser Discussions 9 15 Sep 2004 03:25 pm


All times are GMT -5. The time now is 06:40 am.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors