PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > General PT Cruiser Discussions

PT Cruiser Forum

Advertisements
A/C quit today. worked yesterday !

 
Like Tree4Likes

Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 15 Jun 2017, 09:11 pm
Fresh Cruiser
 
Join Date: Feb 2017
Posts: 31
Default A/C quit today. worked yesterday !

Hi All.
leaving work in the 05 turbo today turned A/C on nothing but hot air all the way home . worked fine yesterday. put the A/C pro pressure gauge on the low pressure line holding 35 Lbs. same as always. both A/C lines are hot to the touch. the compressor is not turning on. the radiator fan turns on when the switch on the dash is turned on. i switched the relay with the starter relay. still nothing. checked the power at the relay with the switch on two positive and one negative. so thats correct. jumped the line to the compressor at the relay direct from the battery still nothing. the fuse is good. what do you think ?
i changed the evaporator back in the spring because it was leaking freon through the dash vents. i refilled it with A/C pro and a can of stop leak. everything worked perfect untill today.
thanks for your help.
by the way the 02 NA with 200,000 miles A/C works perfect.
jim.
Reply With Quote
  #2 (permalink)  
Old 15 Jun 2017, 10:09 pm
Young Cruiser
 
Join Date: Mar 2014
Location: Tampa
Posts: 73
Default Re: A/C quit today. worked yesterday !

Not sure if this will work on the PT, but other cars u have owned, I would remove the low pressure switch lead from the sensor and put a jumper wire connecting the two pins on the lead. If the compressor kicks on and cool air returns you have a bad low pressure switch.
__________________
2003 GT
Reply With Quote
  #3 (permalink)  
Old 15 Jun 2017, 10:27 pm
Fresh Cruiser
 
Join Date: Feb 2017
Posts: 31
Default Re: A/C quit today. worked yesterday !

going to try it tommorow. thanks.
Reply With Quote
  #4 (permalink)  
Old 18 Jun 2017, 02:12 pm
Fresh Cruiser
 
Join Date: Feb 2017
Posts: 31
Default Re: A/C quit today. worked yesterday !

i jumped the low pressure switch and the compressor turned on right away. the pressure gauge dropped to "0" on the refill can. ( i`m thinking the 35 lbs reading on the gauge was the pressure in the can ) so i added freon to 35 lbs in the system the A/C started working and blowing cold air. it worked all the way to work "40 mins" when i left work 8 hrs latter no cold air. so i guess i have a large leak some where.
Reply With Quote
  #5 (permalink)  
Old 20 Jun 2017, 10:02 pm
Young Cruiser
 
Join Date: Mar 2015
Location: Liberty MO
Posts: 61
Default Re: A/C quit today. worked yesterday !

Call me crazy, but I've taken to replacing the low-pressure switches on all my PTs. While problems may not be readily apparent, 2 of 4 now operate more consistently when it comes to blowing cold air. Seems worth the $15 the switch costs.
Reply With Quote
  #6 (permalink)  
Old 25 Jun 2017, 03:51 pm
Fresh Cruiser
 
Join Date: Sep 2014
Posts: 45
Default Re: A/C quit today. worked yesterday !

Same problem on my '03 GT Turbo. Tried taking low pressure switch connection apart; no luck. Does it simply pull apart or is there one more Chrysler trick to getting the lead off? Thanks in advance.
Reply With Quote
  #7 (permalink)  
Old 25 Jun 2017, 07:52 pm
VsandFords's Avatar
Senior Cruiser
 
Join Date: Apr 2014
Location: Gladewater, Texas
Posts: 1,378
Default Re: A/C quit today. worked yesterday !

There is a tap you have to press.
[IMG][/IMG]
rsrocket1 likes this.
__________________
Life is just a bowl of jello, full of fruits and nuts.

2001 LE, auto, billet grille, tall shifter, polished aluminum spare, K&N filter and Hedman hedder. Why a header? Because it makes me happy!

Reply With Quote
  #8 (permalink)  
Old 25 Jun 2017, 10:02 pm
Fresh Cruiser
 
Join Date: Sep 2014
Posts: 45
Default Re: A/C quit today. worked yesterday !

Quote:
Originally Posted by VsandFords View Post
There is a tap you have to press.
[IMG][/IMG]
Thank you.
Reply With Quote
  #9 (permalink)  
Old 25 Jun 2017, 10:10 pm
Gkon's Avatar
Senior Cruiser
 
Join Date: Jun 2015
Location: Queens, NY
Posts: 1,630
Default Re: A/C quit today. worked yesterday !

My '02 N/A is doing exactly the same thing.
__________________
2002 PT Cruiser Limited, 2.4L, Automatic Transmission, Metallic Silver Paint
Reply With Quote
  #10 (permalink)  
Old 29 Jun 2017, 06:10 pm
Fresh Cruiser
 
Join Date: Feb 2017
Posts: 31
Default Re: A/C quit today. worked yesterday !

progress report on the A/C i found a bad seal at the firewall. it looks like a aluminum washer with a red "O" ring inside. there are two of them one is 1/2" the other is 5/8" . so i bought a new one $18.00 at the dealer. i found a lot of oil around the mounting base and on the insulation on the firewall where this seal is located so i expected it was leaking.. so i recharged it and will see tomorrow if it holds a charge.
i did buy a new Accumulator because i seen oil on the driveway under the firewall. after removing my original Accumulator it still had oil in it so it was not leaking. i put it back on. and placed the new Accumulator back in the box.
i`m hoping its the seal.
jim.
rsrocket1 likes this.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
"PCM reset" worked (thanks, IRPT) for me... Gary04GT Turbo Performance 6 04 Mar 2016 12:48 am
AC fan replaced. Ac worked, now not so much. beamsbox General PT Cruiser Discussions 5 05 Jan 2015 12:19 pm
06 Cruiser ran yesterday won't start today johnatwork General PT Cruiser Discussions 20 04 Mar 2014 10:21 pm
Not even a jump worked! Any ideas? durhamchic Tech & Performance Forum 11 16 Jun 2011 05:06 pm
OK, for me this worked for better mileage MINIHEMI46 General Turbo Discussions 13 30 Nov 2008 12:06 am


All times are GMT -5. The time now is 09:51 pm.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors