PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > General PT Cruiser Discussions

PT Cruiser Forum

Advertisements
No Instrument Cluster or overhead lights

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 29 Jul 2017, 10:17 am
wingman55's Avatar
Senior Cruiser
 
Join Date: Aug 2015
Location: Pennellville, NY
Posts: 1,616
Default No Instrument Cluster or overhead lights

So.... I'm having this issue in The RATMOBILE:

Nothing working on instrument cluster

HELP!!


I am getting ready to leave on a trip to Utica to visit my son on our Anniversary. We have to take the RATMOBILE because of my M-I-L.

*argh*

Any quicker ideas????? I'll be driving 'blind' if not.
__________________
2006 Limited Edition, Inferno Red, 5-speed, Bassani dual exhaust, Chrome backup light bezels, taillight trim, fuel door, antenna mount, Ventiports, door spear covers & hood prop. Silver painted lower front grille. American Racing 383 Casino wheels, w/Chrysler emblems, '02 engine cover, PT Cruiser mudguards, cargo mat. EGR Window Visors, dark gray lock pulls, dual horns, Fuzzy Dice, flames and MOPAR emblems added to front door logos, gold Chrysler emblem on rear hatch. Upgraded to RAK radio with 6 CD changer, Cassette Tape and RDS info. Name: "FIREBALL" I bought it Aug 10, 2015, with just over 35,600 miles on it.

2004 Limited Edition Platinum Series, Graphite Metallic, Standard Turbo, automatic, RBQ radio with Sirius Radio & 6 CD changer, VentShades, chrome exhaust tip, door spears, grille inserts, door lock pulls, bright pedals and steering wheel spokes. Red spoiler from a donor PT. Known as: "The RATMOBILE" I bought it Apr 28th, 2016 with 62,400 miles on it.
Reply With Quote
  #2 (permalink)  
Old 29 Jul 2017, 11:30 am
wingman55's Avatar
Senior Cruiser
 
Join Date: Aug 2015
Location: Pennellville, NY
Posts: 1,616
Default Re: No Instrument Cluster or overhead lights

Quote:
Originally Posted by randyincctx View Post
It should be located behind the fuse block,behind fuse terminal #10 in the photo(10A-CUSTER/RKE SKIM).

OK, just did the same. Pulled fuses 10 and 13. A couple seconds later the lights and dash came on. We'll see. Heading to Utica now.

__________________
2006 Limited Edition, Inferno Red, 5-speed, Bassani dual exhaust, Chrome backup light bezels, taillight trim, fuel door, antenna mount, Ventiports, door spear covers & hood prop. Silver painted lower front grille. American Racing 383 Casino wheels, w/Chrysler emblems, '02 engine cover, PT Cruiser mudguards, cargo mat. EGR Window Visors, dark gray lock pulls, dual horns, Fuzzy Dice, flames and MOPAR emblems added to front door logos, gold Chrysler emblem on rear hatch. Upgraded to RAK radio with 6 CD changer, Cassette Tape and RDS info. Name: "FIREBALL" I bought it Aug 10, 2015, with just over 35,600 miles on it.

2004 Limited Edition Platinum Series, Graphite Metallic, Standard Turbo, automatic, RBQ radio with Sirius Radio & 6 CD changer, VentShades, chrome exhaust tip, door spears, grille inserts, door lock pulls, bright pedals and steering wheel spokes. Red spoiler from a donor PT. Known as: "The RATMOBILE" I bought it Apr 28th, 2016 with 62,400 miles on it.
Reply With Quote
  #3 (permalink)  
Old 30 Jul 2017, 11:01 am
wingman55's Avatar
Senior Cruiser
 
Join Date: Aug 2015
Location: Pennellville, NY
Posts: 1,616
Default Re: No Instrument Cluster or overhead lights

OK, so once we left the Instrument cluster was blank again. So I drove out to Utica 'blind'. I just tried to stay with traffic as best I could.

When we went to leave to come back last night, all was well. Everything worked except now the Check Engine Light came on.

This morning I checked and got these two codes:

U0155 Lost Communication with Instrument Panel Cluster (IPC)
U110C Refer to Service Manual.

So, I guess I will start by looking at ground connections. Help would be appreciated looking for them.

Thanks
__________________
2006 Limited Edition, Inferno Red, 5-speed, Bassani dual exhaust, Chrome backup light bezels, taillight trim, fuel door, antenna mount, Ventiports, door spear covers & hood prop. Silver painted lower front grille. American Racing 383 Casino wheels, w/Chrysler emblems, '02 engine cover, PT Cruiser mudguards, cargo mat. EGR Window Visors, dark gray lock pulls, dual horns, Fuzzy Dice, flames and MOPAR emblems added to front door logos, gold Chrysler emblem on rear hatch. Upgraded to RAK radio with 6 CD changer, Cassette Tape and RDS info. Name: "FIREBALL" I bought it Aug 10, 2015, with just over 35,600 miles on it.

2004 Limited Edition Platinum Series, Graphite Metallic, Standard Turbo, automatic, RBQ radio with Sirius Radio & 6 CD changer, VentShades, chrome exhaust tip, door spears, grille inserts, door lock pulls, bright pedals and steering wheel spokes. Red spoiler from a donor PT. Known as: "The RATMOBILE" I bought it Apr 28th, 2016 with 62,400 miles on it.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Instrument cluster lights won't extinguish. NLAlston General PT Cruiser Discussions 5 15 Feb 2017 10:21 am
instrument cluster lights dim slash General PT Cruiser Discussions 0 25 Jul 2012 03:14 am
instrument panel cluster lights??? msmarvel Interior Accessories Forum 7 19 Sep 2011 06:09 pm
Has anyone changed the lights in the instrument cluster? Teknoron67 General PT Cruiser Discussions 5 10 Jul 2011 06:52 pm
Instrument Cluster Lights kappa_kruiser Tech & Performance Forum 1 22 May 2008 01:03 am


All times are GMT -5. The time now is 06:12 pm.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors