PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > General PT Cruiser Discussions

PT Cruiser Forum

Advertisements
PT Cruiser breaking down under load at light.

 
Like Tree4Likes
  • 2 Post By NitroPT
  • 1 Post By ptcruisersteve
  • 1 Post By Quadcab06

Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 16 Aug 2017, 03:16 pm
Fresh Cruiser
 
Join Date: Aug 2017
Posts: 5
Default PT Cruiser breaking down under load at light.

We have an 04 PT Cruiser with 47,000 miles. When stopped, under load in gear with AC on, motor feels like it's miss firing but no rhythm. Car has new plugs, new plug wiring and new coil. While excellerating there is no issues at all. Engine light is not on but works.
Can anyone tell me what I should be checking or replacing to resolve this issue. Has anyone experienced this issue with a PT Cruiser?
Reply With Quote
  #2 (permalink)  
Old 16 Aug 2017, 03:25 pm
NitroPT's Avatar
Obsessed Cruiser
 
Join Date: Jun 2012
Location: USA kalyfornia
Posts: 15,995
Default Re: PT Cruiser breaking down under load at light.

Welcome to the forum

You might want to start a introduction thread as a new member.

In the mean time spend a little time about many other member that have had issues like you described. There is not much that has not happened and threads started over the years.

Clean your idle air valve and then see what happens.

WELCOME and Forum Rules
We encourage all new members to say hello and introduce yourself to the rest of the community by starting a post in the Welcome New PT Owners thread at the top half of the forum.
chuzz and rsrocket1 like this.
__________________
To view larger pictures simply "click " on the picture!

Dalai Lama
"Share you knowledge. It's the best way to achieve immortality."
ASE MASTER TECHNICIAN
Reply With Quote
  #3 (permalink)  
Old 16 Aug 2017, 03:52 pm
Obsessed Cruiser
 
Join Date: Aug 2014
Location: Thousand Oaks, CA
Posts: 7,475
Default Re: PT Cruiser breaking down under load at light.

Welcome to the forum.

With the engine cold, start the engine, turn on the A/C. Does the engine start to run rough? If it does and when you turn off the A/C it runs smooth I would suggest you check your radiator fan. Has tthe radiator fan been replaced?
rsrocket1 likes this.
__________________
If at First You Don't Succeed - Try, Try Again
Reply With Quote
  #4 (permalink)  
Old 17 Aug 2017, 09:33 am
Fresh Cruiser
 
Join Date: Aug 2017
Posts: 5
Default Re: PT Cruiser breaking down under load at light.

Thank you NitroPT for your suggestion, I will try cleaning the idle air valve.
Reply With Quote
  #5 (permalink)  
Old 17 Aug 2017, 09:51 am
Fresh Cruiser
 
Join Date: Aug 2017
Posts: 5
Default Re: PT Cruiser breaking down under load at light.

Thank you for your response Ptcruisersteve. The car only feels like it's going to shut off while under load and while backing up. There is no rhythm to it and it feels like the car will shut off. Car feels strong during ecceleration with no issues. This only occurs when stopped under load and more noticeable with AC on. Due to the cars strong ecceleration I'm leaning away from plus, plug wiring and coil. Just not sure where to look next.

NitroPT suggested cleaning idle air valve, which I will try. Not sure where to look next. Thank you for your time.
Reply With Quote
  #6 (permalink)  
Old 17 Aug 2017, 10:02 am
Handy_Cruiser's Avatar
Obsessed Cruiser
 
Join Date: Oct 2013
Location: Arkansas
Posts: 10,547
Default Re: PT Cruiser breaking down under load at light.

When you clean the idle air control valve, take a multi-meter and check the resistance across the connection pins. It should be around 10 ohms plus or minus an ohm or two. If too far away from this, the IAC valve may be going bad. In my Dodge truck, the IAC valve started showing undue resistance even though it would work when bench testing.
__________________
Reply With Quote
  #7 (permalink)  
Old 17 Aug 2017, 11:26 am
rsrocket1's Avatar
Fanatic Cruiser
 
Join Date: Mar 2016
Location: Sacramento, CA
Posts: 769
Default Re: PT Cruiser breaking down under load at light.

As ptcruisersteve said, I would also suspect the radiator fan not working if the engine bogs down with the AC on and while at idle anytime after the first couple of minutes of the engine running.

To check the fan, do as steve said. Lift the hood, start the engine, keep the transmission in Park or Neutral and turn on the A/C. The high speed fan should be loud enough to hear from the inside with the windows rolled down but you'd clearly notice it if you went outside the car with the hood up, air will be blowing around quite noticeably.

When the AC runs and there is no radiator fan running or no air moving due to driving, the compressor bogs down the engine and eventually shuts off when the refrigerant pressure gets too high.

Anyway, the test costs nothing and you don't have to disconnect or check anything and can do it in 5 minutes. If the fan runs, you can go to the next thing.
Reply With Quote
  #8 (permalink)  
Old 17 Aug 2017, 11:38 am
Obsessed Cruiser
 
Join Date: Aug 2014
Location: Thousand Oaks, CA
Posts: 7,475
Default Re: PT Cruiser breaking down under load at light.

Quote:
Originally Posted by rsrocket1 View Post
As ptcruisersteve said, I would also suspect the radiator fan not working if the engine bogs down with the AC on and while at idle anytime after the first couple of minutes of the engine running.

To check the fan, do as steve said. Lift the hood, start the engine, keep the transmission in Park or Neutral and turn on the A/C. The high speed fan should be loud enough to hear from the inside with the windows rolled down but you'd clearly notice it if you went outside the car with the hood up, air will be blowing around quite noticeably.

When the AC runs and there is no radiator fan running or no air moving due to driving, the compressor bogs down the engine and eventually shuts off when the refrigerant pressure gets too high.

Anyway, the test costs nothing and you don't have to disconnect or check anything and can do it in 5 minutes. If the fan runs, you can go to the next thing.
Sometimes when the radiator fan starts to fail it might be making contact intermittently as the brushes are barely touching at certain times and not touching at other times.

I totally agree with NitroPT in suggesting to clean the idle air valve. When we have had our Pt Cruisers for a long time we usually have a pretty good idea of where to start looking based on what has been worked on and replaced in the past.
__________________
If at First You Don't Succeed - Try, Try Again
Reply With Quote
  #9 (permalink)  
Old 18 Aug 2017, 10:09 pm
Fresh Cruiser
 
Join Date: Aug 2017
Posts: 5
Default Re: PT Cruiser breaking down under load at light.

Thank you everyone that has responded to my issue. I will try everything above and update you all as to the results, thanks again.
Reply With Quote
  #10 (permalink)  
Old 26 Aug 2017, 10:33 pm
Fresh Cruiser
 
Join Date: Aug 2017
Posts: 5
Default Re: PT Cruiser breaking down under load at light.

Update on the breaking down under load issue I've been experiencing with my 04 PT. Bought the FIXD device to check for issues with the PT and it did not even detect a plug misfiring.

I took the car to a mechanic for them to put it on their scope. The car was breaking down due to a spark plug wiring that was arcing. I replaced the plugs awhile back but did not replace the plug wiring at that time. The original plug wire arced on the plug and when I changed the plug I should have replaced the wiring at that time. The original plug wire started arcing on the new plug so that point I replaced the plug wiring but the spark plug already had the arcing mark on it and over time the new wiring got worse. Live and learn!!

So remember to always change both plugs and wires at the same time. The mechanic also said the plugs I bought, which were platinum and are not recommended for the PT with turbo but the auto parts store didn't tell me that when they sold them to me.

Problem solved, thank you everyone for your help and suggestions.
rckstein likes this.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Load Index for a 2004 PT Cruiser GT 2.4l Matthewandrews General PT Cruiser Discussions 0 08 Dec 2016 08:16 pm
Breaking up a cruiser.. best parts to keep as spares? Lankytim General PT Cruiser Discussions 2 26 Aug 2016 07:28 pm
Lug nuts breaking kirbykit Wheels, Tires, Suspension 8 26 Aug 2010 09:09 pm


All times are GMT -5. The time now is 04:59 pm.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors