PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > General PT Cruiser Discussions

PT Cruiser Forum

Advertisements
Oil ligjht came on under hard braking. Normal?

 
Like Tree22Likes

Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 13 Sep 2017, 05:45 pm
Gkon's Avatar
Senior Cruiser
 
Join Date: Jun 2015
Location: Queens, NY
Posts: 1,615
Default Oil ligjht came on under hard braking. Normal?

Hi guys and gals,

Yesterday, as I was driving home from work, I had to slam on my brakes to come to a sudden stop. I was just short of skidding.
When I did that, my oil light came on for a couple of seconds and then turned off.

I mimicked the same situation and had the same result.

After I got home I checked my oil level. The oil was hot and the level was just shy of being right between the two dots on the dipstick in the area for checking hot oil, as it should be.

What gives? Is this normal? Should I add a little bit of oil? I don't want to overfill it.

I remember on my old Kawasaki kz900 there were oil starvation issues under extreme braking conditions. Does the PT have similar issues?

Thanks.
__________________
2002 PT Cruiser Limited, 2.4L, Automatic Transmission, Metallic Silver Paint
Reply With Quote
  #2 (permalink)  
Old 13 Sep 2017, 06:11 pm
Handy_Cruiser's Avatar
Obsessed Cruiser
 
Join Date: Oct 2013
Location: Arkansas
Posts: 8,116
Default Re: Oil ligjht came on under hard braking. Normal?

I believe that the first thing to do when this type of symptom comes up is simply to change the oil with the correct high quality stuff and with a good quality filter.

This will eliminate several of the more common and easily rectifiable causes such as burnt oil, wrong oil, cheap oil, stopped up filter, low oil, etc. And then you can see if the issue returns. And if it does, it might indicated a more serious problem.
__________________
Reply With Quote
  #3 (permalink)  
Old 13 Sep 2017, 08:15 pm
Gkon's Avatar
Senior Cruiser
 
Join Date: Jun 2015
Location: Queens, NY
Posts: 1,615
Default Re: Oil ligjht came on under hard braking. Normal?

Quote:
Originally Posted by Handy_Cruiser View Post
I believe that the first thing to do when this type of symptom comes up is simply to change the oil with the correct high quality stuff and with a good quality filter.

This will eliminate several of the more common and easily rectifiable causes such as burnt oil, wrong oil, cheap oil, stopped up filter, low oil, etc. And then you can see if the issue returns. And if it does, it might indicated a more serious problem.
My oil and filter were changes by my reputable mechanic who used quality oil and filter and I'm not yet due for an oil change.
Also, I baby my car and drive it like an old man.

I don't know that you actually answered my question, though.
__________________
2002 PT Cruiser Limited, 2.4L, Automatic Transmission, Metallic Silver Paint
Reply With Quote
  #4 (permalink)  
Old 13 Sep 2017, 08:33 pm
VsandFords's Avatar
Senior Cruiser
 
Join Date: Apr 2014
Location: Gladewater, Texas
Posts: 1,320
Default Re: Oil ligjht came on under hard braking. Normal?

Gkon, I can't tell you it is common on a Cruiser, however, anytime you hammer the brakes and the RPMs go from 2-3 grand to nothing in a flash, the light could come on. The lower the RPMs, the lower the oil pressure. Since you haven't had this issue during your day to day travels, I wouldn't be concerned.


Just my opinion.
NitroPT and Gkon like this.
__________________
Life is just a bowl of jello, full of fruits and nuts.

2001 LE, auto, billet grille, tall shifter, polished aluminum spare, K&N filter and Hedman hedder. Why a header? Because it makes me happy!

Reply With Quote
  #5 (permalink)  
Old 13 Sep 2017, 09:42 pm
WrenchnIswhatIdo's Avatar
Fanatic Cruiser
 
Join Date: Feb 2016
Posts: 510
Default Re: Oil ligjht came on under hard braking. Normal?

If it was Me First thing Pull the dip stick smell the oil
make sure you can.t smell fuel in the oil
.
Possibly you qualified mechanic put the "Non proper weight or Multi weight"
oil in your cars engine
.
In any case........ Even if your oil was Just changed
This is a red Flag
an a sign to change the oil again
and look what in the oil after change Hopefully it just the oil
if you see Goldsilver flakes in the oil...

........Houston we have a Problem.!
.
.
.
.
.
.
.
.
.


.
Handy_Cruiser and Gkon like this.
__________________
Quote:
Originally Posted by Canadian Moose View Post
Just answer one simple question. Do you own any of the following?: Opel, Alfa Romeo, Fiat, Lada, Yugo, Kia, Daewoo, Volvo, SAAB, Jaguar, Land Rover, Chrysler, Dodge, Plymouth, Jeep, Lancia.

If you answered “yes” then parts car is a really good idea.
Reply With Quote
  #6 (permalink)  
Old 14 Sep 2017, 11:07 am
Gkon's Avatar
Senior Cruiser
 
Join Date: Jun 2015
Location: Queens, NY
Posts: 1,615
Default Re: Oil ligjht came on under hard braking. Normal?

Thanks to everyone for their input.

My oil wasn't just changed, but it is still within the recommended driving range. However, a fresh oil change and filter sound like cheap insurance and may show if there is another underlying problem.

Again, this only happened under severe braking, going from 35mph to 0mph as fast as one can without actually skidding. It seemed like the oil sensor was starved for oil for a second or two because of the sudden stop and inertia.
That's why I suspected possible low oil level, which it didn't seem to be.
My oil light has never come on with normal driving and braking.

I'll check for gas smell in the oil in a bit.

Like I said, this reminded me of my old kz900. They have a low pressure/high volume system so, under severe braking, the oil pump would be starved for oil because it woul all end up on the other side of the oil pan for a second.
Most guys that drag raced would weld a deeper portion onto the pan, as I've seen some of you all do to your PT's. That's why I thought it might be a common issue.
__________________
2002 PT Cruiser Limited, 2.4L, Automatic Transmission, Metallic Silver Paint
Reply With Quote
  #7 (permalink)  
Old 14 Sep 2017, 11:08 am
NitroPT's Avatar
Obsessed Cruiser
 
Join Date: Jun 2012
Location: AMERICA that is the USA
Posts: 13,899
Default Re: Oil ligjht came on under hard braking. Normal?

PM sent
Gkon likes this.
__________________

PERFROMANCE PARTS ENGINEER
"not a Professional Engineer"
Engineers are people who design, construct and test structures, materials and systems
while considering the limitations imposed by practicality, regulation, safety, and cost.

& ase =Already Seriously Experienced
RICE(r)Race Inspired Cosmetic Enhancements
Reply With Quote
  #8 (permalink)  
Old 14 Sep 2017, 11:14 am
Fk5 Fk5 is online now
Senior Cruiser
 
Join Date: Jul 2011
Location: Cloverly, MD
Posts: 1,320
Default Re: Oil ligjht came on under hard braking. Normal?

Just had the oil light scare, so I have read a bit about this one. Mine turned out to be the oil pressure sender/switch. $15 fix. These cars apparently have pretty low oil pressure at idle. Dropping the rpms a tiny bit can make it drop even further causing the light to come on. I am not really a fan of "repeating" a low oil pressure problem, but next time you do, check your revs. If you are under 700, I don't find it surprising. The car is basically stalling - then you can check your IAC and stuff that sets the idle and maybe see if it is a vacuum thing from the power brakes.
__________________
2003 GT 5 speed
150,000 miles
Reply With Quote
  #9 (permalink)  
Old 14 Sep 2017, 12:09 pm
Gkon's Avatar
Senior Cruiser
 
Join Date: Jun 2015
Location: Queens, NY
Posts: 1,615
Default Re: Oil ligjht came on under hard braking. Normal?

Quote:
Originally Posted by NitroPT View Post
PM sent
Thanks. I'll check it out.

Quote:
Originally Posted by Fk5 View Post
Just had the oil light scare, so I have read a bit about this one. Mine turned out to be the oil pressure sender/switch. $15 fix. These cars apparently have pretty low oil pressure at idle. Dropping the rpms a tiny bit can make it drop even further causing the light to come on. I am not really a fan of "repeating" a low oil pressure problem, but next time you do, check your revs. If you are under 700, I don't find it surprising. The car is basically stalling - then you can check your IAC and stuff that sets the idle and maybe see if it is a vacuum thing from the power brakes.

Thanks for the info. I'll check to make sure, but I'm pretty certain the Rams dropped and quickly because of the severe braking. As mentioned, it was braking as hard as you can and combing to as abrupt Of a stop as you can just short of skidding.

Just smelled the (cold) oil. Not a whiff of gas smell, and the level is where it should be.
__________________
2002 PT Cruiser Limited, 2.4L, Automatic Transmission, Metallic Silver Paint
Reply With Quote
  #10 (permalink)  
Old 14 Sep 2017, 12:13 pm
cruserdad1976's Avatar
Obsessed Cruiser
 
Join Date: Sep 2009
Location: st james mo
Posts: 8,196
Default Re: Oil ligjht came on under hard braking. Normal?

Im sure Nitro told you to send the oil to the lab and have it testes which is a great idea?
the oil sending unit was mentioned that too is a great idea to have it changed
I guess if you were really concerned you could put a manual oil pressure gauge on the PT
I really have no idea what the oil pressure runs on a PT
changing the oil is never ever a bad idea
if you do all this all it all looks good id say you are safe
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Pt Braking Issue. Snowmanner Wheels, Tires, Suspension 3 29 Nov 2016 06:39 pm
HELP!!! ...Braking... TangerineDream76 General PT Cruiser Discussions 13 14 Dec 2014 09:35 pm
Transmission slips intermittently after hard braking Slowrider Tech & Performance Forum 9 07 Aug 2013 10:26 pm
Wet Braking Problem compdr59 Tech & Performance Forum 7 18 Feb 2012 10:59 am
Braking problem ??!! junkno General PT Cruiser Discussions 10 13 Aug 2004 07:10 pm


All times are GMT -5. The time now is 03:32 pm.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors