PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > General PT Cruiser Discussions

PT Cruiser Forum

Advertisements
MIL Code City

 
Like Tree16Likes
  • 2 Post By Fk5
  • 2 Post By CREWZIN
  • 2 Post By wingman55
  • 2 Post By Handy_Cruiser
  • 1 Post By ptcruisersteve
  • 2 Post By ptcruisersteve
  • 2 Post By wingman55
  • 1 Post By ptcruisersteve
  • 2 Post By wingman55

Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 05 Oct 2017, 11:27 am
wingman55's Avatar
Senior Cruiser
 
Join Date: Aug 2015
Location: Pennellville, NY
Posts: 1,615
Default MIL Code City

So yesterday on the way to work, FIREBALL's MIL came on. *Ugh* He has been stumbling every once-in-a-while when partially warmed up.

Got these two codes: P0132 and P1128. Oxygen sensor and temp not coming up as quickly as it should. A quick search on line says that a guy with a Dodge Caravan had the P1128 (Chrysler specific code), with the same stumble every once-in-a-while, and what the mechanic did was replace the thermostat. Solved the problem. So, I'll try that first.

THEN, my wife had to travel out of town to take my Mother-In-Law to the doctor, and the MIL came on in The RATMOBILE. *Sigh* I got a frantic call during band rehearsal . . .

She said the car was stumbling a bit, but then smoothed out, so she got off the Thruway and took a less busy road. I checked the code when she got home: P0340 Camshaft Sensor.

So I guess I will be finding out how hard THAT is to replace.

__________________
2006 Limited Edition, Inferno Red, 5-speed, Bassani dual exhaust, Chrome backup light bezels, taillight trim, fuel door, antenna mount, Ventiports, door spear covers & hood prop. Silver painted lower front grille. American Racing 383 Casino wheels, w/Chrysler emblems, '02 engine cover, PT Cruiser mudguards, cargo mat. EGR Window Visors, dark gray lock pulls, dual horns, Fuzzy Dice, flames and MOPAR emblems added to front door logos, gold Chrysler emblem on rear hatch. Upgraded to RAK radio with 6 CD changer, Cassette Tape and RDS info. Name: "FIREBALL" I bought it Aug 10, 2015, with just over 35,600 miles on it.

2004 Limited Edition Platinum Series, Graphite Metallic, Standard Turbo, automatic, RBQ radio with Sirius Radio & 6 CD changer, VentShades, chrome exhaust tip, door spears, grille inserts, door lock pulls, bright pedals and steering wheel spokes. Red spoiler from a donor PT. Known as: "The RATMOBILE" I bought it Apr 28th, 2016 with 62,400 miles on it.
Reply With Quote
  #2 (permalink)  
Old 05 Oct 2017, 11:36 am
Fk5 Fk5 is offline
Senior Cruiser
 
Join Date: Jul 2011
Location: Colesville, MD
Posts: 1,839
Default Re: MIL Code City

Check the wiring, but the camshaft sensor is pretty easy. I did it in the rain with a flashlight in my mouth. Took about 5 minutes. Not breaking the clip off is probably the hardest part.
__________________
2003 GT 5 speed
162,000 miles
Reply With Quote
  #3 (permalink)  
Old 05 Oct 2017, 11:47 am
Obsessed Cruiser
 
Join Date: Sep 2001
Posts: 27,744
Default Re: MIL Code City

Definitely check the wiring harness and the electrical connection clip on the sensor itself. The wiring harness goes from the sensor all the way round the back of the engine and is held in place by cheap plastic clips. Check the harness for anywhere it might come in contact with anything that could rub against the harness and cause a problem.

As was just stated, it's probably the easiest part to replace but don't tighten the small bolts too tight as that could lead to problems. If you take it apart, check real carefully the Target Magnet inside as that could cause problems also.

Fk5 and wingman55 like this.
__________________
Rules of the forum have been updated as of *07/07/2019* Please read them over.

- All decisions by the Moderator are semi-permanent, can and may be changed at his discretion but definitely will be the final word. Any action performed by the Administrator or Moderators are not to be discussed on the forum.
Reply With Quote
  #4 (permalink)  
Old 05 Oct 2017, 12:26 pm
wingman55's Avatar
Senior Cruiser
 
Join Date: Aug 2015
Location: Pennellville, NY
Posts: 1,615
Default Re: MIL Code City

Wow, thanks you guys!

Fk5 and Handy_Cruiser like this.
__________________
2006 Limited Edition, Inferno Red, 5-speed, Bassani dual exhaust, Chrome backup light bezels, taillight trim, fuel door, antenna mount, Ventiports, door spear covers & hood prop. Silver painted lower front grille. American Racing 383 Casino wheels, w/Chrysler emblems, '02 engine cover, PT Cruiser mudguards, cargo mat. EGR Window Visors, dark gray lock pulls, dual horns, Fuzzy Dice, flames and MOPAR emblems added to front door logos, gold Chrysler emblem on rear hatch. Upgraded to RAK radio with 6 CD changer, Cassette Tape and RDS info. Name: "FIREBALL" I bought it Aug 10, 2015, with just over 35,600 miles on it.

2004 Limited Edition Platinum Series, Graphite Metallic, Standard Turbo, automatic, RBQ radio with Sirius Radio & 6 CD changer, VentShades, chrome exhaust tip, door spears, grille inserts, door lock pulls, bright pedals and steering wheel spokes. Red spoiler from a donor PT. Known as: "The RATMOBILE" I bought it Apr 28th, 2016 with 62,400 miles on it.
Reply With Quote
  #5 (permalink)  
Old 05 Oct 2017, 01:01 pm
Handy_Cruiser's Avatar
Obsessed Cruiser
 
Join Date: Oct 2013
Location: Arkansas
Posts: 10,330
Default Re: MIL Code City

Here's my write up with photos.

The Handy Camshaft Sensor Change Out
wingman55 and JDK52 like this.
__________________
Reply With Quote
  #6 (permalink)  
Old 05 Oct 2017, 01:33 pm
Obsessed Cruiser
 
Join Date: Aug 2014
Location: Thousand Oaks, CA
Posts: 7,309
Default Re: MIL Code City

P0340 - No Camshaft Position Sensor Circuit Failure Conditions:

Possible Causes:

1. Camshaft Position Sensor connector is damaged, open or it is shorted
2. Camshaft Position Sensor signal circuit is open or shorted to ground or to battery voltage or 5 volt circuit
3. Camshaft Position Sensor 5 volt circuit is open or shorted to ground or to battery voltage
4. Camshaft Position Sensor ground circuit is open
5. Camshaft Position Sensor is damaged or has failed
6. PCM has failed

I would first suggest checking the Camshaft Sensor connector and the wiring going to it.
wingman55 likes this.
__________________
If at First You Don't Succeed - Try, Try Again
Reply With Quote
  #7 (permalink)  
Old 05 Oct 2017, 01:39 pm
Obsessed Cruiser
 
Join Date: Aug 2014
Location: Thousand Oaks, CA
Posts: 7,309
Default Re: MIL Code City

P1128 - Closed Loop Fueling Not Achieved Bank 1

Possible Causes:

1. Fuel delivery system
2. Manifold Absolute Pressure sensor or wiring connectors
3. O2 sensor wiring or connectors
4. Engine mechanical system
5. Faulty PCM

Check for open ground on the O2 sensor wire. Ground goes to left fender collection of grounds by battery. P1128 code was probably triggered by the 02 sensor circuit not working properly.

Check the group of ground wires going to the left fender as shown in the image below.

Ground Wires.jpg
wingman55 and JDK52 like this.
__________________
If at First You Don't Succeed - Try, Try Again

Last edited by ptcruisersteve; 05 Oct 2017 at 01:50 pm.
Reply With Quote
  #8 (permalink)  
Old 05 Oct 2017, 08:55 pm
wingman55's Avatar
Senior Cruiser
 
Join Date: Aug 2015
Location: Pennellville, NY
Posts: 1,615
Default Re: MIL Code City

Wow. Thanks again! I checked out Handy's link and saw ptcruisersteve's post about the part numbers on his sensors. Mine is the same.

Anyway, here is what I found. The sensor has been replaced, but whoever did it did not put it back together correctly. They must have popped the red retaining clip all the way out, and then didn't put it back in correctly.

IMG_20171005_204338 (Medium).jpg

So, I reinstalled the locking clip the correct way, cleared the code and started it up. I ran it for a few minutes and the code didn't come back. I'll take it for a drive this weekend to see if it comes back.

IMG_20171005_204947 (Medium).jpg

Maybe this is all that was wrong. My wife said that it was raining when the light came on, so maybe some moisture got it the plug. Once the engine warmed up the engine ran fine.

IMG_20171005_210908 (Medium).jpg

Time will tell.

Thanks for all the help. Now to check on that oxygen sensor.

__________________
2006 Limited Edition, Inferno Red, 5-speed, Bassani dual exhaust, Chrome backup light bezels, taillight trim, fuel door, antenna mount, Ventiports, door spear covers & hood prop. Silver painted lower front grille. American Racing 383 Casino wheels, w/Chrysler emblems, '02 engine cover, PT Cruiser mudguards, cargo mat. EGR Window Visors, dark gray lock pulls, dual horns, Fuzzy Dice, flames and MOPAR emblems added to front door logos, gold Chrysler emblem on rear hatch. Upgraded to RAK radio with 6 CD changer, Cassette Tape and RDS info. Name: "FIREBALL" I bought it Aug 10, 2015, with just over 35,600 miles on it.

2004 Limited Edition Platinum Series, Graphite Metallic, Standard Turbo, automatic, RBQ radio with Sirius Radio & 6 CD changer, VentShades, chrome exhaust tip, door spears, grille inserts, door lock pulls, bright pedals and steering wheel spokes. Red spoiler from a donor PT. Known as: "The RATMOBILE" I bought it Apr 28th, 2016 with 62,400 miles on it.
Reply With Quote
  #9 (permalink)  
Old 05 Oct 2017, 09:13 pm
Obsessed Cruiser
 
Join Date: Aug 2014
Location: Thousand Oaks, CA
Posts: 7,309
Default Re: MIL Code City

Quote:
Originally Posted by wingman55 View Post
Wow. Thanks again! I checked out Handy's link and saw ptcruisersteve's post about the part numbers on his sensors.

Thanks for all the help. Now to check on that oxygen sensor.

I would suggest checking the ground wires on the fender before checking the oxygen sensor.
wingman55 likes this.
__________________
If at First You Don't Succeed - Try, Try Again
Reply With Quote
  #10 (permalink)  
Old 08 Oct 2017, 09:23 pm
wingman55's Avatar
Senior Cruiser
 
Join Date: Aug 2015
Location: Pennellville, NY
Posts: 1,615
Default Re: MIL Code City

I took The RATMOBILE out yesterday for a couple of runs to the store and he was fine. No stumbling, no MIL.

So today (Sunday) I took my wife and Mother-In-Law to Fair Haven Beach State Park on Lake Ontario, and then we headed over to Rudy's Lakeside Drive-In for a fish fry.

Probably about a 70 mile round-trip. No problems at all. However, to satisfy my wife's concerns, I'll probably buy a new Camshaft Sensor and replace it anyway.



Rudy's was mobbed. Probably because we are still having an unseasonable streak of warm weather. Today it got up to 75F about 10 degrees warmer than normal for this time of year.



IMG_20171008_161043 (Medium).jpg

IMG_20171008_175216 (Medium).jpg

IMG_20171008_175258 (Medium).jpg
rcktpwrd and Carnut like this.
__________________
2006 Limited Edition, Inferno Red, 5-speed, Bassani dual exhaust, Chrome backup light bezels, taillight trim, fuel door, antenna mount, Ventiports, door spear covers & hood prop. Silver painted lower front grille. American Racing 383 Casino wheels, w/Chrysler emblems, '02 engine cover, PT Cruiser mudguards, cargo mat. EGR Window Visors, dark gray lock pulls, dual horns, Fuzzy Dice, flames and MOPAR emblems added to front door logos, gold Chrysler emblem on rear hatch. Upgraded to RAK radio with 6 CD changer, Cassette Tape and RDS info. Name: "FIREBALL" I bought it Aug 10, 2015, with just over 35,600 miles on it.

2004 Limited Edition Platinum Series, Graphite Metallic, Standard Turbo, automatic, RBQ radio with Sirius Radio & 6 CD changer, VentShades, chrome exhaust tip, door spears, grille inserts, door lock pulls, bright pedals and steering wheel spokes. Red spoiler from a donor PT. Known as: "The RATMOBILE" I bought it Apr 28th, 2016 with 62,400 miles on it.

Last edited by wingman55; 09 Oct 2017 at 11:31 am.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Hello from Carson City NV Chip18sw Welcome New PT Cruiser Members 19 16 Sep 2012 11:09 am
N.Y. City Emisisons Hoot23 Stage Turbo Kits 2 10 Jul 2008 06:13 pm
Swirl City turbomangt The Detail Shop 2 30 Aug 2004 01:55 am
Swirl City turbomangt The Detail Shop 5 20 Mar 2004 04:02 pm


All times are GMT -5. The time now is 03:56 am.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors