PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > General PT Cruiser Discussions

PT Cruiser Forum

Advertisements
2007 base pt rear turn signal issue

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 20 Oct 2017, 01:46 pm
Fresh Cruiser
 
Join Date: Nov 2016
Location: Tyler Texas
Posts: 25
Default 2007 base pt rear turn signal issue

Hi! The left rear turn signal acts like the bulb is bad. It's good.
Has new bulb socket. Reads 11.??? Voltage at socket. Seems not enough amperage to light the bulb. ??
Reply With Quote
  #2 (permalink)  
Old 20 Oct 2017, 04:10 pm
Young Cruiser
 
Join Date: Nov 2015
Location: plant city fl.
Posts: 73
Default Re: 2007 base pt rear turn signal issue

Quote:
Originally Posted by Chucky View Post
Hi! The left rear turn signal acts like the bulb is bad. It's good.
Has new bulb socket. Reads 11.??? Voltage at socket. Seems not enough amperage to light the bulb. ??
hold a jumper lead to the socket and to the body, with the turn signal
on .. did it act normal??
Reply With Quote
  #3 (permalink)  
Old 20 Oct 2017, 07:05 pm
Obsessed Cruiser
 
Join Date: Aug 2014
Location: Thousand Oaks, CA
Posts: 7,309
Default Re: 2007 base pt rear turn signal issue

How much voltage do you get when you turn the hazard lights on? Also with the brake light on?
__________________
If at First You Don't Succeed - Try, Try Again
Reply With Quote
  #4 (permalink)  
Old 21 Oct 2017, 08:06 am
Veteran Cruiser
 
Join Date: Aug 2015
Location: Lake Wales, FL
Posts: 4,764
Default Re: 2007 base pt rear turn signal issue

Check the contact points in the socket and on the bulb. Sometimes they need a little scuffing to make a solid connection.
__________________


Aspire to inspire before you expire.
Reply With Quote
  #5 (permalink)  
Old 21 Oct 2017, 09:50 am
Fresh Cruiser
 
Join Date: Nov 2016
Location: Tyler Texas
Posts: 25
Default Re: 2007 base pt rear turn signal issue

contacts are good n clean, haven't checked voltage with hazards or run a jumper from socket to fender yet. This car have canbus system? Is there a module that operates the rear lights? If there is, what's it called and where's it at?
Reply With Quote
  #6 (permalink)  
Old 21 Oct 2017, 10:42 am
Obsessed Cruiser
 
Join Date: Aug 2014
Location: Thousand Oaks, CA
Posts: 7,309
Default Re: 2007 base pt rear turn signal issue

[/QUOTE]
__________________
If at First You Don't Succeed - Try, Try Again
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
New multi-function swt. & no lft rear turn signal. Michaeld55 General PT Cruiser Discussions 4 08 Apr 2017 02:49 pm
WTB: Rear Turn Signal Socket sifu_scott Classifieds: For Sale/Trade 1 30 Dec 2013 02:42 pm
Turn Signal Problem 2007 Pt Twinb2 General PT Cruiser Discussions 4 26 Sep 2012 02:46 pm
Turn Signal Issue-Please HELP!!! 2002ptcruiserwoody723 Exterior Accessories Forum 1 28 Oct 2009 12:27 pm
Rear turn signal problem leroy420 General PT Cruiser Discussions 5 18 Feb 2009 09:43 pm


All times are GMT -5. The time now is 12:39 am.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors