PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > General PT Cruiser Discussions

PT Cruiser Forum

Advertisements
Power steering woes

 
Like Tree4Likes
  • 1 Post By RickinPA
  • 3 Post By JonN

Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 15 Jan 2018, 10:45 pm
JonN's Avatar
Cool Cruiser
 
Join Date: Mar 2016
Location: Massachusetts
Posts: 315
Default Power steering woes

Hey guys,

Looking for some advice on a power steering issue I've been having. Occasionally at idle my power steering seems to not work and makes steering hard as hell. However, once I start moving over 10 mph steering is perfectly fine. Pump isn't being noisy, belt and tensioner are fine, and fluid level is also fine and I had my rack and pinion replaced last July.

On a hunch I figured the fluid may be contaminated, I took the good old turkey baster out and flushed out the reservoir, holy $hi+ I don't think this looks good....

For some reason my photo keeps getting turned 90° adter uploading here sorry for the inconvenience
20180113_151832_HDR.jpg



I've flushed the reservoir once and refilled with atf+4, but the issue is still present. I'm sure I may have to flush out several times.

Other than that, anyone have any suggestions?

'01 LE 167K

Thanks
__________________
BIG RED '01 LE 186K
Vision Cross 16x7 Rims, 205/55/16 , Painted Calipers, Spoiler, CAI
Sound System
Pioneer DEH-64BT head unit, Zapco Z400-C4SL competition amplifier, 2 RF P2D2 12's, RF P1T-S Tweets, RF PPS4-6 Mids, RF 6x8"s, AudioControl 24XS crossover/line driver

Newest Car
2016 Jeep Patriot Sport 2.4L 6 speed auto 76k
Powerstop Z23 evolution front brakes
Sound System
Pioneer DEH-X9600BT head unit, Bē Rage 1200.6 Amp, 4 JBL GX963 6x9's, 2 Skar VVX3-12's. 6 Channel AudioControl Matrix Plus Line Driver

#LoudLife

Both powered by Mobil1
Reply With Quote
  #2 (permalink)  
Old 16 Jan 2018, 07:37 am
LionPT's Avatar
Veteran Cruiser
 
Join Date: May 2014
Location: Central Florida
Posts: 4,344
Default Re: Power steering woes

It sounds like you have a vacuum leak somewhere...most likely at the brake booster.
I'm gonna guess the bubbles in your pic came from you putting the fluid from the baster to the bottle...but if not, you have a loose line that it letting air into the system.
__________________

2006 Touring Edition in Cool Vanilla...aka/Ghost
Reply With Quote
  #3 (permalink)  
Old 16 Jan 2018, 11:44 am
VsandFords's Avatar
Senior Cruiser
 
Join Date: Apr 2014
Location: Gladewater, Texas
Posts: 1,902
Default Re: Power steering woes

When I replaced the power steering pump on my 01' last year, I had basically the same symptoms. When the Cruiser was not moving, it was impossible to turn. After I started moving, the steering felt fine. My assumption was the pressure relief valve had gone bad. I replaced the pump, pulled the reservoir and flushed the screen inside. Problem solved.
__________________
Life is just a bowl of jello, full of fruits and nuts.

2001 LE, auto, billet grille, tall shifter, polished aluminum spare, K&N filter and Hedman hedder. Why a header? Because it makes me happy!


Reply With Quote
  #4 (permalink)  
Old 16 Jan 2018, 01:42 pm
JonN's Avatar
Cool Cruiser
 
Join Date: Mar 2016
Location: Massachusetts
Posts: 315
Default Re: Power steering woes

Quote:
Originally Posted by VsandFords View Post
When I replaced the power steering pump on my 01' last year, I had basically the same symptoms. When the Cruiser was not moving, it was impossible to turn. After I started moving, the steering felt fine. My assumption was the pressure relief valve had gone bad. I replaced the pump, pulled the reservoir and flushed the screen inside. Problem solved.
I'm thinking I'll do the same when it gets a little warmer here in Massachusetts. Working on cars in the cold is no fun. I'll just deal with it until a good day comes to do it.

Also, how did you flush the screen inside?
__________________
BIG RED '01 LE 186K
Vision Cross 16x7 Rims, 205/55/16 , Painted Calipers, Spoiler, CAI
Sound System
Pioneer DEH-64BT head unit, Zapco Z400-C4SL competition amplifier, 2 RF P2D2 12's, RF P1T-S Tweets, RF PPS4-6 Mids, RF 6x8"s, AudioControl 24XS crossover/line driver

Newest Car
2016 Jeep Patriot Sport 2.4L 6 speed auto 76k
Powerstop Z23 evolution front brakes
Sound System
Pioneer DEH-X9600BT head unit, Bē Rage 1200.6 Amp, 4 JBL GX963 6x9's, 2 Skar VVX3-12's. 6 Channel AudioControl Matrix Plus Line Driver

#LoudLife

Both powered by Mobil1
Reply With Quote
  #5 (permalink)  
Old 16 Jan 2018, 02:12 pm
Cool Cruiser
 
Join Date: Dec 2017
Posts: 240
Default Re: Power steering woes

Does this stiff steering only occur on a cold start up? If so , this goes back to the early days of power rack and pinion. The control valving on the rack wears out the bore and causes cross leaks reducing power assist.

There are two valves in the PS pump, one is a pressure relief that noise you hear when the wheel is turned hard to one side and a flow regulator valve. The pressure relief only comes into play when the wheel is hard to one side, it will never open in normal operation.

The flow regulator valve , in part , gives you consistent rate of steering assist. It could stick but I've never verified this to occur regardless of brand.

The generally the fix is replacing the R&P , a temp fix is to use AW 46 or so hydraulic fluid but this thicker oil can cause pump noise when cold due to cavitation.

If the screen was clogged, you would get pump buzzing. My 06 at 162,000 miles has fluid that looked the same. The red dye used in ATF / other fluids turns brown normally so if the fluid does not smell burnt, it is fine.
Reply With Quote
  #6 (permalink)  
Old 17 Jan 2018, 04:18 am
RickinPA's Avatar
Cool Cruiser
 
Join Date: Jun 2014
Location: southeastern PA
Posts: 301
Default Re: Power steering woes

Here's a video I did of a power steering flush and reservoir screen cleaning:



If you wanted to check the condition of the screen, you could probably pull the lower hose and suck the fluid out to lower the level below the screen. Then look at the screen through the cap with a flashlight.
JonN likes this.
Reply With Quote
  #7 (permalink)  
Old 21 Jan 2018, 05:38 pm
JonN's Avatar
Cool Cruiser
 
Join Date: Mar 2016
Location: Massachusetts
Posts: 315
Default Re: Power steering woes

I've now flushed out the resevoir 4 times and the fluid looks all new now. It doesn't matter if it is cold start or not, steering is still tough at idle. I've noticed though that if I rev it to above 1000 RPM the power steering comes bacl no problem. Do you think this may suggest pump failure? If so, it's a job I'd like to do myself. If anyone has any pointers that would be great.
__________________
BIG RED '01 LE 186K
Vision Cross 16x7 Rims, 205/55/16 , Painted Calipers, Spoiler, CAI
Sound System
Pioneer DEH-64BT head unit, Zapco Z400-C4SL competition amplifier, 2 RF P2D2 12's, RF P1T-S Tweets, RF PPS4-6 Mids, RF 6x8"s, AudioControl 24XS crossover/line driver

Newest Car
2016 Jeep Patriot Sport 2.4L 6 speed auto 76k
Powerstop Z23 evolution front brakes
Sound System
Pioneer DEH-X9600BT head unit, Bē Rage 1200.6 Amp, 4 JBL GX963 6x9's, 2 Skar VVX3-12's. 6 Channel AudioControl Matrix Plus Line Driver

#LoudLife

Both powered by Mobil1
Reply With Quote
  #8 (permalink)  
Old 24 Jan 2018, 11:34 am
JonN's Avatar
Cool Cruiser
 
Join Date: Mar 2016
Location: Massachusetts
Posts: 315
Default Re: Power steering woes

I've decided I don't really feel like dealing with this, so I'll be taking to my mechanic later this week. I'll report back any findings.
__________________
BIG RED '01 LE 186K
Vision Cross 16x7 Rims, 205/55/16 , Painted Calipers, Spoiler, CAI
Sound System
Pioneer DEH-64BT head unit, Zapco Z400-C4SL competition amplifier, 2 RF P2D2 12's, RF P1T-S Tweets, RF PPS4-6 Mids, RF 6x8"s, AudioControl 24XS crossover/line driver

Newest Car
2016 Jeep Patriot Sport 2.4L 6 speed auto 76k
Powerstop Z23 evolution front brakes
Sound System
Pioneer DEH-X9600BT head unit, Bē Rage 1200.6 Amp, 4 JBL GX963 6x9's, 2 Skar VVX3-12's. 6 Channel AudioControl Matrix Plus Line Driver

#LoudLife

Both powered by Mobil1
Reply With Quote
  #9 (permalink)  
Old 29 Jan 2018, 08:53 pm
JonN's Avatar
Cool Cruiser
 
Join Date: Mar 2016
Location: Massachusetts
Posts: 315
Default Re: Power steering woes

Diagnosis came back as the pump being bad. I also had my mechanic replace all pressure hoses for peace of mind. $425 later I am back and steering is perfect.
__________________
BIG RED '01 LE 186K
Vision Cross 16x7 Rims, 205/55/16 , Painted Calipers, Spoiler, CAI
Sound System
Pioneer DEH-64BT head unit, Zapco Z400-C4SL competition amplifier, 2 RF P2D2 12's, RF P1T-S Tweets, RF PPS4-6 Mids, RF 6x8"s, AudioControl 24XS crossover/line driver

Newest Car
2016 Jeep Patriot Sport 2.4L 6 speed auto 76k
Powerstop Z23 evolution front brakes
Sound System
Pioneer DEH-X9600BT head unit, Bē Rage 1200.6 Amp, 4 JBL GX963 6x9's, 2 Skar VVX3-12's. 6 Channel AudioControl Matrix Plus Line Driver

#LoudLife

Both powered by Mobil1
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Power steering UwharriePT Tech & Performance Forum 6 04 Mar 2013 06:29 pm
Power Steering-it takes power just to steer it 05PTGT General Turbo Discussions 8 29 Jan 2013 08:37 pm
Power Steering DonGee Tech & Performance Forum 3 09 Dec 2011 07:34 am
No power steering. monitor51 Tech & Performance Forum 11 20 Dec 2010 08:47 pm
Power steering ??? Hayworth Tech & Performance Forum 4 22 Nov 2009 06:09 pm


All times are GMT -5. The time now is 11:08 pm.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors