PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > General PT Cruiser Discussions

PT Cruiser Forum

Advertisements
All hell (and maybe a serpentine belt) broke loose.

 
Like Tree2Likes
  • 2 Post By chuzz

Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 27 Feb 2018, 05:02 am
Fresh Cruiser
 
Join Date: Dec 2017
Location: Minnesota, USA
Posts: 34
Exclamation All hell (and maybe a serpentine belt) broke loose.

Well, tonight was an interesting night for me and Tina (My PTC).
I was on my way to work tonight when all of my gauges dropped to 0 and went dark. She still ran like normal but I had no idea how fast I was going. Not a huge deal but only the first of a few problems that popped up in my 2-mile commute. As I turned on to one of the main roads with a higher speed limit, I noticed something was off. She wouldn't shift outta 3rd! I was revving up to 4k just to keep the speed limit and she was growling when decelerating. I grumbled to myself but kept driving. Stopped to fill her up with some premium unleaded and she wouldn't turn over after. Got a jump start and got back on the road. As I was leaving, I lost power steering. I was able to wrestle the wheel and get to work on time but now I'm sitting here trying to figure this mess out. I'd assume the serpentine belt is bad considering the fact that my battery and power steering both went bad on the same trip. I've got a new belt and I'm sure I can figure out the install. Not a big deal. This transmission problem is really stumping me though. Could it be a vacuum leak? Is the tranny shot completely? Any ideas on how to troubleshoot the thing? This is my daily driver for at least the next few weeks so any help is greatly appreciated. Thanks in advance.

TLDR - Gauges all stopped working, battery died and tranny wont shift out of 3rd. HELP!
__________________
Silver 2001 “FreeT Cruiser” Base. Dead stock.
1/4 mile: <30 sec
0-60: eventually
I love my car and Cruiser culture.
Reply With Quote
  #2 (permalink)  
Old 27 Feb 2018, 07:30 am
Veteran Cruiser
 
Join Date: Aug 2015
Location: Lake Wales, FL
Posts: 4,264
Default Re: All hell (and maybe a serpentine belt) broke loose.

Obviously the first thing to check are the drive belts. Odds are that your alternator belt broke and then got wrapped in the power steering belt and tossed it off. No belt on alternator, you're running off battery only. Doesn't take long for one to discharge when running lights and other accessories. After replacing the belts, you'll need to recharge the battery to a full 12.5 volts. As for the transmission not shifting, I THINK it may be related to the battery discharge. IDK, I'm NOT an ASE Certified Master Mechanic.
ptprice and rsrocket1 like this.
__________________


Farts are just ghosts of the things we eat.
Reply With Quote
Reply

Tags
alternator, power steering, repair, serpentine, transmission


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Replacing Control Arms. Nut Broke loose. Help! 2004PlatinumTurbo Wheels, Tires, Suspension 5 24 Sep 2014 04:43 pm
Serpentine Belt Question. Tonys18t Tech & Performance Forum 9 12 Sep 2014 12:14 am
Serpentine belt chirping zer0dahero Tech & Performance Forum 3 09 Sep 2014 06:34 pm
Lower Control arm mounting nut broke loose gregc Wheels, Tires, Suspension 11 20 May 2012 12:14 pm
New serpentine belt already? RJ General PT Cruiser Discussions 4 07 Sep 2004 08:12 am


All times are GMT -5. The time now is 12:01 am.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors