PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > General PT Cruiser Discussions

PT Cruiser Forum

Advertisements
O2 heater circuit issue

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 09 May 2018, 09:29 pm
Fresh Cruiser
 
Join Date: Jul 2017
Posts: 11
Default O2 heater circuit issue

I've had an intermittent p0032 and p0038 code that just popped up again. This time the cel started blinking. I got a p0204 also. I checked the upsteam o2 heater circuit for resistance and it checked out. With the engine running and the O2 unplugged I checked voltage across each heating wire on the harness side of the connector. One read 9.5v the other 0.5v (both white wires). It is my understanding that they should have been 12v. Does anyone have a wiring diagram for 2004 PT turbo of the O2 connection to the pcm? Any other suggestions? Thanks.
Reply With Quote
  #2 (permalink)  
Old 10 May 2018, 03:11 am
Senior Cruiser
 
Join Date: Jan 2014
Location: SW PA
Posts: 1,348
Default Re: O2 heater circuit issue

When I had the p0038 code it was a bad/broken ground on the left fender.
Copper wires corroded and seemed tight but I found them broken after removing them from the eyelet.
__________________
Addicted to Mopar You can tell how old I am..
65 Dodge Coronet 6 cyl 2dr Post
66 Ply Satellite with 273 engine swap to 69 340 4spd
70 340 4spd Dart Swinger "Those were the days my friend"
73 Charger SE
Had a few Vetts on the way 69, 85
Several Neons some flips
01 Sebring flip
Cruiser's 01, 220K Gone to a new home
Cruiser 03 133K Gone to a new home
Cruiser 06 110K Project Gone to new Home
Cruiser 05 Ltd 120,809 bought with broken belt Oct2015
May 16 Resurrected to once again roam the streets.

20 Miles South Of Pittsburgh
Reply With Quote
  #3 (permalink)  
Old 10 May 2018, 04:31 pm
Senior Cruiser
 
Join Date: Jun 2014
Posts: 1,630
Default Re: O2 heater circuit issue

Quote:
Originally Posted by fortjp500 View Post
I've had an intermittent p0032 and p0038 code that just popped up again. This time the cel started blinking. I got a p0204 also. I checked the upsteam o2 heater circuit for resistance and it checked out. With the engine running and the O2 unplugged I checked voltage across each heating wire on the harness side of the connector. One read 9.5v the other 0.5v (both white wires). It is my understanding that they should have been 12v. Does anyone have a wiring diagram for 2004 PT turbo of the O2 connection to the pcm? Any other suggestions? Thanks.
You may get lucky and find it is a loose wire or bad ground, so definitely check them out. But, most times, these codes are signaling a failed PCM. I speculate that the high under hood temperatures caused by the turbo, and because the PCM is so very close to that turbo, cause the PCM to fail. It seems that the O2 circuits fail first.

But definitely check your connections and grounds first.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Heater Issue ajhockey3 General PT Cruiser Discussions 2 08 Jan 2018 09:34 pm
O2 sensor heater circuit NPTW Tech & Performance Forum 4 02 Jun 2017 01:21 pm
o2 heater circuit problems Aristo99 General Turbo Discussions 2 04 Oct 2012 07:12 pm
Heater Blower Motor Issue sscanlan General PT Cruiser Discussions 5 30 Aug 2011 10:50 pm
Issue with ac and heater when turn dial on. steph66 General PT Cruiser Discussions 6 06 Feb 2011 07:40 am


All times are GMT -5. The time now is 07:41 am.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors