PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > General PT Cruiser Discussions

PT Cruiser Forum

Advertisements
Ongoing P0481 Problem

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 08 Jun 2018, 08:37 pm
Fresh Cruiser
 
Join Date: Apr 2018
Location: Broomall, PA
Posts: 7
Default Ongoing P0481 Problem

Thanks to this forum, I was able to diagnose and repair my recent P0481 error code...I purchased my 2007 Base PT Cruiser 2 months ago. I noticed that the A/C was not up to par. It would blow somewhat cool, but far from cold. A few weeks after I purchased it, the check engine light came on, and it began to overheat when stopped at a red light or when idling. I learned from this forum about the "key dance", got the P0481 code, and searched this forum for answers. I learned about how to test the fan and relays...determined that the fan wasn't functioning on either low or high speed, even when the A/C was turned on. I replaced the cooling fan assy (complete with both relays on the side). After replacement, the fan now comes on when the A/C is turned on, and it doesn't overheat any more, and the check engine light went off. However, the A/C is still just cool, not cold. A few days after I replaced the fan, the check engine light came on again. The key dance, which I tried several times over a few days, didn't show a code...just "done". I mentioned this to a friend of mine who is a retired auto mechanic. He stopped by with his code reader (or scanner). He wasn't able to get a diagnostic code, just a "dealer " code is what I think he called it. He told me to disconnect the battery for 15 minutes, and it should turn off the check engine light...which I did. The light went off, but came back on the next morning. I tried the key dance again, and got the original P0481 again. Over the next few days, the light will stay on for a day or 2, go off for a day or 2, then come back on again. After being on for 2 days, tonite when I left work, it was off. After 2 short trips, it's on again, but the key dance just says "done", no codes.
Sorry to make this so long...but here's my questions:

1) Could the P0481 code just be a history code since the car runs fine and doesn't overheat since the fan was replaced?
2) Could the A/C not working up to par just be low freon, since the cooling fan works, compressor comes on, and it does blow somewhat cool?
3) Could low freon be causing the P0481? (Forgot to mention that I replaced the low side A/C pressure switch a few days ago).
4) Does a code have to be cleared when the faulty part is replaced...so the code doesn't return again?
5) Could it be that a Chrysler dealer has to clear the code with their scanner?

Once again, sorry for such a long, boring post! Any help or suggestions is welcomed!
Thanks-Steve S. in PA
Reply With Quote
  #2 (permalink)  
Old 08 Jun 2018, 08:43 pm
Cool Cruiser
 
Join Date: Mar 2005
Location: Panama City, Panama.
Posts: 328
Default Re: Ongoing P0481 Problem

take it to an AC repair shop. Yes if its low on freon the AC will turn off to avoid burning up.
Any competent AC shop would figure it out quickly.
__________________
2003 GT
Reply With Quote
  #3 (permalink)  
Old 08 Jun 2018, 11:55 pm
Obsessed Cruiser
 
Join Date: Aug 2014
Location: Thousand Oaks, CA
Posts: 7,066
Default Re: Ongoing P0481 Problem

I would suggest buying your own OBDII Scan Tool and reset the diagnostic trouble codes. The DTC's are stored until you reset them with an OBDII Scan Tool. Keep in mind not all OBDII Scan Readers will reset the codes so do your own homework but I prefer the OBDII Scan Tools.

What brand radiator fan did you buy? New or used?


P0481 - High Speed Fan Relay Control Circuit:

Possible Causes:

Fused (B+) Circuits
Ground Circuit
High Speed Rad Fan Control Circuit Shorted To Battery Voltage
High Speed Rad Fan Control Circuit Open
High Speed Rad Fan Control Circuit Shorted To Ground
Radiator Cooling Fan Module
Totally Integrated Power Module

When I replaced one of my radiator fans in one of my Pt Cruisers I found one of the contacts in the plug of the new radiator fan pushed in not making good contact. I replaced the plug before installing the new radiator fan. Did you inspect all of the contacts in the radiator fan plug before plugging it in?
__________________
If at First You Don't Succeed - Try, Try Again

Last edited by ptcruisersteve; 12 Jun 2018 at 09:08 pm.
Reply With Quote
  #4 (permalink)  
Old 11 Jun 2018, 08:57 am
Fk5 Fk5 is offline
Senior Cruiser
 
Join Date: Jul 2011
Location: Colesville, MD
Posts: 1,569
Default Re: Ongoing P0481 Problem

If the light is on there is a problem. The code might persist for a bit if you didn't reset it, but the light would not be coming and going unless the problem were coming and going. Sorry, I have no info to help with a/c or P0481. Knock wood.
__________________
2003 GT 5 speed
162,000 miles
Reply With Quote
  #5 (permalink)  
Old 11 Jun 2018, 12:08 pm
ajhockey3's Avatar
Cool Cruiser
 
Join Date: Oct 2017
Location: Ontario
Posts: 453
Default Re: Ongoing P0481 Problem

hows your pressure switch? common part easy to replace. Jump it
__________________

2006 PT Cruiser Base 2.4L NA $250
Reply With Quote
  #6 (permalink)  
Old 11 Jun 2018, 02:15 pm
Cool Cruiser
 
Join Date: May 2016
Location: GA
Posts: 226
Default Re: Ongoing P0481 Problem

As Steve has suggested, inspect your connections. Since the problem comes and goes is a good indication of a possible bad connection. Especially since you have been working in the area.
__________________
08 PT Cruiser Limited - 82K (Original Owner)
14 Ram 1500 -Big Horn

Semper Fi (USMC 96-01)

"Insanity: Doing the same thing over and over again and expecting different results." -Einstein
Reply With Quote
  #7 (permalink)  
Old 12 Jun 2018, 07:20 pm
Fresh Cruiser
 
Join Date: Apr 2018
Location: Broomall, PA
Posts: 7
Default Re: Ongoing P0481 Problem

Thanks everyone for all your help...I did purchase a scan tool that will erase codes.
However...now there's ANOTHER cooling fan problem which really has me confused...
Check engine light has been on again for a few days. No problems on my way to work today, but, on the way home, began to overheat when stopped! Most of my drive is highway, so I got home ok. Checked fan operation when I got home, and found the new fan is NOT working, either when the a/c is on, or when at idle and the temperature begins to rise. Just replaced the fan, which came with 2 new relays, just a few weeks ago. Although I had the intermittant check engine light (P0481), the fan operated. Now it's dead again! And to further complicate matters, when I started it tonite to put it in the driveway, the check engine light was OFF, even though the fan is not working. I had planned to spend my day off tomorrow checking the grounds, wiring, and the connections, but now I'm not sure, since the check engine light is off, if I need to go in a "dfiferent direction". A/C still blows somewhat cool, but not cold. I did replace the low pressure switch, since it was inexpensive, last week. Any help would once again be greatly appreciated!!!
Reply With Quote
  #8 (permalink)  
Old 12 Jun 2018, 09:15 pm
Obsessed Cruiser
 
Join Date: Aug 2014
Location: Thousand Oaks, CA
Posts: 7,066
Default Re: Ongoing P0481 Problem

I would suggest manually applying 12 volts to the radiator plug that is connected to the engine wire harness on both speeds.

Check all wiring and the plugs going to the radiator fan.

A bad TIPM can trigger the P0481 but this is very rare. I would check everything else first before looking at the TIPM.
__________________
If at First You Don't Succeed - Try, Try Again
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
ongoing problem after head gasket job 944tim Tech & Performance Forum 8 09 Jun 2018 04:18 pm
Problem with Code P0481 214DallasTexas General PT Cruiser Discussions 10 03 Nov 2017 03:08 pm
ongoing Starter problem schism Tech & Performance Forum 12 31 Jan 2016 07:10 pm
Ongoing Problem with Intermittent Rough Engine at Almost Idle NewPTCruiserInPA Tech & Performance Forum 3 10 Sep 2013 10:56 am


All times are GMT -5. The time now is 02:15 am.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors