PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > General PT Cruiser Discussions

PT Cruiser Forum

Advertisements
Weird problem with my turn signals.

 
Like Tree13Likes

Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 02 Aug 2018, 05:08 pm
Regular Cruiser
 
Join Date: Apr 2018
Posts: 103
Default Weird problem with my turn signals.

Alright, this started a few weeks ago.

The turn signals barely click, or click for a few times then shut off. Then later (during the same drive) they work like they should.

I don't think the bulbs are bad, otherwise they would click rapidly. I also changed the fuses that pertain to the left and right signals. Not sure what's going on here.

I have a 40 second vid that i took. But i can't to upload to imgur, and attaching it with the thread options doesn't seem to work.
Reply With Quote
  #2 (permalink)  
Old 02 Aug 2018, 07:04 pm
Obsessed Cruiser
 
Join Date: Aug 2014
Location: Thousand Oaks, CA
Posts: 7,118
Default Re: Weird problem with my turn signals.

Quote:
Originally Posted by texas2002cruiser View Post
Alright, this started a few weeks ago.

The turn signals barely click, or click for a few times then shut off. Then later (during the same drive) they work like they should.

I don't think the bulbs are bad, otherwise they would click rapidly. I also changed the fuses that pertain to the left and right signals. Not sure what's going on here.

I have a 40 second vid that i took. But i can't to upload to imgur, and attaching it with the thread options doesn't seem to work.
Are all four bulbs doing the same problem?

Is there any difference whether it is the left side or the right side that is blicking?
__________________
If at First You Don't Succeed - Try, Try Again
Reply With Quote
  #3 (permalink)  
Old 02 Aug 2018, 08:01 pm
Regular Cruiser
 
Join Date: Apr 2018
Posts: 103
Default Re: Weird problem with my turn signals.

Yeah, seems like it.

I flip the left, and it will blink a few times then stop. Then i switch to the right and the same... Then after a while they will work fine.

I really wish i could post the video
Reply With Quote
  #4 (permalink)  
Old 02 Aug 2018, 08:09 pm
Regular Cruiser
 
Join Date: Apr 2018
Posts: 103
Default Re: Weird problem with my turn signals.

For the moderators, this is the message i get when i try to upload the vid.


Your submission could not be processed because a security token was missing.

If this occurred unexpectedly, please inform the administrator and describe the action you performed before you received this error.
Reply With Quote
  #5 (permalink)  
Old 02 Aug 2018, 08:39 pm
rckstein's Avatar
Obsessed Cruiser
 
Join Date: Dec 2010
Location: Texas
Posts: 14,366
Default Re: Weird problem with my turn signals.

There currently is no forum moderator.

Post your video to YouTube and then you can post the video in a thread post.
__________________

'06 Touring Edition NA Automatic
160k Miles / Electric Blue Pearl
USMC '82 - '93
Reply With Quote
  #6 (permalink)  
Old 02 Aug 2018, 09:53 pm
Regular Cruiser
 
Join Date: Apr 2018
Posts: 103
Default Re: Weird problem with my turn signals.

Ok, I'm gonna do that.

Gimme a few
Reply With Quote
  #7 (permalink)  
Old 02 Aug 2018, 09:58 pm
Regular Cruiser
 
Join Date: Apr 2018
Posts: 103
Default Re: Weird problem with my turn signals.

Ok, here's the link. I don't know how to embed the video on this forum.

If someone can give me the embed code. I'll fix it

https://youtu.be/4Nrhs3aBBM8
Reply With Quote
  #8 (permalink)  
Old 02 Aug 2018, 10:08 pm
Obsessed Cruiser
 
Join Date: Aug 2014
Location: Thousand Oaks, CA
Posts: 7,118
Default Re: Weird problem with my turn signals.

Does the hazard lights also stops blinking?
__________________
If at First You Don't Succeed - Try, Try Again
Reply With Quote
  #9 (permalink)  
Old 02 Aug 2018, 10:11 pm
Regular Cruiser
 
Join Date: Apr 2018
Posts: 103
Default Re: Weird problem with my turn signals.

Quote:
Originally Posted by ptcruisersteve View Post
Does the hazard lights also stops blinking?
Haven't tried that.
Reply With Quote
  #10 (permalink)  
Old 02 Aug 2018, 10:39 pm
rckstein's Avatar
Obsessed Cruiser
 
Join Date: Dec 2010
Location: Texas
Posts: 14,366
Default Re: Weird problem with my turn signals.

Your vehicle is running and the Check Engine Light is on.

Do you have any codes related to that?

Doesn't the Gen1 have a separate, replaceable, turn signal/hazard flasher, where the Gen2 it's built into the instrument cluster?

I found this online:

"The turn signal flasher and the hazard warning flasher are combined into one unit called a Combination Flasher (combo-flasher) The combo-flasher is a smart relay located on the back of the multi-function switch (Turn Signal ). The combo-flasher is black in color and has a dampener material wrapped on it. The flasher is mounted to the back side of the multi-function switch Combination-Flasher The flasher is serviced separately from the multi-function switch."

Here's your vid:

__________________

'06 Touring Edition NA Automatic
160k Miles / Electric Blue Pearl
USMC '82 - '93

Last edited by rckstein; 03 Aug 2018 at 06:46 am.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Turn signals CREWZIN Tech & Performance Forum 8 02 Mar 2015 05:09 pm
no turn signals Darkchylde Tech & Performance Forum 13 29 Mar 2014 10:44 am
turn signals yukonak2 General PT Cruiser Discussions 7 10 Sep 2013 01:44 pm
2007 problem solved - No turn signals, no wipers, no highbeams, lights on Nameless1 Tech & Performance Forum 7 15 Aug 2013 07:36 pm
turn signals AlexJB Exterior Accessories Forum 6 12 May 2008 08:12 pm


All times are GMT -5. The time now is 09:25 am.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors