PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > General PT Cruiser Discussions

PT Cruiser Forum

Advertisements
all lights flashing on cluster - No power loss

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 18 Sep 2018, 01:18 pm
Cool Cruiser
 
Join Date: May 2013
Location: 20 minutes from downtown Los angeles
Posts: 213
Default all lights flashing on cluster - No power loss

I had this issue two years ago or probably longer and it went away. I kept fiddling around with the wiring that goes to the multi-function switch.

Back then, power would also cut off while driving. Very dangerous. Power would cut off for a second or two then come back on.

Issue came back and would love to hear a 100% for sure fix for this.

From what I've read it could be

Bad ground wires around the battery
bad multi-function switch
ignition switch (can't be taken apart in my 2006)
wiring to the multi-function switch
TIPM?
__________________
--2006 pt cruiser non turbo owner. Completely stock... For now.
Reply With Quote
  #2 (permalink)  
Old 18 Sep 2018, 07:30 pm
Obsessed Cruiser
 
Join Date: Aug 2014
Location: Thousand Oaks, CA
Posts: 7,308
Default Re: all lights flashing on cluster - No power loss

Can you post a video of what is flashing?
__________________
If at First You Don't Succeed - Try, Try Again
Reply With Quote
  #3 (permalink)  
Old 19 Sep 2018, 07:36 am
Veteran Cruiser
 
Join Date: Aug 2015
Location: Lake Wales, FL
Posts: 4,750
Default Re: all lights flashing on cluster - No power loss

I don't have a permanent fix, but sometimes lowering or raising the steering column helps. Wires get pinched in there.
__________________


Aspire to inspire before you expire.
Reply With Quote
  #4 (permalink)  
Old 19 Sep 2018, 05:14 pm
Cool Cruiser
 
Join Date: May 2013
Location: 20 minutes from downtown Los angeles
Posts: 213
Default Re: all lights flashing on cluster - No power loss

Quote:
Originally Posted by ptcruisersteve View Post
Can you post a video of what is flashing?
No video, but it is ALL dashboard lights, dome light stays off. Imagine turning the key one click and all lights go on. Check engine, abs, oil, everything.

While driving, everything turns off for a millisecond, the lights all turn on, and power is resumed. All this over a fraction of a second.

In the video below, can those wires be completely removed, cleaned off, and re-inserted? I have a feeling my issue is from the connection point below.

__________________
--2006 pt cruiser non turbo owner. Completely stock... For now.
Reply With Quote
  #5 (permalink)  
Old 19 Sep 2018, 05:23 pm
Cool Cruiser
 
Join Date: May 2013
Location: 20 minutes from downtown Los angeles
Posts: 213
Default Re: all lights flashing on cluster - No power loss

Can only the ignition switch be replaced without replacing the lock cylinder?

Mine is the 2006 and its the weird version where it doesn't have the hole where you can push in to release the cylinder.

I took it apart but could never get to the inside.

I wish there was a pt cruiser mechanic in southern california.

I may end up taking a road trip to NCAL just to get this fixed by a pro.
__________________
--2006 pt cruiser non turbo owner. Completely stock... For now.
Reply With Quote
  #6 (permalink)  
Old 19 Sep 2018, 05:27 pm
Cool Cruiser
 
Join Date: May 2013
Location: 20 minutes from downtown Los angeles
Posts: 213
Default Re: all lights flashing on cluster - No power loss

__________________
--2006 pt cruiser non turbo owner. Completely stock... For now.
Reply With Quote
  #7 (permalink)  
Old 19 Sep 2018, 09:38 pm
Obsessed Cruiser
 
Join Date: Aug 2014
Location: Thousand Oaks, CA
Posts: 7,308
Default Re: all lights flashing on cluster - No power loss

I would suggest doing a battery load test. Sometimes the battery goes bad and the battery voltage goes down just enough to trigger electrical gremlins.

Also suggest checking the ground wires going to both fenders.

This member fixed the problem with a new battery and cleaning the battery cable contacts.
Intermittent issue, wonder if anyone else has this
__________________
If at First You Don't Succeed - Try, Try Again
Reply With Quote
  #8 (permalink)  
Old 20 Sep 2018, 02:11 pm
Cool Cruiser
 
Join Date: May 2016
Posts: 269
Default Re: all lights flashing on cluster - No power loss

I found lots of similar issues on the web after experiencing these symptoms and R2 the battery was the common fix. R2 my battery and had no issues since. It's been just over 3 years. I know its been 3 years because my battery recently wouldn't hold a charge and it was a month out of its 3 yr warranty Like Steve recommended, have the battery load tested.
Reply With Quote
  #9 (permalink)  
Old 20 Sep 2018, 02:32 pm
Fk5 Fk5 is offline
Senior Cruiser
 
Join Date: Jul 2011
Location: Colesville, MD
Posts: 1,836
Default Re: all lights flashing on cluster - No power loss

I had a similar problem around Christmas of 2011. The lights would all come on. Dash would go crazy, all numbers flashing, getting super bright. A few weeks prior, I was working a bunch of hours and had a shop do some work on the car. Turned out they took the battery out and didn't tighten it back up. The terminals were tight, so when I checked it seemed fine. I tightened it at the toll booth for the Whitestone Bridge, 4:00 am 16 December. All good ever since.
__________________
2003 GT 5 speed
162,000 miles

Last edited by Fk5; 20 Sep 2018 at 02:52 pm.
Reply With Quote
  #10 (permalink)  
Old 22 Sep 2018, 11:03 pm
Cool Cruiser
 
Join Date: May 2013
Location: 20 minutes from downtown Los angeles
Posts: 213
Default Re: all lights flashing on cluster - No power loss

Quote:
Originally Posted by Grasshopper77 View Post
I found lots of similar issues on the web after experiencing these symptoms and R2 the battery was the common fix. R2 my battery and had no issues since. It's been just over 3 years. I know its been 3 years because my battery recently wouldn't hold a charge and it was a month out of its 3 yr warranty Like Steve recommended, have the battery load tested.
What is R2 the battery?

Ground to battery? I do have corrosion on the attachments and the battery is about 2 years old.. battery should be decent.

I'll tell mechanic to replace all ground wires? Isn't it known as the big 3? Should I go to a mechanic or an audio shop?
__________________
--2006 pt cruiser non turbo owner. Completely stock... For now.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Gauge cluster lights, shifter lights, and rear running lights out Jspata Tech & Performance Forum 3 18 Oct 2016 04:33 am
Start-up Issues plus all lights flashing and loss of power while driving. funkyfred General PT Cruiser Discussions 3 15 Mar 2016 07:59 pm
Flashing red light in black dot within instrument cluster CruiserLady Interior Accessories Forum 4 10 Nov 2012 10:43 pm
Flashing dash lights mystynm General PT Cruiser Discussions 4 04 Apr 2012 05:29 pm
Help! Flashing dashboard lights! Silvercat Tech & Performance Forum 2 31 Jan 2011 11:24 am


All times are GMT -5. The time now is 09:50 pm.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors