PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > General PT Cruiser Discussions

PT Cruiser Forum

Advertisements
Codes 344 and 340 bucking and surging

 
Like Tree12Likes

Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 11 Oct 2018, 05:54 pm
Fresh Cruiser
 
Join Date: Sep 2017
Posts: 30
Default Codes 344 and 340 bucking and surging

hey everybody, i'm trying to troubleshoot this cam sensor issue. can anyone tell me what I should be looking for on the 3 wires going to the cam sensor? I know the center one is ground and it's good. i'm getting right about 5 volts from the other two. I thought only one of them was supposed to be 5V. anyone know?

history: I put on an aftermarket sensor last year (yes I know), because the other one was leaking oil. turned out it had no o-ring on it. it's been running great for the last year. recently it will buck and surge intermittently. some days it's fine. other days not. I put in a new aftermarket sensor just to see what it would do and it's much worse. it wouldn't start. then it did, but within a couple minutes of driving, it started bucking again.



thanks!!!
Reply With Quote
  #2 (permalink)  
Old 11 Oct 2018, 07:07 pm
Obsessed Cruiser
 
Join Date: Aug 2014
Location: Thousand Oaks, CA
Posts: 7,118
Default Re: Codes 344 and 340 bucking and surging

Quote:
Originally Posted by jeff180 View Post
hey everybody, i'm trying to troubleshoot this cam sensor issue. can anyone tell me what I should be looking for on the 3 wires going to the cam sensor? I know the center one is ground and it's good. i'm getting right about 5 volts from the other two. I thought only one of them was supposed to be 5V. anyone know?

history: I put on an aftermarket sensor last year (yes I know), because the other one was leaking oil. turned out it had no o-ring on it. it's been running great for the last year. recently it will buck and surge intermittently. some days it's fine. other days not. I put in a new aftermarket sensor just to see what it would do and it's much worse. it wouldn't start. then it did, but within a couple minutes of driving, it started bucking again.



thanks!!!
P0340 - No Camshaft Position Sensor Circuit Failure Conditions:

Possible Causes:

1. Camshaft Position Sensor connector is damaged, open or it is shorted
2. Camshaft Position Sensor signal circuit is open or shorted to ground or to battery voltage or 5 volt circuit
3. Camshaft Position Sensor 5 volt circuit is open or shorted to ground or to battery voltage
4. Camshaft Position Sensor ground circuit is open
5. Camshaft Position Sensor is damaged or has failed
6. PCM has failed

P0344 - Camshaft Position Sensor Circuit Intermittent

Possible Causes:
1. Wiring harness fault 5v supply circuit open or shorted to ground
2. Tone wheel/pulse ring is damaged or corroded
3. Camshaft Position Sensor has failed
4. Camshaft Position Sensor signal circuit is open, shorted to ground
5. Camshaft Position Sensor ground circuit is open
6. PCM has failed

Your target magnet might be cracked if it was removed and reinstalled and over tightened in the process. One member had loosen up the target magnet screws holding the target magnet and that removed the P0344 code. This is very rare but you never know.

Some of the time the members have replaced the aftermarket sensor with OEM sensor and it solves the problem. I only replace sensors with OEM on both of my Pt Cruisers. Never had a problem. Both have only been replaced once.

Also suggest checking the wiring from the camshaft sensor to the PCM. Make sure all wires going to the Camshaft sensor is good.

I would also check the ground wires going to the drivers side fender well. Make sure they are all making good contact.
jeff180 likes this.
__________________
If at First You Don't Succeed - Try, Try Again

Last edited by ptcruisersteve; 11 Oct 2018 at 08:59 pm.
Reply With Quote
  #3 (permalink)  
Old 11 Oct 2018, 10:31 pm
Fresh Cruiser
 
Join Date: Sep 2017
Posts: 30
Default Re: Codes 344 and 340 bucking and surging

the magnet hasn't been removed from the camshaft. what do I look for with those 3 wires? I know one is ground. another is the 5V computer, but what is the other supposed to read on a DMM?
Reply With Quote
  #4 (permalink)  
Old 12 Oct 2018, 01:36 am
Obsessed Cruiser
 
Join Date: Aug 2014
Location: Thousand Oaks, CA
Posts: 7,118
Default Re: Codes 344 and 340 bucking and surging

Quote:
Originally Posted by jeff180 View Post
the magnet hasn't been removed from the camshaft. what do I look for with those 3 wires? I know one is ground. another is the 5V computer, but what is the other supposed to read on a DMM?
According to the shop manual the Camshaft sensor signal is measured using lab scope to measure the square signal 0-5 volts. The results of the DMM measurement can different depending on what kind of DMM you have. You are better off using a lab scope to actually see the square signal.
jeff180 likes this.
__________________
If at First You Don't Succeed - Try, Try Again
Reply With Quote
  #5 (permalink)  
Old 12 Oct 2018, 08:38 am
Fresh Cruiser
 
Join Date: Sep 2017
Posts: 30
Default Re: Codes 344 and 340 bucking and surging

I don't have access to a lab scope.
Reply With Quote
  #6 (permalink)  
Old 12 Oct 2018, 10:47 am
Senior Cruiser
 
Join Date: Jan 2014
Location: SW PA
Posts: 1,294
Default Re: Codes 344 and 340 bucking and surging

Try checking to see how snug not over tightened the cam sensor is.. Check for over tighten and crack,, just a thought...
__________________
Addicted to Mopar You can tell how old I am..
65 Dodge Coronet 6 cyl 2dr Post
66 Ply Satellite with 273 engine swap to 69 340 4spd
70 340 4spd Dart Swinger "Those were the days my friend"
73 Charger SE
Had a few Vetts on the way 69, 85
Several Neons some flips
01 Sebring flip
Cruiser's 01, 220K Gone to a new home
Cruiser 03 133K Gone to a new home
Cruiser 06 110K Project Gone to new Home
Cruiser 05 Ltd 120,809 bought with broken belt Oct2015
May 16 Resurrected to once again roam the streets.

20 Miles South Of Pittsburgh
Reply With Quote
  #7 (permalink)  
Old 12 Oct 2018, 10:59 am
Fresh Cruiser
 
Join Date: Sep 2017
Posts: 30
Default Re: Codes 344 and 340 bucking and surging

I will do that. the sensor I took out would start the car normally and it worked great for over a year. I put a new one in yesterday and it wouldn't start, then did and idled ok, but when you get it up in RPM's it starts surging. the one I took out would do that after several minutes. i'd turn off the car and restart it and it would run fine the rest of the day
Reply With Quote
  #8 (permalink)  
Old 12 Oct 2018, 11:37 am
Obsessed Cruiser
 
Join Date: Aug 2014
Location: Thousand Oaks, CA
Posts: 7,118
Default Re: Codes 344 and 340 bucking and surging

Quote:
Originally Posted by jeff180 View Post
I don't have access to a lab scope.
I have looked at automotive handheld mini digital oscilloscopes that might be affordable but don't have enough knowledge to recommend one.
jeff180 likes this.
__________________
If at First You Don't Succeed - Try, Try Again
Reply With Quote
  #9 (permalink)  
Old 12 Oct 2018, 11:39 am
Obsessed Cruiser
 
Join Date: Aug 2014
Location: Thousand Oaks, CA
Posts: 7,118
Default Re: Codes 344 and 340 bucking and surging

Quote:
Originally Posted by jeff180 View Post
I will do that. the sensor I took out would start the car normally and it worked great for over a year. I put a new one in yesterday and it wouldn't start, then did and idled ok, but when you get it up in RPM's it starts surging. the one I took out would do that after several minutes. i'd turn off the car and restart it and it would run fine the rest of the day
Some members have removed the gasket on the aftermarket camshaft sensors to get the aftermarket camshaft sensors closer to the target magnet and have posted that the sensors work better. This might explain why the original camshaft sensor you had on the Pt Cruiser had no O-ring if it was an aftermarket camshaft sensor.
jeff180 likes this.
__________________
If at First You Don't Succeed - Try, Try Again

Last edited by ptcruisersteve; 12 Oct 2018 at 11:42 am.
Reply With Quote
  #10 (permalink)  
Old 12 Oct 2018, 11:56 am
Fresh Cruiser
 
Join Date: Sep 2017
Posts: 30
Default Re: Codes 344 and 340 bucking and surging

worth a try
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Bucking PT dvddmc Tech & Performance Forum 6 10 Jun 2013 10:48 pm
2006 PT Cruiser bucking when accelerating + no check engine codes mattamusprime General PT Cruiser Discussions 4 26 Mar 2012 08:59 pm
bucking at 1/2 a tank rhell Tech & Performance Forum 4 01 Sep 2010 07:50 am
Bucking bquik Tech & Performance Forum 5 06 May 2010 08:26 pm
Yet Another Surging/Bucking Cruiser.... Scarlet2003 Tech & Performance Forum 2 08 Nov 2008 07:05 pm


All times are GMT -5. The time now is 05:56 pm.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors