PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > General PT Cruiser Discussions

PT Cruiser Forum

Advertisements
Random Electrical Glitches

 
Like Tree18Likes

Reply
 
LinkBack Thread Tools Display Modes
  #11 (permalink)  
Old 11 Feb 2019, 05:09 am
Senior Cruiser
 
Join Date: Jun 2014
Posts: 1,651
Default Re: Random Electrical Glitches

As the others have suggested, check your battery, the battery connections, the grounds, and that your alternator is delivering a stable/clean charge and not erratic. As well, I recall a video posted quite a while ago, from youtube, where the person had loose connections to the wiring under the plastic covers around the steering wheel and steering column. Definitely worth a check.

Failing all that, it is a rather common problem, on particularly the 06 year, for a failing TIPM (Totally Integrated Power Module), which is basically a computerized fuse box under the hood, to manifest itself in exactly the way you have described. The TIPM controls power distribution to most of the car. The replacement TIPM will normally cost about $600. You can save yourself quite a bit of money by grabbing one from the junkyard.

Techinically, they are vin coded to the car they are installed in, however this does not affect the car in any way and will not generate any check engine light. Only the dealer would see the vin mismatch code, and only if they went digging for it.

Around here they charge $20 for a "fuse box" so you may get one quite cheaply. All 2nd gens used the same TIPM so either look for a replacement from an 06, which may have been changed already with a Dorman unit, or factory piece with the last letters AR on the part number label. The later years likely had the newest version installed from the factory. You could either get one of these used units, or a few of them even, since they are cheap, and run the car using them, presumably for many years to come, or, you could use one to verify that is your problem before coughing up the $600 for a new/rebuilt one.
Reply With Quote
  #12 (permalink)  
Old 12 Feb 2019, 09:24 pm
SpaceMouse's Avatar
Cool Cruiser
 
Join Date: Jul 2017
Location: SF Bay Area / Central Valley
Posts: 209
Default Re: Random Electrical Glitches

I pulled and cleaned the 7 lead ground terminal; it looked like it had never been touched since it was originally installed. Gave it, the mounting screw, and the inner fender a good scrubbing with a wire brush. Haven't had ANY of the symptoms occur since.
THANKS!
__________________
Reply With Quote
  #13 (permalink)  
Old 13 Feb 2019, 12:36 am
soonercruiser's Avatar
Obsessed Cruiser
 
Join Date: Jun 2007
Location: Oklahoma City
Posts: 8,540
Default Re: Random Electrical Glitches

Quote:
Originally Posted by SpaceMouse View Post
I pulled and cleaned the 7 lead ground terminal; it looked like it had never been touched since it was originally installed. Gave it, the mounting screw, and the inner fender a good scrubbing with a wire brush. Haven't had ANY of the symptoms occur since.
THANKS!
GOOD!
__________________
Frank, aka SOONERCRUISER,

2003 PT Cruiser GT Panel Van Conversion as new day driver.

Have now owned 6 PT Cruisers = Me PT Crazy!
Reply With Quote
  #14 (permalink)  
Old 14 Feb 2020, 11:57 am
Fresh Cruiser
 
Join Date: Mar 2017
Posts: 3
Default Re: Random Electrical Glitches

Our '06 Touring convertible is also doing the random electrical glitches. Instruments all go to zero, dash warning lights all come on, seat belt warning comes on, then just like that, everything comes back on. Can do it several times a day or only once in a year. Usually will not affect the driving except once it started to do it every few minutes, and the power went way down. Had to keep pumping the gas to keep it running. Only did that once. Dealer checked it all over and could not find an issue. Going to check that 7 wire ground as mentioned by others. Thanks !
rockandroller likes this.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
random electrical issue esoess Tech & Performance Forum 6 03 Nov 2016 12:54 pm
Random PT Art for 1/12 Chromenut General PT Cruiser Discussions 1 12 Jan 2012 02:31 pm
No Power To A/C; Other Electrical Glitches NewPTCruiserInPA Tech & Performance Forum 11 22 Jul 2011 11:10 pm
electrical problem. burning electrical plug cruiserjim269 General PT Cruiser Discussions 17 03 Dec 2010 03:38 pm
HELP! Weird electrical glitches then wont start Bazinga Tech & Performance Forum 6 03 Jul 2010 07:59 pm


All times are GMT -5. The time now is 12:21 pm.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors