PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > General PT Cruiser Discussions

PT Cruiser Forum

Advertisements
Radio stops working related to ignition switch or key chip?

 
Like Tree4Likes
  • 1 Post By rcktpwrd
  • 2 Post By rckstein
  • 1 Post By rcktpwrd

Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 22 Feb 2019, 09:46 pm
Fresh Cruiser
 
Join Date: Feb 2013
Posts: 13
Default Radio stops working related to ignition switch or key chip?

Hi all

My 04 PT's radio comes and goes intermittently, I was playing around tonight and found that the radio will work when key is in Acc. position but not work when car is running.

Has anyone see this before? Maybe something in the key chip? or ignition switch?

Thanks for your help

Jeff
Reply With Quote
  #2 (permalink)  
Old 22 Feb 2019, 09:55 pm
rob302's Avatar
Veteran Cruiser
 
Join Date: Jul 2016
Location: Darien, IL | Forest Park, IL
Posts: 3,519
Default Re: Radio stops working related to ignition switch or key chip?

When the radio is out, does the horn work? If so I doubt its key related
__________________
.
Reply With Quote
  #3 (permalink)  
Old 25 Feb 2019, 09:43 am
rcktpwrd's Avatar
Senior Cruiser
 
Join Date: Jan 2011
Location: Raleigh, NC
Posts: 1,804
Cool Re: Radio stops working related to ignition switch or key chip?

Is it just the radio display that is off or the radio doesn't actually turn on? If it is just the display, does the key in the ignition chime work? If the chime is also out then it is most likely a ground issue that is easily fixed.
__________________
Joel

2001 PT Cruiser 5-speed; 1976 Oldsmobile Cutlass S; 1990 Chevy 454SS; 1995 Caprice Classic woody
www.rcktpwrd.com
Reply With Quote
  #4 (permalink)  
Old 25 Feb 2019, 10:18 am
rcktpwrd's Avatar
Senior Cruiser
 
Join Date: Jan 2011
Location: Raleigh, NC
Posts: 1,804
Cool Re: Radio stops working related to ignition switch or key chip?

Post #9 in this thread: radio fix
rckstein likes this.
__________________
Joel

2001 PT Cruiser 5-speed; 1976 Oldsmobile Cutlass S; 1990 Chevy 454SS; 1995 Caprice Classic woody
www.rcktpwrd.com
Reply With Quote
  #5 (permalink)  
Old 25 Feb 2019, 03:30 pm
Fresh Cruiser
 
Join Date: Feb 2013
Posts: 13
Default Re: Radio stops working related to ignition switch or key chip?

The radio and horn are dead, When I banged on steering wheel radio and horn came back. Where is the ground for the horn/radio?

Seems like a loose ground someplace.

Thanks Jeff
Reply With Quote
  #6 (permalink)  
Old 25 Feb 2019, 03:41 pm
rckstein's Avatar
Banned
 
Join Date: Dec 2010
Location: Texas
Posts: 15,518
Default Re: Radio stops working related to ignition switch or key chip?

Quote:
Originally Posted by designer_jeff View Post
The radio and horn are dead, When I banged on steering wheel radio and horn came back. Where is the ground for the horn/radio?

Seems like a loose ground someplace.

Thanks Jeff
As previously posted:

Quote:
Originally Posted by rcktpwrd View Post
Post #9 in this thread: radio fix
Here are the pics from that thread:





Reply With Quote
  #7 (permalink)  
Old 25 Feb 2019, 07:37 pm
rcktpwrd's Avatar
Senior Cruiser
 
Join Date: Jan 2011
Location: Raleigh, NC
Posts: 1,804
Cool Re: Radio stops working related to ignition switch or key chip?

I did this repair back in 2011 based on my post in that thread, been working perfectly since then! Except for the horn... I added a separate button for that.
rckstein likes this.
__________________
Joel

2001 PT Cruiser 5-speed; 1976 Oldsmobile Cutlass S; 1990 Chevy 454SS; 1995 Caprice Classic woody
www.rcktpwrd.com
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
OEM CD/Radio to Ignition Switch problem harry General PT Cruiser Discussions 4 05 Feb 2018 09:14 am
Replaced ignition actuator switch, now radio display doesn't work Caelestis General PT Cruiser Discussions 11 19 Jun 2016 08:54 pm
Radio Not Working After Ignition Actuator Replacement jeremysaal Tech & Performance Forum 5 17 Nov 2015 02:09 pm
Ignition Switch / Random Stall / Loss of Radio - HELP DagnyT Tech & Performance Forum 11 31 May 2014 12:03 pm
Radio stops working when treble is moved ericraum General PT Cruiser Discussions 3 02 Jul 2004 05:57 pm


All times are GMT -5. The time now is 09:20 pm.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors