PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > General PT Cruiser Discussions

PT Cruiser Forum

Advertisements
A/C not runnign very cold

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 30 May 2019, 03:24 pm
Fresh Cruiser
 
Join Date: Mar 2014
Posts: 36
Default A/C not runnign very cold

So ive had this problem for a while and mostly ignored it. When I turn on my A/C I find that it does not run cold, maybe sorta cool at best. On very hot days darn near warm.

The Radiator fan is running, the compressor seems to be turning on (I can hear it), and the car is not over heating. Though maybe slightly warm. The temp gauge stays about at half way after highway travel. The freon/A/C juice is not leaking. it is full to proper level and charged.

I do find that the coolant seems to always be running low, even though I do not see any leaks.
Reply With Quote
  #2 (permalink)  
Old 30 May 2019, 03:34 pm
Veteran Cruiser
 
Join Date: Aug 2015
Location: Lake Wales, FL
Posts: 4,750
Default Re: A/C not runnign very cold

Keep that coolant topped off. Check your hose clamps and make sure they're tight. And check the over flow hose to make sure there are no holes or cracks in it, either. Have you pressure tested the system? Could be a small leak or the radiator cap is no longer holding the proper pressure.
__________________


Aspire to inspire before you expire.
Reply With Quote
  #3 (permalink)  
Old 30 May 2019, 08:04 pm
Fresh Cruiser
 
Join Date: Mar 2014
Posts: 36
Default Re: A/C not runnign very cold

Quote:
Originally Posted by chuzz View Post
Keep that coolant topped off. Check your hose clamps and make sure they're tight. And check the over flow hose to make sure there are no holes or cracks in it, either. Have you pressure tested the system? Could be a small leak or the radiator cap is no longer holding the proper pressure.
I have done none of those really. Do you recommend filling the over flow tank, or the radiator directly?
Reply With Quote
  #4 (permalink)  
Old 30 May 2019, 10:10 pm
Obsessed Cruiser
 
Join Date: Aug 2014
Location: Thousand Oaks, CA
Posts: 7,308
Default Re: A/C not runnign very cold

Are you aware there is a high and low speed on the radiator fan?
__________________
If at First You Don't Succeed - Try, Try Again
Reply With Quote
  #5 (permalink)  
Old 31 May 2019, 06:46 am
Veteran Cruiser
 
Join Date: Aug 2015
Location: Lake Wales, FL
Posts: 4,750
Default Re: A/C not runnign very cold

Quote:
Originally Posted by Mashuu View Post
I have done none of those really. Do you recommend filling the over flow tank, or the radiator directly?
I always fill the radiator directly, right up to just below the overflow hole in the filler neck. The overflow has marks on it, for high and low. I try to split the difference.
__________________


Aspire to inspire before you expire.
Reply With Quote
  #6 (permalink)  
Old 31 May 2019, 07:00 pm
RickinPA's Avatar
Cool Cruiser
 
Join Date: Jun 2014
Location: southeastern PA
Posts: 301
Default Re: A/C not runnign very cold

Regarding the A/C:

If you're sure the system has a proper charge of freon, feel the very front radiator. That's the system condenser, if operating correctly, it should be warm. The aluminum tubes on the passenger side of the engine compartment carry the freon , they, or at least one of them should be cold in operation. If not the above, I'd suspect a problem with the refrigerant system.

Check the heater / air conditioner controls on the dash. Turning the knobs, you should feel and hear a change in the air flow. If the temperature control knob does not effect a change, it could be a jammed or stuck (hot / cold air) blend door in the system (under the dash).
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Upon Cold Start in Cold Weather, Loud Noise?? paulrosenthal Tech & Performance Forum 33 01 Oct 2014 09:55 am
Hot, cold, hot, cold...I'm freezing in here!!!! Ironman Tech & Performance Forum 8 07 Dec 2010 10:51 am
don't run well when cold... yaris Tech & Performance Forum 8 21 Apr 2010 10:22 am
Cold Cold Crazy PianT General PT Cruiser Discussions 13 21 Jan 2004 11:35 pm
cold air vs. hot air ptcruz311 Tech & Performance Forum 3 22 Sep 2003 01:31 pm


All times are GMT -5. The time now is 09:29 pm.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors