PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > General PT Cruiser Discussions

PT Cruiser Forum

Advertisements
Losing battle with this car

 
Like Tree2Likes

Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 19 Jun 2019, 07:11 pm
Regular Cruiser
 
Join Date: Dec 2017
Location: Rhode Island
Posts: 155
Default Losing battle with this car

I cant find my original post.. ok guys car still wont start! This is the weird thing now.. we have the original key, the dashlights come on, but it wont crank,no sound,no horn... when you turn the key to the OFF.... the lights are still staying on! Any ideas, before I post it for parts? Im so frustrated since now well be left car less
Reply With Quote
  #2 (permalink)  
Old 19 Jun 2019, 07:42 pm
Regular Cruiser
 
Join Date: Dec 2017
Location: Rhode Island
Posts: 155
Default Re: Losing battle with this car

OK ive been looking online and thinking maybe its the ignition switch, since hubby had a hard time getting it to go all the way off before..
Reply With Quote
  #3 (permalink)  
Old 19 Jun 2019, 07:57 pm
RickinPA's Avatar
Cool Cruiser
 
Join Date: Jun 2014
Location: southeastern PA
Posts: 309
Default Re: Losing battle with this car

Sounds likely. Sounds like the ignition switch can make it to the run position, but not the start position, and hangs in the run position. Search "replacing ignition switch pt cruiser" on YouTube. There's a number of videos, which says to me it's not an uncommon problem. Although, I've never had the problem myself.

Switch replacement looks pretty straight forward. However, there is a peculiar Torx bit required. It's a "security bit" the bit has a hole in the center because the Torx screw has a pin in the center.

Last edited by RickinPA; 19 Jun 2019 at 08:01 pm.
Reply With Quote
  #4 (permalink)  
Old 19 Jun 2019, 08:07 pm
LionPT's Avatar
Veteran Cruiser
 
Join Date: May 2014
Location: Central Florida
Posts: 4,353
Default Re: Losing battle with this car

Help!! Lost keys in vent on dash!!
__________________

2006 Touring Edition in Cool Vanilla...aka/Ghost
Reply With Quote
  #5 (permalink)  
Old 19 Jun 2019, 11:53 pm
Regular Cruiser
 
Join Date: Dec 2017
Location: Rhode Island
Posts: 155
Default Re: Losing battle with this car

Quote:
Originally Posted by RickinPA View Post
Sounds likely. Sounds like the ignition switch can make it to the run position, but not the start position, and hangs in the run position. Search "replacing ignition switch pt cruiser" on YouTube. There's a number of videos, which says to me it's not an uncommon problem. Although, I've never had the problem myself.

Switch replacement looks pretty straight forward. However, there is a peculiar Torx bit required. It's a "security bit" the bit has a hole in the center because the Torx screw has a pin in the center.
Ty. He just told me when he steps on the brake the lights come on..even when it's in the "off" position.
Reply With Quote
  #6 (permalink)  
Old 20 Jun 2019, 12:20 am
Obsessed Cruiser
 
Join Date: Aug 2014
Location: Thousand Oaks, CA
Posts: 7,321
Default Re: Losing battle with this car

Quote:
Originally Posted by Oceana View Post
Ty. He just told me when he steps on the brake the lights come on..even when it's in the "off" position.
I would suggest checking to see if the ignition actuator got disconnected from the ignition switch.
__________________
If at First You Don't Succeed - Try, Try Again

Last edited by ptcruisersteve; 20 Jun 2019 at 12:32 am.
Reply With Quote
  #7 (permalink)  
Old 20 Jun 2019, 04:48 pm
RickinPA's Avatar
Cool Cruiser
 
Join Date: Jun 2014
Location: southeastern PA
Posts: 309
Default Re: Losing battle with this car

Quote:
Originally Posted by Oceana View Post
Ty. He just told me when he steps on the brake the lights come on..even when it's in the "off" position.
If you mean the brake lights on the back of the car come on (with the key off), that's normal. Brake lights are wired constantly hot, they always have been. It's a safety thing, the brake lights should work regardless of key position.
Reply With Quote
  #8 (permalink)  
Old 20 Jun 2019, 08:29 pm
rob302's Avatar
Veteran Cruiser
 
Join Date: Jul 2016
Location: Darien, IL | Forest Park, IL
Posts: 3,519
Default Re: Losing battle with this car

Quote:
Originally Posted by RickinPA View Post
Switch replacement looks pretty straight forward. However, there is a peculiar Torx bit required. It's a "security bit" the bit has a hole in the center because the Torx screw has a pin in the center.
Those pins snap off really really easy and then you can use a regular torx
__________________
.
Reply With Quote
  #9 (permalink)  
Old 21 Jun 2019, 09:06 pm
Regular Cruiser
 
Join Date: Dec 2017
Location: Rhode Island
Posts: 155
Default Re: Losing battle with this car

Quote:
Originally Posted by RickinPA View Post
If you mean the brake lights on the back of the car come on (with the key off), that's normal. Brake lights are wired constantly hot, they always have been. It's a safety thing, the brake lights should work regardless of key position.
I meant the dash lights...
Reply With Quote
  #10 (permalink)  
Old 21 Jun 2019, 09:07 pm
Regular Cruiser
 
Join Date: Dec 2017
Location: Rhode Island
Posts: 155
Default Re: Losing battle with this car

Quote:
Originally Posted by ptcruisersteve View Post
I would suggest checking to see if the ignition actuator got disconnected from the ignition switch.
Ill check into that. Thanks!
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
OK here goes the battle with the dealer who sold me the car... Dwummer General PT Cruiser Discussions 28 26 Jun 2012 12:07 am
New Battle Cruiser Added VNT General PT Cruiser Discussions 16 26 Mar 2012 07:33 am
months of battle, PLEASE HELP US thegirlwkalideoscopeyes Tech & Performance Forum 13 06 Dec 2011 08:42 pm
Battle at the Beach MB-4 RED N BLACK Southeast PT Forum 0 01 Oct 2003 06:54 pm


All times are GMT -5. The time now is 09:34 pm.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors