PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > General PT Cruiser Discussions

PT Cruiser Forum

Advertisements
LOST MY INSTRUMENT CLUSTER LIGHTS!

 
Like Tree3Likes

Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 25 Oct 2019, 02:48 pm
soonercruiser's Avatar
Obsessed Cruiser
 
Join Date: Jun 2007
Location: Oklahoma City
Posts: 7,905
Default LOST MY INSTRUMENT CLUSTER LIGHTS!

So, I was swapping out all my interior lights for LEDs, after draining the new battery from leaving the hatch ajar Tuesday for about 6 hours.

I was working on the very last bulb, the cup holder illumination....regular incandescent bulb was working....and tried in the LED ....musta been reversed polarity....NO!
Now the regular incandescent bulb won't even work! No juice!

****And, my instrument cluster is no lighting or working!
(along with the HVAC lighting not illuminating)

Since it's just not only the cluster, but also the cup light, I'm thinking fuse.
I had done a pretty good job of saving all the diagrams and charts on my computer.
Checked all the applicable fuses under the dash...Nothing!
Checked all the fuses in the PDC.....Nothing!

Any thoughts????
__________________
Frank, aka SOONERCRUISER,

2011 GWE Dodge Challenger SRT8 as Show Car
2003 PT Cruiser GT Panel Van Conversion as new day driver.

Have now owned 6 PT Cruisers = Me PT Crazy!

Last edited by soonercruiser; 25 Oct 2019 at 04:11 pm.
Reply With Quote
  #2 (permalink)  
Old 25 Oct 2019, 04:53 pm
rockandroller's Avatar
Obsessed Cruiser
 
Join Date: Feb 2013
Location: Western Canada! (Okanagan)
Posts: 8,158
Default Re: LOST MY INSTRUMENT CLUSTER LIGHTS!

hmmm... pulled a major ground wire loose, when opening something up? ( I do not have wiring diagrams handy)
soonercruiser likes this.
__________________
2004 'Turbo Lite'
Reply With Quote
  #3 (permalink)  
Old 25 Oct 2019, 07:39 pm
soonercruiser's Avatar
Obsessed Cruiser
 
Join Date: Jun 2007
Location: Oklahoma City
Posts: 7,905
Default Re: LOST MY INSTRUMENT CLUSTER LIGHTS!

Quote:
Originally Posted by rockandroller View Post
hmmm... pulled a major ground wire loose, when opening something up? ( I do not have wiring diagrams handy)
Since everything worked until I pulled the cup holder bulb.....
it would lead one to believe there is one there????


Could be I have a bad fuse that looks good a first sight.

I've read pretty much all the old "Instrument Cluster" threads, and the ones that come up on Google....with no solution so far.
I guess I can pull the center bezel, radio, and look in there for a loose wire.

Otherwise that leads to the question...WHAT GROUND WIRE being loose would cause me to loose the instrument cluster lights, HVAC lights, and the cup holder light???
__________________
Frank, aka SOONERCRUISER,

2011 GWE Dodge Challenger SRT8 as Show Car
2003 PT Cruiser GT Panel Van Conversion as new day driver.

Have now owned 6 PT Cruisers = Me PT Crazy!
Reply With Quote
  #4 (permalink)  
Old 26 Oct 2019, 07:27 am
Veteran Cruiser
 
Join Date: Aug 2015
Location: Lake Wales, FL
Posts: 4,838
Default Re: LOST MY INSTRUMENT CLUSTER LIGHTS!

I don't know if it's connected or not, Frank, but take a look at the ground on the back of the cigarette lighter or outlet on the dash or console. I don't even remember if there is one!
soonercruiser likes this.
__________________


Aspire to inspire before you expire.
Reply With Quote
  #5 (permalink)  
Old 26 Oct 2019, 11:15 am
soonercruiser's Avatar
Obsessed Cruiser
 
Join Date: Jun 2007
Location: Oklahoma City
Posts: 7,905
Default Re: LOST MY INSTRUMENT CLUSTER LIGHTS!

Quote:
Originally Posted by chuzz View Post
I don't know if it's connected or not, Frank, but take a look at the ground on the back of the cigarette lighter or outlet on the dash or console. I don't even remember if there is one!
Thanks for the idea Chuzz!

I am planning on taking out the radio and bezel and looking in there today.
But, that cig lighter/outlet is still working.
I tested it early on.
__________________
Frank, aka SOONERCRUISER,

2011 GWE Dodge Challenger SRT8 as Show Car
2003 PT Cruiser GT Panel Van Conversion as new day driver.

Have now owned 6 PT Cruisers = Me PT Crazy!
Reply With Quote
  #6 (permalink)  
Old 26 Oct 2019, 11:18 am
soonercruiser's Avatar
Obsessed Cruiser
 
Join Date: Jun 2007
Location: Oklahoma City
Posts: 7,905
Default Re: LOST MY INSTRUMENT CLUSTER LIGHTS!

Quote:
Originally Posted by rockandroller View Post
hmmm... pulled a major ground wire loose, when opening something up? ( I do not have wiring diagrams handy)
Here it is...

__________________
Frank, aka SOONERCRUISER,

2011 GWE Dodge Challenger SRT8 as Show Car
2003 PT Cruiser GT Panel Van Conversion as new day driver.

Have now owned 6 PT Cruisers = Me PT Crazy!
Reply With Quote
  #7 (permalink)  
Old 26 Oct 2019, 01:53 pm
rcktpwrd's Avatar
Senior Cruiser
 
Join Date: Jan 2011
Location: Raleigh, NC
Posts: 1,819
Cool Re: LOST MY INSTRUMENT CLUSTER LIGHTS!

Visual inspection of a fuse doesn't always show a bad one. You have to check for continuity with a meter.
LionPT likes this.
__________________
Joel

2001 PT Cruiser 5-speed; 1976 Oldsmobile Cutlass S; 1990 Chevy 454SS; 1995 Caprice Classic woody
www.rcktpwrd.com
Reply With Quote
  #8 (permalink)  
Old 26 Oct 2019, 03:37 pm
soonercruiser's Avatar
Obsessed Cruiser
 
Join Date: Jun 2007
Location: Oklahoma City
Posts: 7,905
Default Re: LOST MY INSTRUMENT CLUSTER LIGHTS!

Quote:
Originally Posted by rcktpwrd View Post
Visual inspection of a fuse doesn't always show a bad one. You have to check for continuity with a meter.
You are correct!
So, I learned to do one more thing with my multimeter; and all the concerned fuses test OK.

I just got done tearing down the center dash bezel, radio, and HVAC controls.
Everything seems OK. No special ground wires there.
Everything comes from the harnesses.
Disconnected the battery for 10 minutes, just in case.
No effect.
__________________
Frank, aka SOONERCRUISER,

2011 GWE Dodge Challenger SRT8 as Show Car
2003 PT Cruiser GT Panel Van Conversion as new day driver.

Have now owned 6 PT Cruisers = Me PT Crazy!

Last edited by soonercruiser; 26 Oct 2019 at 04:28 pm.
Reply With Quote
  #9 (permalink)  
Old 28 Oct 2019, 03:16 pm
soonercruiser's Avatar
Obsessed Cruiser
 
Join Date: Jun 2007
Location: Oklahoma City
Posts: 7,905
Red face Re: LOST MY INSTRUMENT CLUSTER LIGHTS!

So, yesterday I came out and the battery is dead again for the second time in a week.
So, I've got a short/draw down on the battery somewhere.

After jumping to start I noticed that the parking lights don't work whether one themselves, or with the headlights.
But, Signals and flashers do work fine.

At that point I was convinced that it was a short in the Multifunction switch.
Found one reasonably at Autozone.

But, That isn't the problem either.
So, I guess I will unhook the battery until I head to my fav dealer on Wednesday.
__________________
Frank, aka SOONERCRUISER,

2011 GWE Dodge Challenger SRT8 as Show Car
2003 PT Cruiser GT Panel Van Conversion as new day driver.

Have now owned 6 PT Cruisers = Me PT Crazy!
Reply With Quote
  #10 (permalink)  
Old 30 Oct 2019, 02:13 pm
soonercruiser's Avatar
Obsessed Cruiser
 
Join Date: Jun 2007
Location: Oklahoma City
Posts: 7,905
Default Re: LOST MY INSTRUMENT CLUSTER LIGHTS!

Got my dead battery (draw) and cluster lights worked out today at my fav dealer.
Rear door popper controller was drawing too much juice; even when popper solenoids are not being activated!

Instrument cluster was fuse #5!
NOT ONE I had ever seen listed as a possible source!
(Thought I checked the all; including continuity.)


Now, I have to figure out how to route the power to the door popper controller...as it now comes off the line to the interior lights, electronic door locks, and rear cargo light!

I'm thinking that I will just tap into that separate fused line to the battery for the popper solenoids; and route that thru another switch near the dash....so it is never on when I don't need it!
Somewhat inconvenient.
I will also call the company to see why the controller is drawing that much power.
__________________
Frank, aka SOONERCRUISER,

2011 GWE Dodge Challenger SRT8 as Show Car
2003 PT Cruiser GT Panel Van Conversion as new day driver.

Have now owned 6 PT Cruisers = Me PT Crazy!
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
No Instrument Cluster or overhead lights wingman55 General PT Cruiser Discussions 2 30 Jul 2017 11:01 am
Instrument cluster lights won't extinguish. NLAlston General PT Cruiser Discussions 5 15 Feb 2017 10:21 am
instrument cluster lights dim slash General PT Cruiser Discussions 0 25 Jul 2012 03:14 am
instrument panel cluster lights??? msmarvel Interior Accessories Forum 7 19 Sep 2011 06:09 pm
Instrument Cluster Lights kappa_kruiser Tech & Performance Forum 1 22 May 2008 01:03 am


All times are GMT -5. The time now is 07:20 pm.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors