PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > General PT Cruiser Discussions

PT Cruiser Forum

Advertisements
Both P0480 and P0481 Lit Up

 
Like Tree4Likes
  • 2 Post By sanatanadharma
  • 1 Post By sanatanadharma
  • 1 Post By RCSnyder

Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 26 Oct 2019, 06:38 pm
Regular Cruiser
 
Join Date: Mar 2015
Location: Liberty MO
Posts: 105
Default Both P0480 and P0481 Lit Up

Popped both codes at the same time this week on my '03 Touring. The fan isn't turning in any mode of operation. Hmmm.

My first time actually getting codes when the fan stopped working, so I do expect something different that I've seen in the past.

Anyway...

Checked the fan for low/high speed continuity and checks good. Plugged in a good spare fan and tested all modes with no luck.

Swapped in what should be good high and low speed relays and no luck. I am confident the high speed relay used is good, but cannot verify low speed replacement.

Is there a single point of failure I should be chasing. And/or would a bad low speed relay pop both codes.

And...

Maybe related, maybe not, the shift lock cable under the dash came adrift and was snagging the steering yolk on right turns when the codes popped. Cable re-secured, but it was bumping up against the steering column wire loom when it was snagging.

Thanks in advance.

Bob in Liberty
Reply With Quote
  #2 (permalink)  
Old 29 Oct 2019, 10:13 am
sanatanadharma's Avatar
Veteran Cruiser
 
Join Date: Sep 2010
Location: Walking distance to the embassy
Posts: 3,092
Default Re: Both P0480 and P0481 Lit Up

Quote:
Originally Posted by RCSnyder View Post
...
Is there a single point of failure I should be chasing. And/or would a bad low speed relay pop both codes....

Thanks in advance.

Bob in Liberty
Fuse #5 (40 amp) in the under-hood PDC (ower distribution center)
Handy_Cruiser and chuzz like this.
Reply With Quote
  #3 (permalink)  
Old 30 Oct 2019, 07:52 pm
Regular Cruiser
 
Join Date: Mar 2015
Location: Liberty MO
Posts: 105
Default Re: Both P0480 and P0481 Lit Up

I gave that fuse a visual once-over, but will recheck tomorrow. Thanks.
Reply With Quote
  #4 (permalink)  
Old 02 Nov 2019, 02:24 pm
Regular Cruiser
 
Join Date: Mar 2015
Location: Liberty MO
Posts: 105
Default Re: Both P0480 and P0481 Lit Up

Okay, so back at it today...

Fuse, grounding and relays check good. Fan runs fine when the relays are jumped, so my problem is elsewhere.

I eliminated - perhaps hastily - the fan thermostat because the temperature gauge works fine. Thoughts?

My fear is that the problem lies within the ECM itself.

Bob in Liberty
Reply With Quote
  #5 (permalink)  
Old 02 Nov 2019, 02:45 pm
sanatanadharma's Avatar
Veteran Cruiser
 
Join Date: Sep 2010
Location: Walking distance to the embassy
Posts: 3,092
Default Re: Both P0480 and P0481 Lit Up

Check fuse #12 (10 amp) in the dash fuse block.
Sorry I missed this signal-side of the circuit. Fuse #5 under the hood is the power demand side of the system (power to the fan motor).

The PCM does ground the relay signal circuits.
RCSnyder likes this.
Reply With Quote
  #6 (permalink)  
Old 02 Nov 2019, 03:45 pm
Regular Cruiser
 
Join Date: Mar 2015
Location: Liberty MO
Posts: 105
Default Re: Both P0480 and P0481 Lit Up

Bingo. That was the culprit.

With all the FAN labeled stuff out under the hood, I was a little focused where it seemed to make sense.

Whooda thunk it.

Thanks again.

Bob in Liberty
Reply With Quote
  #7 (permalink)  
Old 04 Nov 2019, 10:47 am
sanatanadharma's Avatar
Veteran Cruiser
 
Join Date: Sep 2010
Location: Walking distance to the embassy
Posts: 3,092
Default Re: Both P0480 and P0481 Lit Up

No, por favor
My pleasure

I have some knowledge of the 1st gen PT electrical system and schematics.
It is fascinatingly complex, like making correct ethical-moral-electoral decisions.

When this old-man shouts at clouds, it is usually "check the fuses".
Reply With Quote
Reply

Tags
cooling fan, p0480, p0481


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
The old fan problem...P0480 code.. Deac1234 General PT Cruiser Discussions 8 07 Jun 2018 09:27 pm
Air bag Light and code P0480 db300 General Turbo Discussions 2 01 Oct 2017 02:22 pm
'05 throwing P0480 & P0481 after AC job...? AcIdBuRn02ZTS General PT Cruiser Discussions 11 22 Jun 2017 08:43 am
P0480 need help asap 203turbopt General Turbo Discussions 7 25 Sep 2012 04:49 pm
Computer code # P0480 MINIHEMI46 General Turbo Discussions 10 17 Jul 2007 04:04 pm


All times are GMT -5. The time now is 07:09 pm.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors