PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > General PT Cruiser Discussions

PT Cruiser Forum

Advertisements
2300 rpm is all

 
Like Tree6Likes
  • 2 Post By ptcruisersteve
  • 1 Post By Handy_Cruiser
  • 3 Post By Helirich

Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 13 Jan 2020, 05:44 pm
Fresh Cruiser
 
Join Date: Sep 2015
Posts: 49
Default 2300 rpm is all

Like the title, the engine starts and runs great........till 2300 rpm. It doesn't matter if I'm in neutral or 1st, it's fine till 2300. Then it falls on its face. If I put it in drive and excellerate easy (below 2300), it will run fine through the gears and go 60 mph. But if at anytime, I push the pedal to hard and it down shifts, the R's go up to 2500 and it almost stalls. Let off the gas and slowly push, it comes back to life.

Any ideas?

BTW, non turbo 04'.
Reply With Quote
  #2 (permalink)  
Old 13 Jan 2020, 05:49 pm
Obsessed Cruiser
 
Join Date: Aug 2014
Location: Thousand Oaks, CA
Posts: 7,493
Default Re: 2300 rpm is all

Quote:
Originally Posted by Helirich View Post
Like the title, the engine starts and runs great........till 2300 rpm. It doesn't matter if I'm in neutral or 1st, it's fine till 2300. Then it falls on its face. If I put it in drive and excellerate easy (below 2300), it will run fine through the gears and go 60 mph. But if at anytime, I push the pedal to hard and it down shifts, the R's go up to 2500 and it almost stalls. Let off the gas and slowly push, it comes back to life.

Any ideas?

BTW, non turbo 04'.
I would suggest checking the wiring and contacts going to the Camshaft Sensor. If they are okay check the Camshaft Sensor.

With my two Pt Cruisers the Camshaft Sensors average about 70,000 miles before they fail.

Suggest OEM Camshaft Sensor if needed.
Carl48 and LionPT like this.
__________________
If at First You Don't Succeed - Try, Try Again

Last edited by ptcruisersteve; 13 Jan 2020 at 05:53 pm.
Reply With Quote
  #3 (permalink)  
Old 13 Jan 2020, 07:30 pm
Fresh Cruiser
 
Join Date: Sep 2015
Posts: 49
Default Re: 2300 rpm is all

Quote:
Originally Posted by ptcruisersteve View Post
I would suggest checking the wiring and contacts going to the Camshaft Sensor. If they are okay check the Camshaft Sensor.

With my two Pt Cruisers the Camshaft Sensors average about 70,000 miles before they fail.

Suggest OEM Camshaft Sensor if needed.
So if the cam sensor fails, is my symptoms a possible result? The car has lots of power up untill this point.

If it was "old school", I'd say it was the vacuum advance. With electronic ignition, I don't know.
Reply With Quote
  #4 (permalink)  
Old 13 Jan 2020, 08:08 pm
Obsessed Cruiser
 
Join Date: Aug 2014
Location: Thousand Oaks, CA
Posts: 7,493
Default Re: 2300 rpm is all

Quote:
Originally Posted by Helirich View Post
So if the cam sensor fails, is my symptoms a possible result? The car has lots of power up untill this point.

If it was "old school", I'd say it was the vacuum advance. With electronic ignition, I don't know.

The Camshaft Sensor is one of the most common replacement components on the Pt Cruiser.

If you are asking for more information on what the Camshaft Sensor does I would suggest you get the Factory Manual for your year Pt Cruiser.
__________________
If at First You Don't Succeed - Try, Try Again

Last edited by ptcruisersteve; 13 Jan 2020 at 08:12 pm.
Reply With Quote
  #5 (permalink)  
Old 14 Jan 2020, 11:43 am
rsrocket1's Avatar
Fanatic Cruiser
 
Join Date: Mar 2016
Location: Sacramento, CA
Posts: 782
Default Re: 2300 rpm is all

The camshaft position sensor is very easy to replace on the PT. It is right below the PCV hose I'm pointing at in the picture below. It makes things easier if you remove the air box but it can be done without removing it. 2 screws and 1 connector (make sure you pull out the red tab lock before disconnecting). Most recommend the OEM Chrysler sensor.

Reply With Quote
  #6 (permalink)  
Old 14 Jan 2020, 03:54 pm
Handy_Cruiser's Avatar
Obsessed Cruiser
 
Join Date: Oct 2013
Location: Arkansas
Posts: 10,657
Default Re: 2300 rpm is all

Quote:
Originally Posted by Helirich View Post
So if the cam sensor fails, is my symptoms a possible result? The car has lots of power up untill this point.

If it was "old school", I'd say it was the vacuum advance. With electronic ignition, I don't know.

On 2001/2002 PT's, camshaft position sensor failure will result in a dead engine in most cases. But in 2003 and newer PT's, the PCM (computer) will go into "Limp home mode" where the engine runs at a reduced speed under an alternate timing program that does not require the camshaft sensor to function.

When this happens, there is a 100% chance that you will have a Check Engine Light and you will have trouble code that indicates a bad camshaft position sensor. So, do you have a Check Engine Light? And if so, have you read the code and is it P0340, P0341 or P0344?
dougs likes this.
__________________

Last edited by Handy_Cruiser; 14 Jan 2020 at 04:00 pm.
Reply With Quote
  #7 (permalink)  
Old 14 Jan 2020, 07:20 pm
Fresh Cruiser
 
Join Date: Sep 2015
Posts: 49
Default Re: 2300 rpm is all

Well I did some searching and found that if the cam sensor is bad, the engine will go in "limp mode". Limp mode consists of a max rpm of 2500. So yes, the cam sensor will cause my symptoms.

Today I replaced the sensor and it now runs good.


Thanks all.
Reply With Quote
  #8 (permalink)  
Old 14 Jan 2020, 07:43 pm
Obsessed Cruiser
 
Join Date: Aug 2014
Location: Thousand Oaks, CA
Posts: 7,493
Default Re: 2300 rpm is all

Quote:
Originally Posted by Helirich View Post
Well I did some searching and found that if the cam sensor is bad, the engine will go in "limp mode". Limp mode consists of a max rpm of 2500. So yes, the cam sensor will cause my symptoms.

Today I replaced the sensor and it now runs good.


Thanks all.
Glad to hear you got your Pt Cruiser running.

I recommend keeping the Original component Camshaft Sensor for a week in case the problem comes back.Some members have found it was a wiring or contact problem.
__________________
If at First You Don't Succeed - Try, Try Again
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
runs bad at 2300 rpm on hot days cowboy888 Tech & Performance Forum 2 20 Jul 2014 04:43 pm
won't accelerate over 2300 rpms queenwasp Tech & Performance Forum 2 25 Mar 2011 06:14 pm


All times are GMT -5. The time now is 02:16 am.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors